Thrustmaster TCA Addon issues

Okay… the first thing you need to do, is to backup the Throttleconfig.ini file that you have working before. Keep it safe somewhere.

Then delete every single A32NX folder from the community and the one outside of it in the packages folder. This means, you delete both the old naming and the new flybywire folders.

After that, run the installer again, and install the Custom FBW version. This will freshly install the mod into the new folder name.

Run the sim and start a flight once, for the mod to recreate a new work folder with the new name.

Then close the sim, and just copy back the throttleconfig.ini file that you have saved before back into the new work folder with the new name in the packages. That should solve all your issues.

Whew… I need a massage for carrying this topic for so long…

1 Like

Thanks man! il give it a go. cheers for replying!

Thanks Neo, all working an back in the cockpit :wink:

Thanks Neo

And always compare with Amazon. Lately Amazon has been high though.

Aint that the truth…

Good evening.

I’ve an issue with the spoiler axis and flaps axis too.

On the configuration page of Thrustmaster, the gauge axis of the flaps and the spoilers axis are full from 0 to 3, when I’m in full position the gauge is at the half…

I tried to calibrate it but it don’t work.

What I did for the calibration :

Spoilers and flaps full and throttles reverse max

Disconnect USB-C wire

Connect USB-C wire with pressing the right black button.

Spoilers and flaps retracted and throttles TOGA, I press both red buttons
Spoilers and flaps 1 and throttles FLEX-MCT, I press both red buttons
Spoilers and flaps 2 and throttles CLB, I press both red buttons
Spoilers and flaps 3 and throttles idle, I press both red buttons
Spoilers and flaps full and throttles reverses max, I press both red buttons

I press both black buttons and disconnect and reconnect the USB-C wire.

And it didn’t work.

I move all axis at the same time, I tried many times to calibrate it but it didn’t work.

The firmware is up to date.

Anyone can help me ? I’m really disapointed…

Amazon restock yesterday, est ship on Apr. 28 thought.

When you press both black buttons, don’t hold it when you disconnect the USB cable. Just press both black buttons and hold it for 1-2 seconds. Then release the buttons. Then you disconnect the USB cable and reconnect it.

I disconnect the USB cable after realesed the black buttons.

Thrustmaster sended to me a calibration procedure for the spoilers axis and I need to validate each position by up/down gear lever.

But it didn’t work.

But the gear lever has nothing to do with the calibration. It’s not an axis.

How do you set the landing gear to goes down? I can set up to up but then i cant go down.

It’s working if you reset the profile back to default.

Hi Neo

I do not have the Throttle file and it is not creating. Can you help me how to recover the proper work of a quadrant

You have to watch this to know how the new throttle calibration works:

In the sim control options, try mapping both “set landing gear up” and “set landing gear down” to that same landing toggle switch.

(I’m using A32NX FBW custom)

Yes, this… this is what the default binding is anyway.

In fact, up/down gear lever is needed to validate each position of the switch button on the spoiler axis, like pressing both red buttons on the throttles.

Finally, I used DiView to set new axis referency and I have no problems.

I just got the TCA Addon and everything works fine except two things:

  1. How to configure the AutoBreak that should be also switched off when it reaches DISARM position?
  2. SpeedBrakes/Ground Spoilers can’t be armed, aka to pull it up?
  1. The AutoBreak currently doesn’t work with the A32NX mod. It works in the default A320. So I believe FBW is fixing it.
  2. You can arm them but you’ll have to sacrifice the Axis. So instead of binding the Spoiler axis to the spoilers lever. You unbind it. And use digital input of the virtual buttons on each detent to control the spoilers.

Spoilers Up detent = Retract Spoilers
Spoilers 1 detent = Set Auto Spoilers Arming
Spoilers 2 detent = Retract Spoilers
Spoilers 3 detent = Extend Spoilers
Spoilers full detent = Extend Spoilers

The reason why you have to do this is because if you put the spoilers into an axis, the axis position will override everything including the auto-spoilers. So if you put your spoilers in the up position and you use a spoilers arm command, even though it’s arming, it won’t deploy because your spoilers axis is feeding the sim with the retract position. That’s why we have to remove it from the axis, so that the spoilers axis position doesn’t override anything and use the digital input instead to manage the spoilers.

The only downside to this is that you can’t control on how much or how little you want to deploy the spoilers. It’s either Full Retract, or Full Deploy, with the auto-spoiler arm in between.

1 Like