Thrustmaster TCA Airbus side stick

You responded to me to say it had “no pots.” Anyway, we agree there’s a pot on the twist axis.

You should have read both lines of my post, not only the first one. :wink:

Lol, we agree, it’s all good.

1 Like

Any tips how to set the sidestick about sensitivity etc?

1 Like

Leave everything in default and if you notice something that you don’t like, adjust it.
Everyone has their own taste…

1 Like

Quote from an earlier post in this thread:

My personal preference is -50% on X and Y axis sensitivity. -75% on the Z axis sensitivity.
10% deadzone on all axis.

Hi there,

I have the Thrustmaster TCA Captain Pack Airbus Edition, I’ve recently received it. I am using it on the MSFS airbus a320. When I am trying to direct the aircraft on the ground, the rudder does not stay in the direction I want it to do so, and despite twisting the stick either left or right the pedals return to normal, and thus the aircraft will not turn properly to taxi. It appears to work on the fly by wire aircraft only, but not the pre installed a320 or others? Because I have not received any further support and because the options suggested by Flight simulator didn’t work, I decided to give up and simply return to using my thrustmaster HOTAS 4 which had previously worked perfectly. Unfortunately however the HOTAS 4 is now malfunctioning like the TCA, and I am now not able to play the game at all because the aircraft cannot be steered on the ground whilst taxiing! All this is very frustrating and I just want some help to resolve the matter I am experiencing.

Hello @Shaunycag1980,

Have you checked in the sensitivity/bindings , if the input works as expected? E.g. when you use your hardware, does the in-game axis visualization reflect this correctly.
Furthermore I would ensure, with multiple peripherals connected, that only one can control the rudder. Orherwise you may try to turn with rudder pedals, while your joystick commands no rudder/tiller.

Thank you very much for getting back to me. So I checked the “USB game controller” via the pc and the joystick is set up as it is supposed to be (sorry I am not very technical). It’s all set up I think as it should be. It’s strange as the HOTAS was working fine up until I installed the thrustmaster airbus, and now none of them steer the aircraft on the tarmac (pre installed). I don’t have the pedals so this makes it more difficult also, should I have the pedals to be able to steer with the thrustmaster airbus pack? The other strange thing is that the flyby wire a320 is okay with both joysticks, so I am guessing it’s something to do with the game? Thrustmaster have also said it sounds like an MSFS issue? I am at the end of my patience with the matter if honest, and don’t know what else to do?

Is only one peripheral, so e.g. only the Airbus sidestick connected when the issue occures?
You do not need rudder pedals. Please also go to the assistance options and put them to true to life! There is a bug that changes this setting to easy. After that make sure no ai assistance options are turned on in the toolbar on the top of your screen when you are inside the aircraft.

Thanks again for getting back to me. I have both peripherals plugged in when it does it, and the HOTAS is connected to the thrust slider so I don’t think I can remove it. When I get home I’ll try it with only one connected (the joystick) and see if it helps. I’ll also follow the steps you have suggested and see if this helps. Thank you so very much for your assistance and I’ll let you know.

1 Like

Thank you for all the advice. I finally got the issue sorted but I wouldn’t have done it without you. Thank you again for everything.

1 Like

Thank you for all your help with my last problem, I really do not think I would have resolved it without your advice. Another problem I am facing is that the aircraft is now pulling to the right upon taxi or take off on the ground and needs correction. You wouldn’t know why this is either would you? Thank you

Depending on the aircraft and how it behaves, it could be normal:

E.g. I would not expect this behavior with an normal planar takeoff with the A320.

Also check your assist settings. anything with a rudder should be disabled.

Actually setting everything to Hard/True to Life would be even better since you’ll have full control over the aircraft without the assistance features fighting against you.

1 Like

I’m using the PC version of MSFS 2020 and have the TCA Thrustmaster Airbus Captains Pack. I’ve never had this problem before and I don’t know what’s caused it but my side stick is not functioning correctly despite the profile being unchanged. For some reason the thrust increases to full power when I twist the stick left or right. Usually I’d use this to turn the aircraft on the ground or as a rudder in the air. This only occurs once I’ve used the throttle quad and applied a little power to move the aircraft forward. I also noticed that I can turn the aircraft on the ground by moving the sidestick either left or right which isn’t normal. Once airborne the stick acts in the normal manor. I’ve tried uninstalling and reinstalling as per the instructions and tried switching the profile to default but nothing seems to be correcting this issue.

Okay, first thing’s first. Check your current sidestick profile. If you are using the throttle quadrant as well, make sure you remove the Throttle axis binding on the sidestick slider. If you change it back to the default profile it will have the throttle axis bound there. So make sure you remove it.

Or better yet, check your entire sidestick profile and make sure nothing is bound to the throttle axis.

It’s probably best to just delete all your control profiles from both hardware to revert back to default. When you have the TCA Captain’s pack, make sure you start the Sidestick from a blank new profile, and start to manually bind one function at a time. But keep the Throttle quadrant profile from Default, then Duplicate that default profile. Then you can make the minor adjustments as needed.

The few golden rules to follow when it comes to MSFS:

  1. You can bind multiple function/commands to a single button/axis/switch. But never bound multiple buttons/axis/switch to a single function/command. This is coming from the collective of all your connected hardware. (eg. If you have the throttle axis bound to the throttle quadrant, remove the throttle axis from the sidestick slider, and any keyboard bindings to the throttle).
  2. Make sure you have the proper binding types matched to the correct button/switch type. Don’t use “Toggle” command on a switch like the TCA engine switch. Toggle is for buttons. Set is for switches. Axis is for sliders.

Is there a way to disable the RZAxis on the TCA.A320 joystick? It causes my screen saver to fail to trigger because it senses the RZAxis is moving… (?)


I used to have one - there was a mechanical lock on the bottom of the handle near the base - I thought that prevented the rudder axis from moving. But if the potentiometer is that shot - meaning it’s still twitching even though the stick is completely still (untouched by hand), not sure that will help. Short of mechanically removing / disabling the wiring of the pot, there’s not much you can do.