Thrustmaster topgun afterburner ff joystick makes game CTD

After connecting my thrustmaster topgun afterburner ff joystick and win10 installs the drivers automaticaly (HOTAS Force Feedback Joystick), msfs2020 loads up for a second and then CTD.
When i remove the HOTAS Force Feedback Joystick in Settings/devices msfs2020 loads up normaly.

Anyone some idea?

1 Like

I have the same issue here did you succeed to get it working?

No, i have not unfortunately. I went to the thrustmaster site and saw lots of releases of the same joystick under different names and drivers. I did not dare to install them.

I now make use of a more simpel logitech joystick i had under the cubboard somewhere.

Have the same problem. Interestingly, it also CTDs DCS on Steam - so this is not just FlightSim :frowning: The Top Gun AfterBurner has been a long time favorite!

I just plugged in my old Thrustmaster Top Gun, Forge Feedback Joystick.

MSFS crashed before the welcome screen,

If I wait to plug it in later, when in the CONTROLS menu, it recognized the Name of the Joystick (USB communication, but CTD before putting up any sort of configuration screen)

Did not even create a profile file in SystemAppData
UPSETTING – should NOT CTD !! Asobo – How about a bit of Exception handling here, and an appropriate error message.

Note: At last one currently for sale on Amazon. $130 Used – A Bargain – if it worked in MSFS

So why don’t we see ant new ForceFeedback on the general market. - PATENT TROLLS

Immersion Corp. are a patent troll and pretty much own the patent to Force Feedback apparently.

They seem to own multiple patents to multiple implementations to Force feedback, hence why they sued Microsoft/Sony back in 2002.

Some online say it expires in 2019 but I see no evidence of that?

Just tried it in FSX on same W10 PC as I have MSFS on.

No issues, works - FSX had prifoile, but could edit it. So all was good.
So not a W10 issue

After 9/29/2020, still CTD when Thrustmaster is plugged in.

Caught screen just before crash.
It had read the name of the Thrustmaster, and put up a setup screen, but then a few seconds later, it crashes.
I suspect when trying to read the Axis & Buttons available.

a CTD is BAD !! . Whatever is going wrong should be handled, and an Error Message displayed.

Chances are ASOBO do not have one of these joysticks to test with, so that would make Degugging the code a challenge.

Unfortunately, due to a patent Troll, nobody is currently marketing an inexpensive Force Feedback Joystick, so choices are limited.

Many simmers from earlier Flight Sims, have and used the Thrustmaster Force Feedback, and it would be great if MSFS at least did not CTD when they are plugged in.

Old gen Force feedback Joysticks aside, MSFS should not CTD when a USB device is plugged in !!!

It gets as far as this screenshot, but does not create the XML configuration file for this Joystick , and is probably CTD because it cannot ??

ZENDESK ticket submitted

PLEASE – Anyone with this issue , submit a ZENDESK bug report.

The more of us Thrustmaster owners that do, the more likely they are to look into it

Stesso problema