ThrustMaster Usb Joystick problems and questions. Please help!

I connected the base model by Thrustmaster, simply called Thrustmaster USB Joystick. Despite several attempts to set it up, only the thrust lever seems to work in the game, although when I set it up, all inputs seem to work.

According to the official website, this model was designed for DirectX 9 which is now obsolete. The official manual even contains a link to DirectX9 which leads to a dead web page… “We are sorry, the page you requested cannot be found. The URL may be misspelled or the page you’re looking for is no longer available.”

I hope this joystick works even with the latest DirectX version that I have installed.

It is strange that the thrust lever works fine but not the buttons or the main “sidestick”… Any ideas?

There is also a mapping guide for MSFS. Do I need to strictly adhere to that specific instruction or can I assign buttons to different functions?

go into device and settings for windows used to be in windows control panel open that and find your joystick, click on I thinks its properties button ( there are 2 of them so if its not that one its the other) and you’ll see a place to calibrate the stick, do the calibration and make sure everything is working correctly.

Now launch the game go into options controls and set the stick up there for what you want it to do. This is the way I setup my X56 stick and it worked just fine. Also when your in game setting up the stick, add just a little dead zone to your control axis throttle stick etc or some planes may have issues.

Good Luck hope this helps

BTW I would just uninstall all the Thrustmaster stuff drivers software since windows should be able to detect and use the correct drivers for you.

Device manager cheking was done. All USB devices indicate that drivers are automatically installed by Windows 10. Also, in the game, the controller indication is a joystick with a ? on it. Does it mean that the game does not recognize this model but it knows that some joystick is connected? Can’t seem to find a solution.

Does the built in Windows Utility called USB Game Controllers recognize it and show all axes and buttons? That’s step 1.

I would uninstall the thrustmaster stuff, reboot, then go into game and see if your still getting the ?
If you are, try making a new profile for the stick and see what happens then.

Not only does this utility detect and recognize the joystick but also no calibration is required. All buttons, view switch controller and stick work fine in the Test department of the app. In fact, the calibration field shows something weird. In neutral position, the stick marks the top left corner of the calibration box. It can move all around the box but when I let it go, it goes back to that spot. That initially confused me, because I saw it as an indication that calibration is needed… But that test contradicts the test field results, which show that the joystick works fine (neutral position = centre of the box) and all 4 buttons too. The same applies to the camera angle switch. Regarding drivers, the update driver button results in “best driver available has been installed”. So what could be the problem?

The only thing left is the manual’s suggested mapping. To assign each button and movement to specific functions, if it is mandatory to adhere to the manual…

Based on your comments above, the device is out of calibration, little + should be in the exact middle of that window. You might check Thrustmasters site and see if there is a new driver for device. Please NOTE - Windows Calibration/Config, will only allow the discovery of 32 physical buttons. Most modern Joysticks, and controllers, have way more than 32. I do not know much about Thrustmaster Devices. However, MSFS should see it clearly, and know what it is.

One other thing you can try, go into Device Manager, and delete all the USB ports for devices present, restart system, Windows will find and reassign those ports, maybe you got on with messed up communication.

Virpil beat that problem with a checkbox in their software that will mimic keyboard pushes, and Windows sees (if I remember correctly 256 keyboard strikes), hence I can configure all the buttons on my Virpil TM-3 Throttle to do anything I want it to do in FSX. However, MSFS-2020 and XP-11 can read up to 128 buttons, having that check box enabled can cause some movement in the cockpit unwanted. I just click my default’s view button and right back to where I need to be. Takes some getting used to, but I like FSX.

[Mapping-USBJoystick_MFS.png (1403×992) (]

I am under the impression that this particular model has no specific drivers. It works with generic drivers, downloaded from Windows 10 automatically.

ThrustMaster’s official website does not contain any link for drivers…

This is the page for my joystick… Just in case someone else had the same model with the same problems…

USB Joystick - | Thrustmaster

My Thrustmaster USB accessory isn’t recognized in the Gaming Options (or Game Controllers) section of the Control Panel, …

All I did was to follow a link in this thread for the xbox with the same joystick and had it setup rather quickly.
This is the forum . on
An this is the link to a reddit posting that solved it for me.

1 Like