Thrustmaster Warthog Throttle inaccurate operation

I have the throttle set up in MSFS, when I check the range etc I have full smooth operation from closed to full, however in game from full throttle if I start creeping the throttle back the RPM drops from full to about 2000 then either creeps back up of drops to 1500, not smooth at all, If i pull the throttle back at 1500 it can rise to 2000 plus then drop straight down, there is no smooth 1500 1400 1300 etc, more like 1500 1800 2100 1500 1100. I am a licenced aircraft engineer by trade and run these things day in day out, and no piston engine aicraft have I ever seen operate like this, I am talking the 152. 172 as none turbo and also the jets like the G-91 etc

Using the Warthog Throttle here, I would double check your control bindings, the only time I see what you’re describing is if I have more than one axis bound to the Throttle in error.

Hi. I’m having exactly the same problem. I am using a Thrustmaster Hotas Warthog and, when I move the throttle forward to open it up, the revs increase and then fall back. The more I open the throttle, the more the throttle seems to close. Raynen suggested checking to see if more than one axis is bound to the throttle in error. Is there a quick way to check for this ? also, has anyone else had the same issue and managed to solve it ? All help would be gratefully received. Many thanks, Ed

Hi Nutloose, I have just noticed your posting. I have been having the same issues with MSFS and my Thrustmaster HOTAS Warthog throttle. Did you ever get a fix that worked for your error ? all the best, Ed

Sadly no, idle and full is fine but anywhere between isn’t, reducing rpm is a none entity until it gets to idle then it goes to idle, nothing in between, there is no gradual reduction.

Hi there, many thanks for getting back to me. I think my best bet is tio contact Microsoft Support and let them remote in. It looks like many simmers are experiencing the same issues. My original installation was fine and the throttle worked perfectly. The issues that I am having now started after one of the earlier mandatory updates. If I manage to get Microsoft to own and fix the issue, I’ll post an FAQ here on the forum to help everyone in the same position as ourselves. All the best, Ed

The on/off throttle behaviour, from previous posts i’ve seen, can be caused by mapping the physical throttle axes to the wrong axis command. Not at my sim PC at the moment, but the correct axis command does NOT have “(0-100%)” in its name, so something like “Throttle Axis 1”.

Also, as suggested above, IIRC, there are also axis commands that control all of the virtual axis levers at once, so check that you don’t have that mapped to one or both of your warthog levers, as well as having the throttle 1 and throttle 2 virtual lever axis commands mapped, especially if any of the mappings is a “(0-100%)” variant.

Past updates have certainly been known to introduce changes to your control mappings, so it might be worth checking those again.

Hi Hawkmoth - I think I have solved the problem (at least on my Thrustmaster HOTAS Warthog throttle). I actually purchased a second throttle thinking that my original thgrottle was faulty. It wasn’t ! I got exactly the same problem with my throttle bouncing all over the place in MSFS when I increased / lowered my Warthog throttle. I have liased with some brilliant techs at Thrustmaster and they did all they could to help but the issue clearly isn’t a Thrustmaster hardware issue. I tried DCS, IL2 and Cliffs of Dover and they all worked perfectly with the throttle. So the issue has to be with MSFS. Then I went back and very closely looked at all my control bindings. What I found was a ‘mixture control’ binding that I hadn’t set. I deleted the mixture control binding and, as if by magic, my Thrustmaster HOTAS Warthog throttleThrustmaster HOTAS Warthog throttle is now working properly. This binding must have been set during one of the many asobo updates and clearly shows that the asobo techs are not testing their releases properly. I know that many other Thrustmaster throttle users have had the same issue and I am hoping that, by posting this message here, the fix will get to them and help them out. Regards, Ed

1 Like

Ed,

It is entirely normal that a game assigns axes to hardware control axes that it finds available at the PC. This is exactly what Raynen said 2 years ago: check your bindings. DCS, which was mentioned above, does that too. MSFS will assign the mixture to Z or Y or whatever axis and it will obviously interfer. Whenever you plug in a new hardware controller: check the hardware assignments and the first thing to do is delete them. The TDC controller is usually set to control the elevator and ailerons, obviously delete them. The zoom slider (actually friction in the A10) will have something as well.

Hi there, many thanks for your reply, yes, that makes sense. The problem I faced relates to the bindings changing after I had set them all up initially when I first installed MSFS in March 2021. The hardware itself remained the same (Thrustmaster HOTAS Warthog throttle, joystick and rudder set). MSFS ran perfectly with the bindings that I had established and tested from March to September 2021 however, somewhere down the line after October 2021, a compulsory update was released and one of the bindings that was set by the update (it looks like it was the mixture binding) created the throttle issue. Interestingly, my versions of DCS and the IL2 Battle series have retained their hardware settings over the last eighteen months even though the packages have been updated multiple times. What I have learned from the issues that I have faced with the asobo changes is to make sure that I retain an up-to-date copy of all of my stable bindings and, in the event of future problems, compare these bindings to the current ones and look for any differences. The good news is that the bindings are now stable and everything works exactly as it should which is a big relief ! Regards, Ed

So, after spending four hours trying to get the ‘ghost throttle’ issue sorted out with my Thrustmaster HOTAS Warthog throttle and Microsoft Flight Simulator 2020, I have finally identified the issue and sorted it out.

This is a Microsoft / Asobo issue and is not an issue with the Thrustmaster Throttle. Having said that, I suspect that other MSFS users using different throttles, could also experience similar issues.

The issue is caused by a setting, deep inside Microsoft Flight Simulator 2020, that provides ‘Take-off Assistance’. When this option is set (which it is by default since the update back in Mid 2021) the simulator tries to override the users throttle and some joystick movements on take-off. This forces the flight simulator to take 2 sets of input signals for the throttle.

The first signal comes from the physical throttle movement from the Thrustmaster HOTAS Warthog throttle and the second signal (the one that causes the erratic behaviour) comes from the simulator itself as it tries to override the users physical throttle settings.

The fix is really easy.

Within MSFS, navigate to OPTIONS / ASSISTANCE OPTIONS / PILOTING

Turn off ‘Assisted Takeoff’

Click ‘Apply and Save’ or F11 to save your new settings

And that is it. Everything works perfectly once this change is made.

Microsoft / Asobo either can’t or won’t acknowledge this as a serious issue but at least there is now a fully working solution to this awful controller issue.

Hopefully, this message will assist others who are having the same issues that I have experienced and, for goodness sake Microsoft, set this flag back to off on the next update and document it so that others can make a value judgement on whether or not this option is useful to them or, as in my case, a massive overhead.

Ed

1 Like

It worked for me. Thank you very much. I was tired of crashing…

1 Like

Fixed it for me too, it’s the glider tow setting.

1 Like

Hello!

Your topic has been moved into the General Discussion & Community Support category.

The Bug Reporting category is for posting suspected or confirmed bugs that other users are able to reproduce without duplicating an existing bug topic. Using the template is required in order to provide valuable information, feedback, and replication steps to our test team.

If you are not sure if your issue is a bug or need further input from the community, please use the General Discussion & Community Support category. If the community can replicate your issue, first search the Bug Reporting category to see if there’s an existing topic. If it already exists, contribute to that report. Duplicate bug reports will be closed.

If you believe it is a new report, then create a new bug topic using the provided topic template.

NOTE: All issues caused by or involving third-party addons/mods should be reported to the third-party developer. Assure that no addons/mods are used when reporting issues in Bug Reports.