Tobii 5 Eye Tracker - Stops Working in Windowed Mode (When Window Gets Minimized)

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?

Yes

Brief description of the issue:

Tobii 5 eye tracker works, except when you go from fullscreen to windowed. It stops working all together; no longer shows in peripherals.

I am able to repro this by making the sim go in Windowed mode, then minimizing the window and re-maximizing the window, then Tobii stops reacting/goes away in controller settings.

Provide Screenshot(s)/video(s) of the issue encountered:

Can’t provide screenshot, but have repro’d this several times.

Detailed steps to reproduce the issue encountered:

Ensure Tobii is working, go from fullscreen to windowed mode in settings, get back into sim – Tobii no longer responsive.

PC specs and/or peripheral set up if relevant:

i9-12900k, Windows 11, 3080 Ti


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

No problem here when switching full/windowed. But Tobii tracking can act weird at times, where it just doesn’t work (happend in SU9 and maybe before also)

1 Like

No one else w/ Tobii having intermittent issues – the sim won’t even recognize I have it some times, so I have to restart the sim and then it works fine.

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes, same issue - Tobii Eye Tracker 5 stops working after minimising/maximising in window mode and disappears from the control options

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

I do occasionally have this myself

Provide extra information to complete the original description of the issue:

Weird thing is, if I power down the Tobii and turn it back on, the sim doesn’t pick up on it like it will do other peripherals.

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

yes

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Yes

Provide extra information to complete the original description of the issue:

On occasion, going from windowed to full screen or vice versa stops Tobii from working. Only restart of the game restores it.

If relevant, provide additional screenshots/video:

1 Like

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I have exactly the same issue.

This issue is still happening. Any updates Asobo or Tobii?

I tried using Tobii and changing the Sim from Full to Windowed mode from within the settings menu, rather than using the Alt and Enter keys, did not result in a Tobii issue. It takes longer of course. So I wonder if the Alt and Enter keys are causing the problem. It also seems as if the problem is intermittent, as my last flight was faultless, while during the previous flight Tobii failed.

In Sim Update 10 beta, for me, I don’t even have to do Alt-Tab – I just minimize the window, re-maximize the window and Tobii stops working.

I have a theory, not yet tested, that if you disable tracking in the options menu or using a shortcut key and then change from Windowed to full screen and back Tobii will continue to work. I will test this later today. Whatever the cause it is annoying and Tobii is the only external MSFS hardware that has this issue so you would imagine that they would keen to resolve it and issue a fix. It’s disappointing to hear that it appears to still be a problem in the forthcoming update.