Triple monitors, one accasionally goes dark

Decided to go for 3 monitors - ViewSonic VX3268’s - and they work very well 99.9% of the time. BTW, i9-9900K, RTX-2080Super, 32GB RAM. Using the RTX’s DP ports. FPS is in the 30’s and overall looks good. Mostly High settings.

Here’s the issue: once in a fairly great while, one of the monitors goes dark for a second or two, then comes back. First time it happened it was the center monitor, now it seems to be the right monitor. I had an FHD monitor on the RTX’s HDMI port, Windows didn’t seem to mind and NVidia seemed to handle it OK. I’ve since disconnected the FHD side monitor (which I had intended to use for the pop-out instruments) so we’ll see if that changes anything. Also, I had tried installing an old GTX1050 in the same PC and while it all worked OK, that’s when my issue seemed to start (the GTX is now out of the PC). I had wanted to use the 1050 to render the instruments but since doing so didn’t change the main display’s FPS, wasn’t worth doing anyway.

Sorry for the rambling, just wondered if anyone else has encountered something like this.


make sure your dp connectors are all the way in videocards and not being hold back by pc case, otherwise lame cable or failing monitor.

1 Like

I had a similar issue recently with my GTX960, as it happens my GPU was failing. Given the cost of new GPUs now, do check all the other options before jumping to that conclusion, but keep in mind it is possible.

1 Like

Thanks for the input, guys!

Week old monitors and a year-old RTX2028 so I hope that’s not an issue! Just ran a fairly lengthy flight with the old FHD monitor disconnected and it ran flawlessly. Now if will only stay that way. Time will tell.

I made the fatal mistake the other day of doing too many things at once - new monitors for the three-way config, then added the video card to test the 4th individual monitor, upgraded the NVidia driver - won’t do THAT again! So I’ve reverted back to just the 3-monitor config with one rev back on the driver. So far so good.

For the record, one thing I did notice with the GTX and FHD monitor connected, every time I adjusted the bezel alignment, Windows would throw the FHD monitor to the right (I had moved it to the left in Windows Display). Didn’t do that when I used the RTX HDMI output. So something was getting confused.


Try backing down the refresh rate for all three, I have an older video card and three new monitors.

At 165hz plugging monitors becomes a game of Whack A Mole, 144hz one would blink as you describe and 120hz and lower all three are fine.

I am using 2 monitors, one 34in main and underneath a 23in touchscreen for instruments. At some point, I had an issue where the 22 in was going blank or turning off sporadically. In my case it turns out it was a power or mini surge issue, I had the monitors and the computer plugged into the same outlet with a basement freezer via an extension cord. After moving to a different power outlet problem went away.

I’m on a UPS so that shouldn’t be an issue…I did remove the 4th monitor (1080P) on the HDMI port and so far so good. We’ll see.

1 Like

The NVidia panel defaults to 144Hz (the ViewSonic default) - not sure if there’s a way to change the monitor itself. I can drop the rate to 120 or 60, I believe, and give it a try also.

How about VSync in the sim? On or Off? I had turned it ON to prevent tearing when I was using a 43" TV, now it doesn’t seem to make a difference either ON or OFF - ViewSonic doesn’t support it anyway (I think). At one time, as I recall VSync was to be left OFF.

I did remove the 1080P monitor on the HDMI port and so far, so good.

In the control panel where you select “span displays with surround” below it hit configure and it will take you to a second screen to select what HZ you like. It may ask you to close some programs before it will allow you to that screen, completely normal.

I hope this is not a dumb question but I can’t get any of of the MSFS cockpit to display on my extension second monitor. I can move and see the mouse across to the second screen which is just the blank blue Windows wallpaper.
If I try to move just the inset map it stays on the main monitor right hand edge.
How do you get the instruments on the second screen ?
Both monitors are connected t o the same GPU.
I thought I would be able to have a widescreen display with half the cockpit on each monitor.

Oh, I am using Air Manager for instrument panels and undock only the G1000 glass displays from MSFS and drag them to the second screen. Hold Right-Alt and click. I am not sure why you cannot drag the VFR map onto your 2nd screen, do you have Expand selected for the monitors in Windows?

Since realised I have to set up in the Graphics Card settings not just press Windows Key +P.

Managed to get MSFS on to two monitors and thought it was a very dissappointing result even though the resolution was set to 3840 x 1200 in Settings.
I couldn’t drag anything on to the vacant desktop so could not see the point of doing it.
Spent a couple of frustrating days when I suddenly found a YouTube video where the presenter said…" You must be in Windowed mode and don’t forget to drag the left and right hand edges to fill both screens."
I have not found anything on this forum saying that and it was not obvious to me that I would need to do that.

Do me a favour please and hold Right Alt while you left click on your VFR map, that should undock it and you should be able to drag it onto your “blue” area, I guess.

Have you got G-Sync enabled by any chance? Sometimes my screen blanks for a second or so when my refresh rate drops below 30fps in-game with G-Sync on.

Thanks yes you are right ! , but I have just discovered why it wouldn’t leave the main screen before.
You have to change the VFR window , top right to maximum not minimise then it can escape. One lets it go one doesnt very odd ?

Can you tell me where I would find out , is it within the Nvidea Graphics settings .
What is it supposed to do exactly

It syncs your monitor refresh rate to the display frames-per-second, say for example you’re getting 50fps your monitor will refresh at 50hz making things nice and smooth. I don’t think it worked properly in the sim in full-screen mode until a patch or two ago, I used to have to select the ‘enable for windowed & full screen mode’ but now just full screen mode seems to do the trick.

In my experience if frames drop below 30-ish my monitor will blank out for a second or so then sort itself out, unless G-Sync is set to off. Personally I can live with that and prefer the ‘smoothness’ of Gsync when it’s enabled.

Thank you…I will experiment with it .
Your reply is why I like this Forum, always something new to learn.
I spend most of my time trying to work out what all the abbreviations mean though.

You’re more than welcome.