Troubles with scenery object modeled in blender

Hello FlightSim community,

I recently started creating scenery for a local airfield. Everything seemed to be fine, I managed to include some handcrafted scenery pieces as I wanted, working around every problem on my own until today ; using the sdk editor in-game is starting to become somewhat fluid.

But, I have now started modeling a bench, and things are going not so well (it’s very frustrating even if it’s a part of the learning process).

Here is a picture of the bench :
banc-public-beton-blanc-10023176-2

As you can see here, it has holes, and that’s what causing trouble.

I have succeeded to get a decent result in blender, however, I have used a boolean modifier in order to cut the holes into the mesh itself. Because yes, that’s the only working solution i’ve found after doing some research.

Here is a picture of the bench in blender :

So, the real problem is that when imported into the sim using Asobo’s exporter, the object is a real mess.

Here is a picture of the bench into the sim…

I was really disappointed when seeing this for the first time, as everything (almost like I said earlier) worked as planned up to that moment.

- First, a texture seems to be missing even though it is present in blender (both edit and object mode, backface culling is disabled on both the bench and the boolean object making the holes).
When rotating around the object, the front faces (first to hit the camera) are the only ones being invisible. Thins is only occuring onto the part where you’re supposed to sit.

- Second, the boolean object is showing up rather than making the hole as expected. I cannot find an alternative for the holes to be directly cut through the bench’s mesh, maybe that’s the issue here.

- Third, the bench texture is applied to the boolean object
It seems that the two objects are separated from each other in blender, but the sim somehow wants them to merge together.

- And finally, when clicking the “build all” button in the project editor window, which I think is required to apply the modifications without closing and opening the simulator; the sim freezes, the console cannot open, and so the sim crashes. I do not know if the modifications can be applied without havind to build all. Maybe some of you do know ?

Any help on those problems would be really apprectiated,
Thanks !

Hi, I have been using the boolean modifier in Blender (versions 2.9 and 3.2) quite a lot and I do not think, that that in itself causes a problem. I use it for doors, windows, holes in ruined walls a.s.o.
Also the Asobo Exporter (1.1.6) - after a learning curve - gives the results I want.
A few questions, just to make sure:
On my computer, the Boolean Modifier shows the desired results in object mode, but not in edit mode. Same in your case?
On my computer, Backface Culling is checked for all objects. How does your model look like with Backface Culling checked?
The effect you see in the Sim, I sometimes see in Blender and then I know, I somehow messed up my normals and I need to recalculate them (sometimes even re-create the object from scratch - if re-calculation does not work). Have you had similar problems on the Blender side and then tried to repair something in Blender? And maybe only then created the problems in the Sim?
The Boolean object (the one that creates the hole) needs a texture, that is ok. It is displayed “inside” the main object where the hole is created (for example the door posts of a door inside a wall).
I do not know the effect of using the “build all” button. I am using the scenery editor only the place the model. For everything else, I use the fspackagetool. But I do not think that that makes a difference.
I hope this is of some help…

Try to apply your modifiers, that export them
Or
Make sure that you check the apply modifiers option in the export settings
Also, the Asobo exporter exports everything inside the object collection, so it it likely that the booleans are exported too, move them in antother collection

I have experimented a bit and found, that wrong normals (pointing inward instead of outward) can be “repaired” by creating a second problem and uncheck Backface Culling. Then you are displaying your inside as an outside.
Maybe you want give the following procedure a try:

  1. unhide all objects you use to create holes; if necessary, pull objects apart, so that you can reach all surfaces.
  2. activate Backface Culling for all objects (Bench and holes)
  3. select all / all strange looking / a single test face
  4. Press Alt+N to bring forward the Normals menue.
  5. Select"Recalculate outside" (or maybe “Flip”)
    Do things look better?
    If so, work yourself through your model until everything is fixed.
    If not, please let me know

Hello again, thank you for your replies.

First of all, concerning the normals of the bench, I followed @KrimSect 's instructions, and it seems to have corrected the problem in blender (the bench looks normal both in edit and object mode with backface culling checked, which wasn’t the case before). However, in the sim, nothing has changed.

Then, I tried @mamuDesign 's answer : checking the “apply modifiers”, removing the object from the collection, applying all changes on the objects.
Again, nothing changed in the sim.

All this makes me think that it is indeed coming from the " build all " issue, which is the only one that should still be a problem after applying all your tips.
I’m going to check out on the fspackagetool, see if anything comes out right as it should, and head back to you on this topic.

If you have anything to add, feel free to do so,
Thanks again !

It turns out that building the project via fspackagetool finally applied the changes I made to my model following both of your instructions. They are now loaded into the sim, and the bench looks perfect.

Thank you very much.

2 Likes

where can i get the fspackage tool ? I am having issues with this new Asobo MSFS exporter. It only creates an xml file, not the *.bin or the *.gltf file anymore.
anyone have any ideas about this ? I was using the old Blender2MSFSgltf exporter and this new Asobo exporter is new to me.

You can find fspackagetool after installing the SDK Core files, default installation path is C:\MSFS SDK\Tools\Bin

However, the fspackagetool has nothing to do with the missing . glTF+bin, usually is a problem during the export from Blender

Hi,
this is how I have setup my system:

ensure, you have the following two plug-ins activated (the upper one is from Asobo, the other one comes with Blender.
needed1

ensure you have de-installed (or de-activated) the old Blender2Msfs tool.

Then: I use the Blender collection to define, what’s to be exported (ks-grebenstein in this case).
needed2

and my settings are as follows:
needed3

My model does not use custom properties - I get an error when I check it
Punctual light (point light, spot light a.s.o) do not work for me so far. Missing extension error - and I do not yet know, how to make it usable / install it (MamuDesign - do you have an idea?)

But other than that it works fine for me.
needed4

@SlidHydra647449 I wrote this out as a reminder for myself hopefully this helps you out.