Troubleshooting scenery stutters on high-end hardware (RTX 4090 / 5900X / Reverb G2)

After spending time to finetune my new 4090 I have a peculiar situation: I have a perfectly smooth experience with 30 fps locked with Motion Reprojection, and about +35% overhead, but I still have random scenery stuttering every several seconds. It is especially noticeable on the background of otherwise butter-smooth flight. The intervals are random - 3 to 15 seconds between stutters usually. Stutters are modest, sometimes they feel like a dropped frame, sometimes like a “rubberband” speed-up of the scenery, but generally they feel like an interruption of a smooth motion. They are not very noticeable when looking ahead, but are quite noticeable and annoying when looking to the side and flying low. I always had them on 3080, but now I’m very puzzled, as I still have them on 4090, at least in 737 in a dense area, but even in a not so dense area they are still present.

- Do you experience them too, or is my situation more or less uncommon?

- If you were able to overcome the stutters, what helped you do that?

- Are they unavoidable or is it something peculiar with my hardware?

I have Gygabite RTX 4090 Gaming OC, Ryzen 9 5900X (liquid cooled by a 360 3-fan AIO cooler), 1250W PSU, 64Gb DDR4 RAM running at 3800. Thermals are great, everytyhing runs cool. I run a mild rock-stable overclock, but when I was troubleshooting the stutters earlier I did test on stock speeds and it made no difference whatsoever. Win10, latest OpenXR runtime and OpenXR Toolkit - no scaling, FFR Quality/Wide only, 100% TAA, 100 OpenXR Developer Tool resolution, Motion Reprojection on “always on”, locked at 30 in OXRTK (tried unlocked too). 4090 gets it rock-stable in 30 fps MR (sometimes at 45 fps MR) even in 737 over Manhatten in dense clouds. My settings are mostly high, Clouds Ultra, Rolling Cache off (also run for a while with cache on a RamDrive). HAGS off, SMT off, resizeable bar enabled and verified, latest drivers. MSFS is on a fast 2Gb NVMe SSD. Beta SU11, but same problem was present in SU10. Frametimes are around 22ms CPU / 22ms GPU in a dense area.

I don’t know what else to try. It’s almost perfect but the graphic flow is disrupted by those microstutters…I thought it’s my hardware before, but now it definitely isn’t. Needless to say, Half-Life Alyx and anything else I throw at it is all perfectly smooth. Sorry for another stutter thread, but I think I’ve exhausted everything I knew that could help. Maybe I’m missing something, and the community wisdom can point me to a solution…


Hi @RomanDesign

Sorry to hear about the micro stutters that are ruining an otherwise perfect experience. I have a suggestion, and my apologies if you’ve already tried it.

Have you tried setting a maximum FPS cap in Nvidia control panel (e.g. 45 FPS) for MSFS?

I know you’ve mentioned in other threads that you prefer the highest FPS as possible but perhaps it’s worth a try (if you haven’t already done so) just to see if it removes the stutters.

I use an RTX 3070 and found that a constantly fluctuating FPS was a big contributing factor towards stuttering on my machine. I capped mine to 36 FPS (I use a Quest 2 at 72HZ) to ensure my PC could always reliably generate the same number of frames every second.

If you’re using a Reverb G2, then try 45 FPS as a cap to begin with, and if that removes the stutters, slowly increase the FPS cap until the stutters begin to appear.

Note - you have to restart the sim every time you change the FPS cap in nvidia control panel.

Follow-up edit: in addition to capping the FPS in nvidia control panel, it’s also worth setting the same cap in the openxr toolkit menu (if using the toolkit).



I’ve been capping the frames in OpenXR Toolkit, which can do it on the fly, without restart. It was helping a bit prior to the last few OpenXR runtime updates, but lately I don’t see any difference. I’ve try flying unlocked just to see how often I can hit 45 fps MR, but generally I tried the normal 30 fps lock, but it makes no difference, unfortunately. Thanks for the advice though, I welcome any ideas, even obvious once - just in case I forgot or missed any, or maybe another factor masked a possible solution at the time I was trying it…

1 Like

I’m glad to read about this, I fly vr with G2 and a 3090, a 4090 is coming soon, I fly the wonderful fs2020 in vr with helicopters, since the beginning of fs2020 this is a problem that has always been there, except for a small period of time between one update and another.

I only remember a long time ago that in one of the updates of fs2020, I don’t remember his number, this problem mysteriously disappeared, I was very happy and I thought that Asobo had already managed to find the solution.

But no !!!, some time later, with a new update, the problem returned and has been there ever since.

I describe the problem, I am flying with the H145, with the Bell47, Cessna152, and my frames are perfect, 35/40/45fps (Oxr Toolkit + Ffr quality), if I am looking straight ahead, the experience is incredible and very smooth, it seems real !!!, but, at the moment that I look from the sides of the aircraft towards the terrain, the terrain passes before my eyes as choppy, with small jumps, as if the Fs2020 IS NOT ABLE to draw the terrain in a side view smoothly and evenly. (Assetto Corsa, driving an F1 Ferrari at 300 km/h, with 20 opponents on the track, I look at my sides at 300 km/h and everything is perfect !!!)

It also happens, with the helicopter, when making a sudden maneuver in the air, where it falls to the side and turns quickly, the simulator is not able to draw the scene without producing micro-cuts and small jumps.

The most surprising thing is that it does not happen due to lack of frames or lack of power, when I suffer microcuts, my fps go to 35/40/45 without a problem.

With my 2080ti it happened to me, with my 3090 it happened to me and with my future 4090, IT WILL ALSO HAPPEN. SURE !!!

I have never enjoyed a correct side vision experience, except very early in the Fs2020 launch, I thought they had fixed the problem forever, but the joy was short-lived, in the next update, they messed it up again.

(I9 12900kf, 32 ram ddr5, Asus 3090 Oc, updated W10, HP Reverb G2, Opxr Toolkit, always flying in vr, never on monitor).

1 Like

If you are using NVIDIA experience, get rid of it.

I had these rubber-banding stutters every 30 seconds. This was the cause for me.

Makes no sense, as my overlay was disabled but glad it is fixed.

Got rid of it long time ago… I also make a clean install of every new NVidia driver, and I use a clean Win10 partition for MSFS (and other games / VR) on a separate drive, so it doesn’t have any unnecessary apps and processes running.

Yes, you described it perfectly: stutters looking sideways while maintaing high fps. It seems no matter how much money you throw into MSFS rig - it’s never perfect…

1 Like

i don’t experience them (4090/i7 7700K@4.5/32GB@3600)

see above

who knows? that’s msfs for you (unpredictable). i know you use MR, but have you tried using msfs without MR to see if the stutters still happen (i know it won’t be “smooth” enough for u, it’s just an experiment to see if it still stutters)?

1 Like

-Do you experience them too, or is my situation more or less uncommon?
Yep - sometimes more, sometimes less. Sometimes it’s more or less constant (about 1 stutter per second), sometimes much more intermittent. The weird thing is that only the scenery seems to stutter, everything else like head movement and plane motion seems perfectly smooth. As if the thread that is processing the sce ery motion (assuming there is a dedicated one) is not able to keep up.

- If you were able to overcome the stutters, what helped you do that?
Nothing so far, though I have noticed that it seems to be better with less complex aircraft (eg, stock 172 vs JF Arrow), which supports my suspicion that it’s CPU related (8700k OCed).

- Are they unavoidable or is it something peculiar with my hardware
I didn’t used to get them pre SU7 or 8 I think. No idea what changed. I do believe it’s CPU related though.

What headset are you using?

pimax 8KX and quest 2

Interesting idea, I’ll try that.

Yes, exactly.

The 5900X requires very low RAM latency but with 64GB DDR4 you increase it unnecessarily. 32GB should be more than enough and bring the latency down a lot.

On top of that the 4090 with DDR4 ram and a 5900X might simply be too fast.

Interesting. I can try taking out 2 out of 4 modules. Not sure though how it would decrease latency… My ram is overclocked from 3200 to 3800 at the expense of increased timings. I think it’s supposed to run at 3600/16 XMP. maybe i can put it back to stock too see if it helps…

Here’s my original 64Gb overclocked to 3800 benchmark results:
And here’s the same with XMP profile (3600):
So overclocking decreases latency, but the XMP profile decreases L3 Cache latency, while increaseing L1 and L2 a bit. Interesting. I then took out 2 modules, leaving 32Gb and here’s what I got:
Basically same latency as 64Gb, but a much better L3 Cache latency. Almost 70% lower, however the speeds are tiny bit lower too. Interesting why memory would affect L3 Cache, but I’m sure there’s a reason. I 'll test it in MSFS and see if threre’s any improvement. Supposedly L3 Cache is a big deal for gaming.

I got the same problem with Asus TUF OC RTX 4090, 5900X, 64 GB RAM 4000MHz, NVMe SSD. I did not try VR yet, but those stutters are happening constantly, no matter if I have 50 FPS or 100FPS with frame generation. I can also hear the coils and every time it stutters the whistling stops for the moment.


Mostly they are generally caused by another app I have running in the background. The worst offender is file explorer, which often induces stutters every few seconds with whatever it is doing with file indexing, and closing that usually cures the stutters. Next can be Firefox, especially if I have many tabs open and one has recently played a video.

I have also found that I get pretty much no stuttering if I enter VR on the world map before I click Fly for the first time.

Also, as I am using Win 11 22H2, I have to kill the HolographicShell log process just once after starting Windows then WMR.

Doing these three things keep me stutter free in VR.

1 Like

What version of Windows are you using? I am on 22h2.

My problem is similar to others with respect to stutters in that they occur in frequently every 2 to 4 seconds typically. When I plot frametimes, these stutters are more like a pause with a very slow frametime. The reason that we notice them looking out the side window is that viewpoint is the most difficult for scenery and not the cockpit is that in 20 msec for example, a given close object on the ground will appear to move laterally a lot more than it would if it were up front of us where it simply slowly grows in size. Actually I am pretty impressed with that motion re-projection works as well as it does. And if we can ever get rid of these long stutters, we will be able to operate much closer to higher FPS values and stay with smooth, fluid imagery

My last experiments today were with the 32Gb RAM taken out, and trying to load the GPU as much as possible while remaining steadily within 30 fps MR locked, so to be GPU-limited, as it’s supposed to help. I tried OpenXR Development tool resolugion of 125%, and 150%, however 150% results in CTD, as well as 150% in-game resolution with 100% OXR. 125% may be a bit better, the jury is still out. I also disabled FFR in OXRTK, and upped some GPU-relevant settings. I think now on 100% or 125% resolution the stutters seem to be less pronounced, but they are definitely not eliminated. I did see a bit of a smoother ride though.

What coils?

I also enter VR on the world map, and keep all the background apps under control or with CPU affinity set to 4 last cores. I’m on Win10, tried killing that process but I see no improvment, unfortunately… But I will revisit all running processes and see what else I can ■■■■ down, or set CPU affinity to, it’s been a while and maybe there’s something I missed.

Win10, whatever the last version is, I think it’s 21H2.

He’s talking about GPU coil whine, a high pitched or scratchy sound given off by the voltage inductors in the GPU. It’s very common in GPUs and is noticeable on the latest Asus Tuf 4090 cards.

GPU coil whine video