Try Turning HT off on the core with your main thread is on

I’ve played around with performance for years in Flight Simulators.
I haven’t exhaustively tested this yet but my initial impression
is that by turning Hyper-threading off in the bios for the core that
runs MSFS main thread, performance improves a little for those
who are really pushing their system.

In my case i9 10900K @ 5.2ghz MSFS 2020 puts the main thread on logical core 20.
I’ve noticed that on approach to KJFK for example that core can get up to 80% + usage.
while logical core 19 is at 20 to 30% and I can see an FPS hit in that the FPS drops below
my target of 24fps to 20 or 21. Enough to brake the immersion of an otherwise glassy smooth
sim experience.

However, I’ve found turning of hyper threading on the 10th physical core (core9) reducing the number of logical cores from 20 to 19 has somewhat mitigated this. The main thread is now 19. I still see up to 80%+ usage now on Logical core 19 and 20 to 30% or so on Logical core 18. The FPS as I have observed still takes a little hit dropping below 24fps in the same scenario but its less severe.

How are you getting such a low frame rate on a 10900K to begin with? LOD way above 4?

You have a point. I could run the sim at 30fps on the same setting (everything is maxed out) and up until approach or in a translucent cloud layer I’d see 30fps but then on approach into KJFK or KORD or KLAX etc. in interesting weather on approach after the outer marker I’d start getting some stutters and look to see the FPS hitting the low 20’s. I find the smoothness the same for 30fps or 24fps so I use 24fps all the time and virtually never see FPS lower than 24fps

For me I turn off the Virtualisation technology in the BIOS but I kept the HT enabled on my i9-9900K.

Things could change with DirectX-12… theading more balanced, more cores involved.

1 Like

Moved to #self-service:pc-hardware

They aren’t rewriting the game just adding an API.

Why? The .exe is controlled by MS anyway so I don’t see the need!

Here is an illustration on approach to JFK. The system quite easily maintains 30fps until short final and then the FPS starts to dip below 30 and the stutters begin. Even so sometimes the FPS is below 24 but with my refresh rate set to 23hz the approach is much smoother at 24fps than it is at 30fps. In this instance I have HT off on core 10 only but looking at the usage of logical cores 18 and 19 I’d say my casual observation that performance is a bit better on the approach into the likes of KJFK, KLAX with HT off on the last core is reasonable but I acknowledge it could be placebo. If I recall correctly visualization technology is also off. This was just upload so its not 4K yet:

First of all, turn off in-game Vsync. This may net you a few frames depending on certain situations, and reduce the stuttering when FPS < 30 that seems to be quite significant based on your video. Instead, enable Fast Vysnc in the Nvidia Control Panel and limit your framerate to 30 fps in the control panel as well.

Also, set offscreen terrain pre-caching to ultra if you haven’t already. There’s no reason your 3090 can’t run that. The stuttering you get when panning reminds me when the pre-caching wasn’t an option.

Second, use HWInfo and find which is your best core as defined by the hardware. You’ll see a series of numbers ranked from 1-10. Try turning off HT on your best few cores, but most importantly, your #1 ranked core. I will be honest, I’m not convinced turning off HT is particularly useful. You may manage to squeeze out an extra frame per second because of reduced heat going through one thread instead of two, but I do not think it’s worth your time or effort.



I just turn it off completely, 8 physical cores are fine for gaming.

I think even 6 cores would be fine?

I’ll try using Vsync = Fast in NCP instead of in game Vsync and see if that makes a difference.

Just to conclude, I’ve found the solution for my system. I know one doesn’t have to run MSFS with all the graphics setting at the top but since in virtually every scenario I can and maintain 30fps why not. However the caveat is and has always been in Microsoft Flight Simulator (FSX, P3D) that the FPS hit comes on the approach into the destination airport. MSFS 2020 is no exception. As a result of this I’ve found that a refresh rate of 23hz (actually in reality that is much closer to 24hz something like 23.97hz) works best with flight sim. There is a Judder issue at that refresh rate but my Samsung 4KTV does a superb job of eliminating the Judder so as to make it look like the FPS is frankly over 60fps so long as one doesn’t Pan above a certain rate which is slow and requires TrackIR tweaks and some training of the head. This prevides the same smoothness on the approach at 23hz and my system can deliver in every other phase of flight at 30hz (29.97hz). It crossed my him back in the days when I was using P3D that if I could find a way to use a keyboard short cut to switch from 23hz to 30hz and back again I could have the best of both worlds. I couldn’t find a simple way of doing this and eventually gave up on it. BUT today I found a simple way of doing it using an app called HRC - Hotkey Resolution Changer V2.1 which has in fact been around since 2012. The result are fantastic. I get to fly the entire flight at a liquid smooth 30fps and more than satisfactory panning rates and then as soon as I see signs of trouble on short final I hit Shift-2 and my refresh rate is switched from 30hz to 24hz. I get a momentary black screen (half a second) and land with the same stutter free smooth experience I enjoyed in the rest of the flight.

So here’s a short video of what I see when I hit the hotkey. I cannot capture the smoothness in the video since the refresh literally changes on the fly from 30hz to 24hz but I can witness that in the sim its a huge improvement for me for me:

24hz?! No thanks. We’re supposed to progress Not regress.


G-Sync and FreeSync automatically match the refresh rate to the FPS rate. However, supported monitors are more expensive because of the additional hardware. TNSTAAFL

I’ve been casually interested in flight sim starting about 40 years ago and have been a disciple of the top flight sim performance guru’s and THE top Flight Sim performance guru. I have a top shelf system with a i9 10900K at 5.2ghz on all cores and RTX 3090. I’ve periodically had a top shelf system for the last 20+ years. I’ve posted flight sim performance related videos on youtube that have had up to 40K views with comments suggesting that seasoned viewers have had their chin on the floor watching them. I honestly have to say that if one of the simmers criticizing my approach where to stand in front of my display and see what is presented at 23hz they would have a panic attack! Enough said! LOL!

Turned HT off completely. I see no benefit with it on at all, and lots of extra heat.

1 Like

I wonder if we’ll ever get to see frame interpolation because with latency hardly an issue I would think MSFS is made for it … and maybe it could even reduce server load.

Back to the subject. If all you do is simming then turning off hyperthreading is fine for eight core systems however anything lower and it may lead to problems with e.g. spatial sound and of course rendering video and some other editing tasks will take twice as long. For Ryzen turning off cores is another option as it still switches between all of them but with the same limitations. I would never recommend disabling physical cores of a non thermally dynamic cpu as this will only shorten its lifespan.

This has been my experience as well. It seems as though I do pickup a couple of FPS with it off as well.

We’ll, I’m not suggesting turning of any physical cores. My suggestion is to turn off hyperthreading on one core only. The core with the main thread. Since the original post there are a few other things I’ve done that have helped with stutters. Stutters that are not caused by FPS drop below the refresh rate. This is not the only cause of stutters. In my case turning game mod off, Hardware Accelerated GPU scheduling off. And under Properties for FightSimulator.exe compatibility tab disable full screen optimization and Overide high DPI scaling behaviour and Select Application for ‘scaling performed by’. Then just ‘prefer maximum performance’ in NCP. Not my own observations. They came from Q8Pilot youtube channel “Complete Settings Guide with Tweaks and Tips” uploaded in May this year. It appears they work for me.

I have no temperature issues at all on my system with HT on. One Last thing. I use a Samsung 4KTV for display and it has a built in Judder Reduction filter which I use on full. I figure this is done by frame interpolation but I don’t know. 24fps looks better with the judder reduction filter on than 60fps looks with it off. That’s the best way I can describe it. Can’t be captured by video. It also works at 50hz which I use for Sim racing and there is no lag in either FS or Sim racing. The goal posts get moved again tomorrow. I certainly look forward to more improvement. This Flight Sim continues to amaze me! :grin: