Turning off Volumetric Shadows improves FPS

Good afternoon, without any encouragement to extend myself, tinkering with UserCfg.opt, I have found that by disabling volumetric clouds (it cannot be disabled in the game options), the increase in FPS is drastic, especially in 4K. The file is located in the LOCALCACHE folder (MS version, steam version is in roaming).

I know that disabling this function visually is a bummer, but what can we do? :slight_smile:

I have also touched other functions within the file, which visually I did not like (basically what you do not like you put a 0).

Here is my raw config, if someone needs it:

Version 66
{Video
Adapter “NVIDIA GeForce GTX 1080 Ti”
Monitor 0
Windowed 1
FullscreenBorderless 1
Resolution 3840 2160
FullScreenResolution 3840 2160
PrimaryScaling 1.000000
SecondaryScaling 1.000000
VSync 0
HDR10 1
PosX 0
PosY 0
}
{Graphics
Version 1.1.0
Preset Custom
{Texture
MaxAnisotropy 16
Quality 0
}
{SuperSampling
SuperSampling 2
}
{Terrain
LoDFactor 1.500000
}
{ObjectsLoD
LoDFactor 1.500000
}
{Shadows
MaxSliceCount 4
Size 2048
MaxDist 10000.000000
DLightContributionCullingThresholdS0 0.050000
DLightContributionCullingThresholdS1 0.050000
DLightContributionCullingThresholdS2 0.050000
DLightContributionCullingThresholdS3 0.050000
OmniContributionCullingThreshold 0.010000
}
{HeightFieldShadows
Enabled 1
Size 1024
}
{SSRaytracedShadows
Enabled 1
Quality 2
}
{Water
FFTSize 256
}
{VolumetricClouds
Enabled 1
Quality 2
}
{VolumetricLights
Enabled 0
Quality 1
}
{LightShafts
Enabled 0
Quality 3
}
{SSR
Enabled 0
HalfRes 1
Quality 1
}
{WindShield
Quality 2
}
{SSAO
Enabled 1
Quality 1
}
{SSSSS
Enabled 0
Quality 2
}
{AA
Enabled 1
Type 2
Quality 3
}
{Bloom
Enabled 1
Quality 2
}
{DOF
Enabled 0
Quality 0
}
{Buildings
Enabled 1
Quality 2
}
{VegetationLarge
Enabled 1
Quality 2
}
{VegetationSmall
Enabled 1
Quality 2
}
{TextureSynthesis
Quality 2
}
{PostProcess
Enabled 1
EyeAdaptation 1
ColorGrading 1
Sharpen 1
Fringe 0
LensDistortion 1
Dirt 0
LensFlare 0
FilmGrain 0
Vignette 0
LensBlurMultiplier 1.000000
FringeMultiplier 1.000000
}
{VectorDataTessellation
Enabled 1
Quality 3
}
}

Cheers!

I forgot to add, with Vol. shadows on i get 40-42fps overall in 4k, but with V.S. off i reach 58-62fps.

Core i9 9900k 5,0 OC
32GB DDR4 4000 18-18-18-39
SSD
1080Ti

OMEN EMPERIUM 64.5 G-SYNC HDR BFGD.

1 Like

Maybe put up screenshots before and after?

Hard to judge if it’s worth it. Let’s be honest, 40fps is alot more than we got back when FSX was released, so…

as i said, i have no intention to extend myself,
or seek any prominence, nor do I intend to waste your time (my apologies if this sounds cold). Is up to you to try it.

Also you could try it by disabling it in Dev Mode (i have realized about it, now)

Ok…

Off:

On:

P.S. Enable Bloom, for Bright Sun :slight_smile:

Its a flight sim… you only need 40 FPS… and if you need more why running 4K on an old 1080TI ?

2 Likes

To be honest, I don’t know what to answer to that question.

Well he is right, like you have a brand new CPU and 32GIG RAM and a 3 year old GPU. Also the game doesn’t utilize all the cores on our CPUs… It’s pretty poorly optimized. So no matter what you do you won’t get better FPS… that’s why everyone even with high end rigs are getting 45-60 fps.

I have i7-9700k, 32GIG RAM, 2070 Super and get 45-60 fps in 1440p. 60 fps when im at high altitude. And Noted I’m on medium preset. If I go to High it’s 35-45 with some huge stutters. Also I have Vsync OFF and the game is still locked at 60 fps and won’t go over. So I don’t know what the deal there is.

Also I wanted to add my FPS issues aren’t from the clouds because I use LIVE Weathers and after my first flight the LIVE weather is broken and just has clear skies, I have to restart the game every time to get the live weather to work again.

Hello what settings in the UserCFG,opt do I adjust please? @CodenameJack447

You could disable fringe (chromatic aberration), Vignette, , filmgrain, Dirt, SSSSS, SSR, LightShafts, and VolumetricLights.

The game should look more crisp and not so overwhelmed by Fx, and maybe it improved a bit fps, but is more related to visuals.

It’s a matter of likings… for example i feel more confortable with textures looking less blurry.

1 Like

so… by basically disabling clouds you get better fps? That’s great and all, but clouds do matter don’t they?

It could be a great tip for low spec systems and later on VR tho! great find :smiley:

1 Like

Mine do use the 8 cores I have, but all pc’s are different. CPU pretty old I7-6700, but running good.

1 Like

The truth is, that my real time live weather is working despite other people reporting not functioning properly (as you can see from the captures), but the fact is, that even putting it without clouds on the horizon, the fps do not rise in the same way that if I disabled volumetric clouds completely. Which makes me think that the game keep calculating those that are more on the horizon or behind the plane and that we don’t really see.

Visually they matter for the immersive experience, but there are also people who connect at night to play because they work during the day, and prefer to put a daytime in the game with fake weather.

I’m running HT of because of power saving and heat reduction. Also i don’t notice difference with HT on:

That’s interesting. I’m running a Ryzen 3900X with 32GB Ram and 1080ti but also running the game off an NVME drive and get very little stuttering in 1440p in ultra settings except in New York when doing a bank roll. I think storage drive plays a big role in it. I get around 25-50fps. Tells me the game isn’t CPU bound.

I’m going to say those “stutters” I’m getting is the streaming happening… otherwise it’s fine.

Please note I’m not complaining at all. 45-60 FPS is fine for me. The game is fun, although there are some issue like the LIVE weather for ME, and last night was having ATC issues, but I’m expecting that stuff will be fixed over time so I’m not worried about it.