Turtle Beach Velocity One - Toggle Cursor

Hi, Looking for some help if possible. I got my Velocity one today and everything is working fie apart from ‘Toggle Cursor’. I cannot get this to work, the only way I can get the cursor to work is to have my normal xbox controller on to move about.

I’ve tried with the default profile and made sure that in the control settings it’s selected as ‘Default’ and it still doesn’t work.
Has anyone else had this issue? I’m running the latest beta of MSFS so I wonder if it’s that causing issues.

Ok after further testing this issue isn’t just in because I’m running the latest beta. I have two Xbox’s, one running the last release and one running the beta. Toggle cursor does not work on either of them. I’ve tried to remap the button but it doesn’t work. I’ve tried to use different profiles and it still doesn’t work.

I’ve also found that if I have the velocity one connected when starting the xbox running the beta it instantly crashes the sim after about 10 seconds of launching it.

I’ve raised a support ticket for the issue

1 Like

So my raised ticket is now showing as ‘Resolved’ but no explanation how to resolve the issue or what was solved.

1 Like

You may wish to check out this FAQ section on what the status means:

  • New: The bug report is in the queue and hasn’t been handled yet.
  • Open: You updated the bug report.
  • Awaiting your reply: Our team contacted you to request more information and is waiting for your reply.
  • Solved/Closed: The bug report has been handled and escalated to our internal bug tracker—Our QA team will then review the information and try to reproduce the issue thanks to the information you provided.
1 Like

I just got my TBVO controller last week and I use PC, I can’t say thats an issue, but I’m having so much trouble binding the thrusters. I’m using default with is fine it keeps me flying , but I can’t bind the other 3 levers and any of the buttons below the thrusters. Great system though eh? I had a thurstmaster before this and this thing is epic compared to TM.

Have you watched the setup guide by Simhanger on YouTube. I recommend it if you haven’t, this may help you with your issues

yeah I have seen a few vids on this. I still couldn’t do it. I know eventually I will get it, for now I’m ok I’m able to fly and enjoy it but obviously I would prefer to use all the buttons and levers the way they were meant to be used. Thank you

Have the same problem & also tried several mapping solutions with no success. Having to use my Xbox controller is not just an inconvenience, it is causing conflicts and other issues and making it very difficult to successfully complete a flight. For example, when I try to set the altitude or VSI there seems to be a signal coming from one or the other that increases the altitude at a high rate and can’t be stopped or sent in the other direction. If left untouched it just keeps increasing & increasing. I can use the B button to time it and to deselect but once I select again it starts shooting uo, never decreasing. I hooked up a game pad and mapped two keyboard keys to cockpit input increase and decrease and if I exit ot of the controllers’s selection of the bug or knob I can use the mapped game pad cockpit decrease key to adjust it down. Until we get a cursor and ability to select items the Velocity One can’t be a stand alone yoke device and that’s going to seriously hurt its utility to me. I’m comparing it and the TM Boeing package and other than this am really liking the velocity one so hope they can fix it. I can be patient on the status indicator lights working but they need to get the cursor working asap. Thanks for making the ticket.


They Resolved to ignore it? Lol that’s nuts. Are you going to reopen it? I’m sure lots of folks will discover it’s a bigger deal than they think. I originally thought using the Xbox controller in combination would not be a problem but it is. Lots of conflicts & problems that make using the AP nearly impossible due to
problems adjusting anything like heading, altitude,vsi, as controller & VO together lead to this rapid increase in any selected value using a controller stick

I have the same problem and it gets me frustrated…

1 Like

Did this get resolved?

Unfortunately not

Greetings Irma


I follow the flight training and in one of the topics of naviagtion you have to start the stopwatch. I am using the velocity one Yoke of turtle beach (default settings) but I can’t find the way I can start the stopwatch. can someone help me?

Thanks a lot! Irma

Received mine today, the issue is still there, it’s pretty mich unusable. Any fix ideas?

Received my Velocity One flight yoke a few weeks back, appears to be a great product and I still have high expectations, but am currently disappointed in the Toggle Cursor bug that others have experienced.

I’m able to trigger the (default) button (B1) - Cursor Toggle and enter the Toolbar/Cursor mode, however, the POV-1 does NOT work to allow for cursor movement. The nice instructional Quick Flight Guide that is included with the product clearly states that the POV1 is dual-use for Quickview Change and Cursor.

The POV1 is mapped to quickview functions for viewing. I tried to re-map POV1 to perform cursor control and created a new Velocity One controller profile (a copy from the default) within XBox FlightSim, however the POV1 still performed the default quick viewing functions. Not surprised, though, I did get a warning upon remapping that the POV was shared and already mapped. My next experiment will be to try remapping the POV to be used exclusively for cursor control. That is not a real solution however, since we would be losing the Quick views. The bug appears to be related to the DUAL use nature of POV1. It is only working for the Quickview use and not working for Cursor control. In my opinion, this is where the developers need to focus.

Alternate experiment I’m planning is to attach a Microsoft wireless mouse to my Xbox and have it sit alongside the yoke (not ideal, but a possible workaround) for cursor mode controls.

Worst case is the current case for me, which is to use the standard Xbox controller for cursor controls. The controller’s Left Stick dual use appears to work while using Velocity One, but certainly not what I expected after the amount spent on the yoke.

1 Like

Yep still not fixed for me and it’s very annoying as this should work out of the box!!

1 Like

Just punched a few hours with my new Velocity One and am having this problem. Very frustrating.

Has anybody had any luck with a fix?

I plugged my velocity one in this weekend and it’s now working as expected. I’m on the latest beta on XBOX.

My yoke broke so I returned my unit and had it replaced. I still find cursor mode is finicky. Sometimes you can’t move the cursor w Right Stick and even when it does work - the right stick not only moves the cursor but still does the ‘quick look’ moves with the camera so your pov is flying around (no pun intended)

1 Like