Turtle beach VelocityOne yoke problem

Hi Guys, I am trying to sort out my problem with Turtle Beach VelocityOne with Microsoft Simulator support and anyone had/having problems with yoke at pushing & pulling….I have been contacted with Simulator support and ask me to put on this form to ask if anyone having same issue like me? I’ve also been in contact with turtle beach as well and no one knows how to fix the problem…and I would much appreciate if you do have same and please let us know? As they seem to think it just me…I’ve try to add video but won’t let me :pensive:
Many regards

If you’re on PC you can check the calibration in window, you’ll be able to see all the axis and buttons in operation (just Google Joystick calibration). Having returned a VF1 for refunded I say it’s probably the yoke and not the sim.

Hi Tony, yeah have done all that and including training setting on itself…

Dear members. Need some help regarding TB velocity yolk. I dropped it from standing height, since then the aileron axis and rudder triggers are not detected by MSFS and yolk itself. I ran the TB recovery tool, it reverted the firmware to older version so i updated it again to V1.4.0, nothing improved, every other button and axis is working. out of curiosity i opened it up see if anything is broken. everything seems intact and all wires are connected. i don’t know what part is actually damaged. is there anything I can do about or is it going straight to the bin. please comment. Thanks you.

Have you tried reverting back to the default bindings in the yoke, throttle body and MSFS? Make sure all 3 are set to the same.

The center point of the yoke sticking is a well documented issue on the TBV1. It is not an issue with the sim but the yoke hardware. On Turtle Beach’s web site it recommends to wipe the metal yoke stem with a paper towel and over time it should get better. After 6 months it has not really improved much on my TBV1 yoke :frowning_face:.

There is a calibration of the entire yoke and throttle body controls that you can find on the Turtle Beach web site. It won’t help with the yoke sticking but will help if it is not centered properly on its axis.

1 Like

Please tell me how to do that. I think that might solve my issue. Thanks

1 Like

This YouTube video will walk you through the process of setting things up properly. The pertinent part starts at the 1 min 32 sec point.

(3) Getting Started with VelocityOne Flight by Turtle Beach’s Dev Team - YouTube

Happy Flying!

1 Like

Hi WingWarper1,
Sorry for delay getting back
Every time I talk about to turtle beach and Flight Microsoft they haven’t got clue what wrong and saying it TB or FS….I never experienced this problems last year until there was update on the game….I keep telling FS that it their game need sorted and update the problem….no end answer :disappointed::disappointed:

I’m having the same issue but mine seems to be a conflict with my HF8 haptic pad. The yoke will move forward and backward on screen with no issue. As soon as I apply any power which leads to the haptic pad vibrating, the yoke will move forward or backward but then immediately return itself to centre. I’ve tried a powered USB hub as I thought it might be a power issue but still gettting the same issue.

Managed to solve my issue, unplugged my thrustmaster hardware which has stopped this issue happening. Sharing in case it helps.

Hi guys, I have managed to solve the problem, I have decided to get different controllers which I’ve got thurstmaster now and still having problem….inwas thinking is it game or Xbox S it self! So in the end, my wife brought me NEW Xbox X and problem has disappeared!! So it could be Xbox Microsoft console is the problem :roll_eyes: but weird thing is they can’t detect it :man_shrugging:t2:

Hi, when installing my brand new Velocity One Yoke and I remarked that the shaft is permanently pushed all the way backwards. I mean I can push it forward but when I release the pressure there is something inside that pushes it all the way back. Impossible to fly with it.
Good news is that I got a refund but before disposing of the yoke I would like to check if there is a way to fix this problem. Any idea ?
Thank you by advance,