Two screens showing in Oculus Quest 2

I’ve read others having the same problem but didn’t find a solution posted. I’m got MSFS with wired Oculus Quest 2 headset. Running Virtual Desktop Steamer and Virtual Desktop on the Oculus, and I’ve assigned the keys for activating VR. My monitor switches to split screen but the headset is also showing the split screen view and I can’t get the headset to actually be a VR experience. I’m close to getting it but after several hours of searching and trying I’m out of ideas.

Please share suggestions. Thanks!

Sounds like you are remaining in the Desktop mode rather than VR mode - Have you tried bringing up the VD menu (menu button on the left Quest 2 controller) and selecting “Switch to VR”?

Thanks for the quick reply, but I’m not finding the Switch to VR mode with the Oculus left menu button. It pulls up a big list of settings, including the computer I’m attached to. The only VR button in that screen is “Launch Steam VR” which brings up a couple games on my computer that must allow VR.

For your info most people tend to find it easier to get it running with the Oculus link software, especially as you mention you are wired already. I used link for a long time then switched to virtual desktop due to a couple of extra features (mainly gamma adjustment being possible).

For virtual desktop my next suggestion would be ensuring that your OpenXR is correctly pointing at your SteamVR:

-Open the registry editor (search regedit on your taskbar)
-Browse to
-Change ActiveRuntime to
C:\Program Files (x86)\Steam\steamapps\common\SteamVR\steamxr_win64.json (or wherever your SteamVR is installed)

Hopefully this will make the “Switch to VR” button appear in the Virtual Desktop menu, just below “Launch Steam VR”

Thank you…I’m close. After getting awhole bunch of errors and program shutdowns, the Switch to VR final showed up and the MSFS views on the monitor was responding to moving the headset. Only problem is the goggles were black…I could hear the sound of the plane but nothing visual. I ordered another headset cable since this one keeps getting a message that it’s not plugged into USB 3.0, when it is, so something is a miss.

If there is something else I should check in the meantime to get video going please let me know. I’m getting back into “real” flying and MSFS is proving to be very helpful with maneuvers and landings.

Thank you so much!

Hmm. Virtual Desktop doesn’t require or use the USB cable at all, it connects to your PC wirelessly via your WiFi. This means network configuration can be a further cause of issues which is why I mentioned that most people instead find it easier to use the standard Oculus software and the USB cable, at least to start with.

Ignoring MSFS, Do other Steam VR games work in Virtual Desktop? If you don’t have other games, does the Steam home environment at least load correctly when you click “Launch Steam VR”?

If you have Virtual Desktop (VD):

  1. Open Oculus software on PC. Show Advanced Settings. Click Developer tab. Make sure VR Runtime is set to Steam VR.

  2. Launch Steam VR in VD. When you see aurora, you are in VR.

  3. On PC launch FS. At menu toggle VR. It should be that easy!

When you switch back and activate the VR in Flight Simulator you have to let Virtual Desktop know that you are in VR mode, otherwise you indeed will see a split screen in your Oculus Quest 2.

If you press on the menu button on the Oculus controler (not the oculus button) you will see options from Virtual Desktop. Here is a button called “switch to VR”. Then you are in full VR mode :wink:

You don’t have to use an USB cable.

I was under the blind assumption that if my computer wasn’t wired to the router I had to use the USB cable. Never even tried with out it. I see it works.
Now on to the newest problem…For the registry edit there was a subfolder labeled “1” under the C:\Program Files (x86)\Steam\steamapps\common\SteamVR\ That is where I edited the runtime, since there was no runtime listing under StreamVR.

Now when I hit the key assigned to get MSFS into VR it comes up with >Error: The initialization of VR failed. Please check that OpenXR is installed on your computer and your headset can use it.

Do I need to uninstall and then reinstall something. I’m baffled why
this is so difficult.

this is a very common issue. If you search on this forum you will find the anwser.

GxM42, thanks for the info but when I open the Oculus software on the PC there are no Advanced Settings. There is Settings, but that has Account, Privacy, Payment, General, and Beta listed. I didn’t find any advanced settings or anywhere to set VR Runtime to Steam VR.

You can change the setting on the beta tab.

Great. I’m so, so close. The googles are connecting, I can switch MSFS to VR mode. In the Virtual Desktop within the googles I get all the options for VR/Desktop/etc… The last bit is when I switch the Virtual Desktop into VR mode the google display goes blank. Moving my head moves the plane in MSFS on the monitor but the googles are blank.

When I launch Steam VR on the desktop I can go into Display VR View and everything is fine and responsive.

Is there one last setting I need? After all these hours it’s exciting to be this close.

Assuming you have Virtual Desktop properly installed, here is my procedure to use VR for FS2020.

  1. Insure OpenXR is set to Steam.
  2. Start Fs2020 on PC.
  3. While FS is loading, put on headset and start Virtual Desktop and connect to your PC.
  4. Click the left controller menu button, and select Launch SteamVR.
  5. Once you have FS loaded and your plane is on runway, press Ctrl-tab to enter VR.
  6. Computer screen and headset should show split screen.
  7. Using left controller menu button, Start VR.
  8. Adjust seat location then press Spacebar.

I have found that if you don’t launch steam vr and let FS do it for you when you ctrl-tab that I ended up with desktop theater mode. Also, when using left controller menu button, sometimes you need to do a short press and sometimes a long press to see those Launch Steam VR and Start VR options. You may also need the View Desktop option when navigating menus in FS.

Hope this helps. I spent hours nailing this down for my setup.

When you go in Virtual Desktop and Launch Steam VR and switch to VR mode, make sure you see the aurora view to confirm you are in VR view. You can do this before FS even starts. If you aren’t seeing this, then something is not connecting. Again, make sure that SteamVR is still set as the runtime because I think it can get changed sometimes.

I presume you have tried pressing the keys to switch back out of VR, and then switch back in?

I only mention this because for the last month or so, when I am running virtual desktop and first press the keys switch to VR in flight sim, it fails on the first attempt and I see a weird image in the headset (not a fully black screen, but a black screen with a glitched image of the cockpit). I believe this is because it is automatically booting up Steam VR in the background, and indeed for the remainder of the session switching in and out works fine. However I note others have advised you to manually launch SteamVR which may avoid this issue anyway.

Otherwise, as mentioned in my previous post it would be good to know that VD works for you in other games so we know that your issue is MSFS specific ?

I got it to work! I started over and uninstalled Steam. Then on the install I did the regedit again (verifying carefully the install location). And after several attempts I could finally use the googles. I think the components are now in place and I need to follow a specific sequence as mentioned by OldeManToad.
It is quite an amazing VR experience as I’m trying to master the landing attitude and speeds for a Cessna 172. Sorting this out will save a bunch in rental expense of the real thing.
Hopefully I can repeat my previous success.
Thank you so much for the patience and help.

Great ! Now it is working one very good tweak we are lucky to be able to do in virtual desktop settings is adjust the gamma (brightness) down, the sim is too bright and there is no other way to adjust brightness on the quest. Happy flying

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.