Typhoon Eurofighter spontaneous rolling on Autopilot

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting. NO ADD-ONS

Are you using Developer Mode or made changes in it? NO DEV MODE

Brief description of the issue:
THE AIRCRAFT ROCKS BACK AND FORTH WHILE IN AUTOPILOT.

Provide Screenshot(s)/video(s) of the issue encountered: VID BELOW

Detail steps to reproduce the issue encountered:
JUST BRING IT UP TO 20,000FT TURN ON AUTOPILOT AND WAIT. WHEN IT STARTS, TURN OFF AUTOPILOT AND IT STOPS.

PC specs for those who want to assist (if not entered in your profile)
CURRENT:
Edition Windows 10 Home
Version 20H2
Installed on ‎8/‎16/‎2020
OS build 19042.746
Experience Windows Feature Experience Pack 120.2212.551.0
NVIDIA GEFORCE RTX 2060
Device name DESKTOP-GFI7AOU
Processor Intel® Core™ i7-7700 CPU @ 3.60GHz 3.60 GHz
Installed RAM 16.0 GB
Device ID A26DF92A-2953-4A60-809F-4E1389569983
Product ID 00325-96075-74108-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display


Did you submit this to Zendesk? If so, what is your ticket #? NOT YET

This is the wrong section of the forum for this post.

  1. Autopilot rocking back and forth is a fairly well known issue with lots of posts in the forum on it.
  2. It is not for third party addons.
    The moderators are quite strict in that regards.

Having said that, try these steps.
If this thread gets closed, repost in the Third Party Add-on section.

With the sim running, if you are on the start up screen, from the top heading, select “Options”, or if you are already in the sim, press “ESC” on the keyboard.

  • Under “General”
    Set “Flight Model” to “Modern”, not “Legacy”.
  • Under “Assists”
    Set all “Piloting” assists to “Off”
  • When you are in the sim, from the “winged” sim icon, Open AI Control (icon to the right of the yoke icon), and ensure that “Control Aircraft” is “Off” (button placed to the left).
  • Next, and quite important, is to add deadzones to each axis for all your controllers. Approximately 5% should be enough, but there have been instances where significantly more was needed.

Do not assume, even if you know how you had these already set, ensure these are this way now.
The last few updates did change some user settings.

This section is dedicated to bugs & issues for the core sim (not mods or 3rd party content)