Unable to capture glideslope on ILS approach

When flying ILS approach (APR mode armed with white GS indication) the glideslope doesn’t capture. I’ve tried several times at Heathrow EGLL, Charles de Gaulle CDG and Peachtree-Dekalb KPDK with both C172 G1000 and BBG36 G1000, and have been successful at capturing glideslope only twice, but not sure what I did differently. Is this a known issue with the game?

Besides flying at the correct altitude, distance, course and heading, are there specific airspeed limits for capturing glideslope? Just wondering if I’m flying too fast and that’s why I’m not able to capture GS.

My WT CJ4 used to capture the Glide Slope 100 % of the time.

It has stopped.
There was another thread about this.

No knows why but seem to think it is pilot error.

1 Like

In those aircraft that shouldn’t impact your ability to capture the GS, just how aggressively it will pitch down to follow it after. As far as what’s wrong, will start with the basic troubleshooting, is the correct frequency set in Nav1 or Nav2 and the CDI set to Nav1/Nav2 accordingly?

Check your assist settings. Make sure your landing assists are turned off, they interfere with the ILS glideslope capture.

I’ve attached a snapshot at the moment glideslope should have been captured with APR armed and ready, but fails.
Flying to KPDK, Jeppesen & FAA charts shown.

1 Like

The WT CJ4 is capturing Glide Slope as of today.

I don’t know why it started.

Previously today (4/22/2021), I installed the Hot Fix and other download from
MS Store but don’t think that would affect this.

What airport and runway did you fly into? Let’s see if it works for me.

Looking at the approach I see two things.


CHAMB is the fix to intercept 6.2 DME at 2900asl.

You are 6.5NM out at 2950 but showing 29.92, is that the correct setting? If the altimeter is wrong you will have issues hitting your altitude targets.

More importantly you have not captured the localizer. You are still in heading mode.
image
The glideslope won’t engage if the localizer isn’t captured. Even handflying an ILS it is a NO-NO to descend prior to centering the localizer.

1 Like

My test flight is from KJFK to KEWR (Newark, NJ).

The Flight Plan is KJFK (RW 31R) to AGNSS. VERDE, TALTE to KEWR (RW 22R).

Flying 3,000ft per Plan and ATC instuctions. Some times ATC will request 2,500 ft.
If I don’t lower it, ATC will cancel the IFR flight.

I actually crossed 6.2 DME to PDK as well with no effect. The FAA chart states 2900’ minimum intercept altitude, and 29.92 is the correct setting for the airport per ATIS. I guess the question then becomes why is the localizer not capturing?

Have bad ILS captures lately, puke.

I have a thought, I see you don’t have the approach loaded in your flight plan. I would think that should not matter on G1000 units, but have seen stranger things happen in MSFS.

Edit: Nope, that works fine still.

Edit2: Just flew the approach to KPDK a few times, was successful using various different methods. If you haven’t already done so empty your community folder, otherwise try re-installing the aircraft using the Content Manager.

I cleared the liveries and all content from the community folder except for a folder named AFC_Bridge which is for the Honeycomb peripherals, but still no luck. I’m not sure if I can delete that folder.

I’m glad you tried the same route and showed it works. I’ll keep trying. Hoping for a miracle here.

Do me a favor and try flying the ILS without the full procedure.

Set up your radios with the correct frequency and fly using HDG/ALT. Do a 45 degree intercept with APR armed at 2800ft and around 10NM out. Let’s see if you get a LOC capture. Don’t make a manual turn to final. The AP should capture the LOC and make the turn. If it just blows on through then something else is going on.

If you capture LOC then let it follow the localizer until you either see the GS indicate you are too high or it captures. Don’t descend unless you capture the GS.

Flew armed on a 160 deg heading at 2800 ft ~10 DME and still no capture

May not be right, but i will go from HDG to NAV mode first, to capture localiser. Looks liked you’re still in HDG mode.

1 Like

Everything looks correctly setup there, at this point my best guess is either some kind of unusual hardware conflict or corrupted installation.

I tested that earlier, it will capture IPDK perfectly fine from HDG mode.

Try without the honeycomb bridge. It is the only thing that may be interfering, that you haven’t already killed.
You may lose the functionality of the honeycomb panel but at least you will know if that is the issue.

tick another box…

Deleted the AFC_Bridge folder and lost only the Bravo panel lights functionality. Tried several times, direct approach and 45 deg intercept from either side, both 2900’ and 2800’, and still no luck with LOC/GS capture. On the bright side my descent skills have greatly improved.

1 Like

it’s absolutely awful I either dont capture at all or land on the taxiways, since the introduction of “World updates” it’s been useless, I’ve complained many times to no avail, they should be concentrating on the flying aspect’s first not just trying to make the scenery look great, which it does but it’s soul destroying to fly from London to KJFK approx. 7.5 hrs. only to find you cannot land, it is exactly going the same way as FSX NOWHERE