Unable to click or change with the mouse

And… in my excitement I dropped my Rift and cracked one of the screens. FFS

Hello everyone, this is my first post here - I just bought a VR helmet, mainly for MFS. Same issue here (I can interact with cockpit gauges, but no ‘click’ on the panels) - Reverb G2 and MFS via Steam… kinda frustrating :confused:

Moderator Edit:
Hello, since the last update, the mouse pointer disappears as soon as I put on the REVERB G2 headset and the floating windows remain in the middle of the view. Unable to move it. Control + 0 only rotates the view 90°

Bonjour, depuis la dernière MAJ, le pointeur de la souris disparait dès que je mets le casque REVERB G2 et les fenêtres flottantes restent au milieu de la vue. Impossible de la déplacer. Control + 0 ne fait que tourner la vue de 90°

I can interact with the menus once I hit Ctrl+0 but I can’t interact with any of the controls. They turn blue when I hover over them but do nothing when I click them. I’ve also tried with my VR controllers, but they don’t do anything either. If it weren’t for my button box, I wouldn’t be able to fly at all.
This started with the last update. It’s been weeks now without a peep from Asobo or MS.

1 Like

As stated above, this is where clicking the Auto Pilot (AP) button on off worked for me. I’m not inexperienced with FS and my problem wasn’t that the aircraft was “just on Auto Pilot”. Somehow, this issue was actually reset something in the mouse control configs, via that onscreen VR button.

Does it work if you use a keyboard number row Crtl+ 0 instead and not Ctrl + numberpad 0?

In my opinion there are two possible solutions:

a) Pressing the key combination Ctrl+0 (in my opinion, the combinations Ctrl+1 to Ctrl+9 also work). For some, the menu could then be used permanently with the mouse.
With me the operation worked then only once. Afterwards the same problem was there again, until pressing Ctrl+0 again. In addition the seat position shifts then likewise.

b) Setting in the Sim menu “General options”, “Camera” “Home cockpit mode”=“ON”.

After that I could use the menu permanently.
Unfortunately, you then catch other problems, such as the seat position, which is then sometimes not correct.
Also, at times I could no longer start or end the VR mode via a key combination. Sometimes it works, sometimes not.
Remedy: You can start and end the VR mode in the main menu.

I have the same problem (also REVERB G2) since the last update.

This is a joke. How can they leave their customers “grounded” for weeks with no clear timeline to solve the issue. It’s ridiculous.

Try a right-click on the mouse when the left-click doesn’t work. It does a quick zoom but may also restore function… YMMV

SInce Update i have Mouse not working when trying to move or interact the map in VR . Without VR everything okay. In VR Map stays in middel of the wieuv , cant interact with map. THis worked fine in the past . What is this now ? Are the Basics getting worse after each update ?

I mean ...  PLEEEEEASE   let those BAAAAAASIC Issues get fixed before other things !!!  camon....

Cant Fly without beeing able to look at map Dont want to switch back to desktop each time i need to.

Same problem here (cannot manipulate floating panels, namely VFR Map, OBjectives, and Navplan, in VR with the mouse) since the last two updates. I have been grounded and used to enjoy simming nearly every day. This has broken my setup, and I am unable to fly in VR (which is ALL i fly in)…

WTH is the issue here, and WTH isn’t it fixed yesterday???

3 Likes

OK.
Professionals don’t take weeks off around “holidays”. You take a day off here and there, and you stagger your crew.

  • List item

I have this same issue. Haven’t flown in a while but have a few days off work and was excited to fly… alas, I can’t interact with any of the menus once flying in VR. I can interact with the cockpit fine.

Also seems like the window “loses focus” regularly.

Works for me :wink:

All the aircraft supplied by MSFS need improvements to the control links to make them more easily operable either with the mouse or with oculus controllers. I guess this will happen in time. Meantime finding VR just incredible.

1 Like

Hi,
Don’t work my picture up ?

This was by the far the most frustrating issue with SU7.

Good News, this along with a bunch of other things have been fixed in the public Beta release that was released in December. While the beta is not perfect for everyone, its a great step in having a smooth flight.
Ctr + 1 didnt really work for me, so I jumped in and joined the beta, and I am glad I did.
Having a blast in VR (G2 3070 12700, oxr 100 rs 100 nis 75 sharp 50)

There are a couple of simple steps to join the Beta, then download, install and enjoy.
Hope this Helps

:grinning: Hi, i fixed this problem :
Go to the X-BOX App, select FS (not the play now button !), and look for an Update-option just below the label-picture (in blue area) … You will find this option only here, because it is not offered as update-option while start-up of FS … If You could find, close FS (when open) and run the Update … this will solve Your problem … :grinning:
In addition I solved flickering-problems in VR by changing from DX 11 to DX 12 (Beta) in the grafic-optiones in FS … You will have to restart FS as You will be told … have a happy flight ! :grinning: