Unable to click or change with the mouse

I am having issues with the mouse in VR. The pointer is follow focus ing my movements but clicking or changing settings like altitude do not work. If I right click to zoom it works on the second or third attempt and then I can interact again but then loses again.
It seems like the mouse is losing focus with the FS2020 window.
Anyone else have this issue?


I’ve had it on a couple of occasions but returning to the main menu and restarting the flight appears to resolve the issue. I have however had to completely quit out on a couple of occasions.


This happened to me only when MSFS window was minimized to taskbar. Maximizing the window back to desktop will bring mouse back.

I’m happy to have found this topic but sad that the issue has not been resolved.

I’ve had this mouse issue since the last update (WU4). At times during the flight I can move the mouse cursor but cannot click or interact with the desired switch, dial or menu item. I can usually get it to work by trying a few other cockpit switches until it eventually “comes to life” and I can use it as normal. This happens frequently during nearly every flight I have taken since the update.

At first I thought it might be a bluetooth issue since I had just recently bought a bluetooth mouse. But when I switched off the bluetooth mouse and returned to my USB mouse I continued to have the same problem.

I’m using a Reverb G2, by the way.


I have same thing going here too, usually i get rid off it by clicking twice right mouse button.

I have found that the mouse causes bad stuttering, which I can get rid of by several clicks, left or right until the stuttering stops but then the mouse isn’t visible in the headset (HTC Vive Cosmos Elite).

Do any of you have developer mode on? I found that causing all my problems. My mouse would be hung up on the menu bar and thus not clicking in cockpit.


I am having this issue too. I can use the mouse in VR to select anything in the menu. I can also use it to select the menu at the top whilst in flight e.g. weather and I can use it to select ATC responses, But I can’t change any dials, buttons or switches.

Can anyone help?



I have a multi-monitor setup and the sim is running on just one monitor. When I am in VR (which is most of the time) I can’t tell if the mouse somehow is over on a different monitor. It does not happen often but if I move the mouse around to get it back to my main monitor, it seems to return.

Somewhat same issue. Mouse pointer pauses while moving, and stops responding to inputs.

If I lift the HMD, the pointer moves fine across the 2D screen, but can see it pausing & stuttering in the VR window.

Rift S, no Developer mode. Started after SU5. I filed a Zendesk ticket, I hope everyone else who has posted here has filed a ticket as well. Unfortunately these forums are not followed by MS nor Asobo.


Similar but “inverted” issue - mouse can interact with switches, dials etc, but can not move floating windows (ATC responses etc.). Very annoying as ATC panel sits right between my viewpoint and outside view. Landings thus almost impossible - have to use external view.

The only floating panel I can interact is the very first one one where I click yellow “start flying” (or similar) button.


forgot: started with recent mandatory update - before everything was working OK.
Using Oculus Quest 2.

Try hitting cntl+0

Also hitting this - latest MSFS 2020 update, can’t move any floating windows or interact with menu bar, but can interact w/ cockpit controls with mouse.

1 Like

+1 same issue

Tried it. No visible effect.

Thanks Habukabeast for the idea. Went to Controls and found keyboard commands for showing/hiding floating windows. They work OK.

For reference:

  • ATC window: Scroll Lock
  • Checklist: Shift + c
  • menu bar: Tab

The main problem persists - mouse does not interact with menu bar or floating windows. More precise: hovering mouse pointer over floating window buttons or menu bar buttons does highlight them but button press does not have effect.
At least I can hide the floating windows now… however i would like to rearrange them around the cockpit to have them handy for interaction. Can’t do that without mouse.

CTRL-0 doesn’t work with Oculus from what I can tell.

Doesn’t work with my Reverb G2 and Steam delivered US version either.

Also tried a clean install. No effect.
Writing this to help others save time - took me A LONG TIME to DL 120GB to a SMR HDD :frowning: