Unable to exit to desktop if VR has been activated

:wave: Thank you using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Brief description of the issue:

Using a Reverb G2 . If a VR sessions is activated quitting to the desk top results in the app being minimized with the “quit “dialog still displayed in the windows preview window (mouse over it) the only way to shut down the app is an End Task with the Task Manager

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

launch MSFS

  • Start a flight
  • activate VR using a reverb g2 / windows mixed reality portal
    Return to the main menu
    Exit to the desktop and confirm
    MSFS disappears but the running icon is still present in the task bar

Note this behaviour happens regardless if VR is deactivated first.

PC specs and/or peripheral set up if relevant:

Reverb G2
Windows 11 using Windows Mixed Reality Portal. It is unclear if the same behaviour happens on a Quest 2/ virtual desktop setup

Build Version # when you first started experiencing this issue:

SIM update 7 I believe

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

I hate to state the obvious, but have you tried Alt+F4?

Yes … tried everything I could think of … it’s still alive but inaccessible

same, also G2. Everytime after i was in VR i have to Taskmanager kill the Game

Just wanted to chime in and say I have the same problem as well with a G2. This only seems to happen after using VR in the sim. If MSFS is launched and VR is never used, it will quit completely without having to use the task manager.

Yes this is correct, just did a clean install to try and resolve. Sim closes fine if G2 hasn’t been used, hangs otherwise and requires manual termination of sim