Unable to hide yoke in VR mode

I think the suspance you put on that is great…but do to the fact that this is not a Tarantino’s movies forum…could you please be more explicit? Thanks a lot in advance!

After the latest update I couldn’t interact with the cockpit via the mouse, but I found a setting called Legacy Interaction (I think) but I’m not at the sim so I don’t recall where that setting was. Everything works perfectly now.

For some reason I decided to try the tutorials in VR the other day and I was stuck at the very first tutorial in the game asking you to hide your yoke by clicking on it :joy:
It shows how much QA goes into this game

Since the latest update 1.21.13.0 I experience 3 issue which may be caused by the same bug.

One is that you cannot hide the yoke.

The second is the toolbar issue: I can activate the toolbar by pressing the tab-key on the keyboard, highlight the icons by moving the mouse pointer over it, but no window pops up, when I press the left mouse button. (https://flightsimulator.zendesk.com/hc/en-us/articles/360016027399-KNOWN-ISSUES-Last-update-July-27-2021-)

The third issue is, that in a bush trip I cannot move or remove the popup windows “Navigation” and “VFR-Map”. In the Navigation-window it is not possible to scroll or any other action is possible. I reported this problem already to the Zendesk. (https://flightsimulator.zendesk.com/hc/en-us/requests/135387)

Did anyone else experience the last issue? My current work around is to switch off the Navigation-window and the VFR-Map with the corresponding keys “N” and “V” on the keyboard and to read the navigation instructions by toggling between VR-Mode and 2D-Mode. But if I toggle too often, the system becomes instable, stucks or crashes.

1 Like

ctrl-0 (Instrument View 10) makes the windows and the toolbar controlable again. This does not work for planes which make use of “Instrument View 10” (e.g. Cessna Grand Caravan EX). The yoke still can not be hidden.

Update on not being able to “hide the yoke” while in VR mode:
https://forums.flightsimulator.com/t/cessna-172-52-yoke-control-wheel-has-no-visibility-toggle/479652/4

1 Like

Makes sense. If you use the VR Controller to grab the Yoke, you can’t hide it at the same time.
But they could have used another button just for this, like a new bind called “Yoke Visibility Toggle”.
It could have been that simple…

1 Like

Right.
Of course it is essential, as long as the controls of the VR equipment are used. But those of us who don’t use them, should be able to hide or show them.

Why not make it possible to select which controllers you want to use? For reasons stated above I would like to disable VR-controllers most of the time…

2 Likes

Still not resolved. Worked up to update 6… Neither beta or full release of 7 resolved. @Asobo… ETA, by chance?

See above, there’s nothing to “resolve” as it’s a design decision, a ridiculous one yes but with zero communication as to why we can only guess.

Disable it in Desktop Mode, then jump into VR. Should be hidden.

That’s the worst excuse I’ve seen in a LONG time. Hiding the yoke in VR worked flawlessly for a YEAR but now all of a sudden it’s a necessary “design” decision. Ridiculous! Fix this please!

1 Like

I mobility impaired. I do all of my computing from within VR.

It would be best if I could just jump into VR and Fully operate the SIM from there. I must not be the only person who has disabilities that would find this technical deletion difficult? Jumping in and out of VR, for me requires someone to help. Should I expect to have my nurse sit and watch me play just in case I need to jump in and out of VR to re hide the yoke every time I go to change planes or something like that?

1 Like

I was just trying to help.

While I agree a more customizable start-up, in your case “in VR Mode, with yoke hidden” would be ideal, just start a flight and hide the yoke prior to entering VR Mode. There shouldn’t be a need to “jump in and out” of anything.

Yes. Can be done with the mouse. Go into General Options, then Accessibility. Set The Cockpit Interaction System to Legacy. After that, you can click with the mouse on the yoke to make it visible or invisible.

It also works without the legacy mode, at least in SU 8 beta.
But impossible to do it with the VR controller.

1 Like

It doesn’t work here, no way to hide Yoke in VR at the moment.

Not many in the right mind would use the beta. There are already too many bugs in the normal version.

1 Like

Thank you, N582TC… I appreciate your trying to help. Fact is, I got used to doing something and it works just the way I like it, and then have the feature taken away. It was a real bummer. Anyway, it seems my (our) pleas have been heard, and it’s been reintroduced in Beta 8. I’m excited about it. But I found the last couple of times I tried to use it. I get a CTD. Too tired to work on it anymore tonight. Let’s see how it does tomorrow with fresh windows restart and go at it again.

Cheers.
J.