Unable to launch FS2020 ---> Store

I suffered the same issue this morning, so I was very happy to quickly find this very efficient fix ! Thanks much for your support !

Thank you HC4Lif3

it worked and FS2020 is starting finally.
Thank you for your help.

Thanks Scott. The issue is closed for me. The OP, however, seems to have given up (Unable to launch FS2020 ---> Store - #17 by Fly83130).

It doesn´t work for me. Does anybody have another idea?

1 Like

Thank you very much. This also helped me a lot.
But strange enough how such an error occurs all by a sudden.

I did the manipulation without success over fs 2020 for 2 days

1 Like

I did the manipulation without success more fs 2020 for 2 days

Thank you!

Open Registry Editor

Go to HKEY_LOCAL_MACHINE → SYSTEM → CurrentControlSet → Services

Remove the GamingServices and GamingServices.Net

Restart Computer


1 Like

Thanks a lot. This worked great for me.

Great thank you it worked for me too :wink:

This worked for me, thanks.

Thank you, problem solved.!!!

It doesn´t work for me. Outrageous to be delivered to unverified amateur updates.

1 Like

Did you restart your PC after deleting both files ?

Had same issues with Gaming Services, deleted entries in registry as suggested, rebooted pc, it was reinstalled when I launched MS Store, I now have version 2.53.17003.0. I launched MSFS, but I have been stuck on Paris screen for absolute ages, with revolving “circle” at the bottom right of screen. Any ideas?

1 Like

There could be many reasons.Can we talk together on discord?


Hi Scotty,

I came right, thanks. I first tried the regedit option, which did not work.
I then tried the “reset” option in Settings/Apps/Microsoft Store/Advanced and shut down pc, restarted, went straight to MSFS icon and launched game, and it loaded and installed update, just finished. Game launches fine.


This registry hack is not SOLVING the problem, it is simply MASKING the problem.

As far as I can see, it is merely bypassing the broken Gaming Services while starting MSFS to allow it to run but that now means that any tasks, checks, maintenance, or updates that are usually done by Gaming service will not now be run.

The SOLUTION is to get Gaming Service working and starting with MSFS, as it should - but (again, as far as I can see) nobody has found out how to do that. Obviously, the ultimate responsibility for this lies with Microsoft (and their representation on here) but they seem more interested in shutting down any threads about this, with dismissive posts that imply “this is solved, you just didn’t search hard enough” and then pointing to this thread - whereas, in truth, they are as clueless as the rest of us.


Well at least, it is not happening on my PC.


1 Like