Unable to run OpenXR Developer Tools

It probably won’t change my life, but I’d like to tweak some of the settings in OpenXR using the OpenXR Developer Tools.

The trouble is, I have never been able to run the Developer Tools. Everything else is fine. I have a Reverb Gen 1 running in WMR. I choose the WMR OpenXR runtime for MSFS and SteamVR for X-plane.

Both sims run OK.

But when I open the Developer Tools, I just get the opening screen:

The Demo doesn’t run and won’t reset and clicking the other two tabs (System Status & Developer Settings) just fix the app into the eternal spinning blue circles.

I’ve checked my permissions - all ticked. I’ve uninstalled and reinstalled a number of times - no change. I’ve searched the forums and MS help desk - nothing.

Any ideas? All suggestions gratefully received :slight_smile:

Following since I have the same issue.

1 Like

Thanks, @MykaiRO - I was beginning to think that I was the only one in the world that has this problem!

I can’t find anything at all on the MS help sites so am at a bit of a loss. Do you run on a WMR headset as well (mine is the Reverb Gen 1)?

It seems to get into a loop that, because OpenXR is loaded automatically when you download WMR, that it seems to not be able to link up with the Developer Tools. Well…that’s what I originally thought until I started seeing loads of other Reverb users not having any trouble with using the Developer Tools at all.

To me, it makes no sense. The OpenXR is there and is functioning fine…so why does the Developer Tools app have problems interacting with it…

Have you tried uninstalling and reinstalling it?


Yes - many times. The WMR has also been updated at least once, as has SteamVR. Oh, and Windows 10 too.

Always the same result.

It has to be something like that - a quirky inconsistency or corruption somewhere, but I’m running out of ideas of anything else that could be clashing with it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.