Unable to set elevator trim using 'set trim' command

Hi all, I am trying to build some arduino based sim control devices and first on my list is an elevator trim wheel using a rotary encoder.
I read this response: Dumb question - what does "set elevator trim" command do? - #5 by willisxdc?
and as part of initial testing tried to map ‘set trim’ to a keyboard button, and ‘cockpit interaction decrease/increase’ to two more.
The issue I have (one of mannnnny with this sim) is that if I mouse over the trim wheel and press the cockpit interaction buttons, the trim wheel moves however if I just press the ‘set trim’ button then press thee interaction buttons, nothing happens. I have tried holding the set trim button as well as different combinations and nothing works.
Am I using the set trim command incorrectly or is it broken?

If you wish to use a rotary control it would be an analogue control and therefore should be assigned to the elevator axis - unless I am misunderstanding you? :thinking:

Don’t use an analog control bound to elevator trim axis. You’ll have problems when disconnecting A/P because the pot will send it’s physical position, wich is the one before connecting A/P (or anyone if you moved the trim with A/P connected).
This doesn’t happen with an encoder.

For me the ‘set trim’+‘interaction’ have never worked. And this long before the SU5 update.
Bind your encoder like buttons with ‘trim up’ and 'trim down", and adjust sensitivity, travel and speed in the Arduino program.
I have no knowledge for the Arduino interface, but perhaps you can simulate an axis for the trim like I do in my VKB Joystick software.
It offers me a virtual axis for up/down and even a reset to 0 button.
In MSFS this axis is bound to the trim axis.
I have no problem when disconnecting A/P because the value stays at the current position and not suddenly going back to the position given by an analog potentiometer.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.