Undocking ATC with VSync HALVES fps (?)

@LinerXiandra exactly, without VSync when you undock the ATC you just lose some fps, but it will not halves. Without VSync i can do 63-65 fps, when i undock ATC it drops to 60-59.
With VSyinc on, i get steady 60 fps naturally, but undocking ATC it halves to steady 30 fps.

@MichaMMA i’m using internal MSFS counter, which is reliable and in depth featured.


ah… understand now.

Maybe you run then into fps lower than the vsync target and it switched to the next vsync-step ( which is 30 for a 60 fps monitor ).

But,… hmmm… is a bit… hmmm… I try to recheck this tomorrow :slight_smile: … maybe there is another (new) vsync issue.

good point… i made some tests, but unfortunatley for some reason i cannot understand, i can’t get 60 or more fps with ATC undocked, even with lowest resolution and lowest graphics settings. Which really doen’t mean a thing to me. At that settings with ATC docked i can reach 110 fps. So when i undocked it i expected 80 or 90… but it goes down to 50-55, making the test uneffective.
Please, if you can make some tests, let me know

I have recently found this as well.

I haven’t used the sim since December… and back then, I could undock windows with vsync on (60Hz) and not have it limit to 30fps. Now it limits FPS to 30. It also seriously degrades my FPS.

Without undocking, I get 57fps, undocked (vsync off) I get 39fps, vsync on, I get 30fps.

I’m almost certain that back in Dec. undocking windows had virtually no effect on FPS.

Since i just bought it last week, i do believe you if you say previous versions didn’t had the problem.
Fix one thing, destroy 100 others. A classic.
This is a serious issue Asobo should take in account.

Same here. I’m having this issue. I thought I’d fixed it, but whatever temporarily fixed it must have been something else because the problem has returned.

I’m almost certain that back in Dec. undocking windows had virtually no effect on FPS.

This is true, previously it did not affect framerate very much at all.

Ok…maybe someone can weigh in here.

I just reset my NVIDIA control panel 3D settings for MSFS2020 to default, and now the problem went away. I only had Tripple Buffering turned on, and Power set to High Performance. Now, I’m getting 45-55 FPS again with the ATC panel undocked.

My new theory is that if you make any changes to the VSync option in NVIDIA, it causes issues with MSFS. I had previously tried turning Vsync off in MSFS, and on in NVIDIA, and then reversed the change after performance didnt improve. Perhaps, ever since then, it was acting like it was still turned on in NVIDIA control panel?

After hitting the “restore” button in NVIDIA, i’m back to expected FPS.


Interesting. I will try that.

i think i didnt understood well.
you are back to expected fps while you play with vsync on?
if yes, vsync on in msfs or nv?

p.s. triple buffer is obsolete in new games. does not change anything.

Edit: i just recieved an answer from ms in zendesk:

“Currently multiple monitors are not supported in MSFS2020, but the functionality is in deelopment”

… What? So what is the point to make windows undockable?! Sensless.
And… this happens even if you use one single monitor… nothing related to multi-monitor.

There was always a penality to the pop-out boxes but indeed it does feel like the last couple of updates have locked a lot down. ATC (and sometimes VFR map) popped out to a different monitor is my usual config and since most recent hotfix I think I’m seeing the VFR map cull frame rate by about 20fps. I try to avoid using it now. I’ve not actually counted the impact of the ATC pop out…

i tried to do what you say, no luck.
same behaviour.
VSYNC on → Docked ATC 60 fps. Undocked ATC 30 fps

So… some tests later… There is an issue.

Settings IN-GAME : V-Sync=On : 60 ( full )

Normal ATC Not ext. Window:

ATC now ext. Window. Get FIXED 25fps

Back to interal ATC-Window:

Thus, it seems there is another kind of V-Sync Bug, similar as the old one, but not same:

If open ATC as ext. Window , the Game jump to the second V-Sync step ( note: I own a 75fps monitor… 75-37-25 ).
Not sure why in your case seemingly it jumps to the first V-Sync step ( 60-30-20 for a 60fps monitor ) … Or own you a 120 FPS Monitor ??

I also re-tested the fix of the old bug, and the old one is still fixed.
With the V-Sync-30 Setting, I get the correct first V-Sync-Step (37fps for my 75fps monitor).

Have you already created a ZenDesk Ticket ?

Thank you so much! This is exactley what i meant and what i am experiencing.
Yes, i opened a ZenDesk explaining everything about VSync on-off and fps behaviour, and everythig else.
They replied me that “MSFS does not support multi-monitor at the moment.”
So lollish…
First: It happens even if you disconnect out the second monitor and use just one…
Second: why the hell making windows undockable if the app doesn’t support multi-monitor?! ahahah

I remember at these post for release where the other vsync bug was fixed.

It might be some users already reported issue, but we not aware of it.

You can do some tests with the Nvidia Controll V-Sync Setting, but I’am not sure whether this will helps a lot ( persistent ) and possible you have to limit the fps then also outside of MSFS.

yep… it is not necessarly a multi-monitor issue. Of course , we know that Ext.Window-Mode is only necessary in case you want to move it to another monitor. But the issue also exist, as you said , in single monitor mode ( as by me ). Simple answer the support and explain him again what you have done. Possible made screenshots , link to forum posts, etc.
If I have bit time, I will also create a new ticket and I can refer to my older one. The “effect” is the exact same “second v-sync-step” (in my case) as in the fixed former issue. For me is it of course not high prio, because I don’t use the ext.windows often… but might be important for other users.


Sorry for the delay - havent been able to get on the forum till now. Yes, something I’ve been able to do allows the frame rate to return to close to the normal state (very little drop…maybe 1-2 fps) with the ATC window undocked.

I’m trying to think what else I did…

The only other thing I did was reset the toolbar with the right hand config option, and then open the ATC window fresh, resize it, THEN pop it out and drag it over to the other monitor. Perhaps it has to do with resetting/resizing order? I know I’ve had issues when I resize it after undocking.

I just looked again and I’m still having no drop with it docked on my other screen.

Or, if this doesnt work, perhaps it’s just a really random bug, and I happened to hit the magic formula…for as long as it lasts before I get the FPS drop again, that is.

Still baffled by this. But, I was able to repeat the “fix” somehow.

So, I tried the new Nvidia drivers (465.89) released today. No go. Not as smooth as the good ol 457.30. I used DDU to remove the new one, went back to the old one. Standard.

Re-launched MSFS, and now I’m stuck at 30FPS again! So, I tried the same thing as last time. Undock, redock, resize, undock, Alt-Enter, etc. Finally, I reset the toolbars, closed MSFS, relaunched, and still stuck at 30FPS with it undocked. So, I tried expanding the ATC window to fullscreen on the second monitor, and the instant I did that, I went to 50FPS. When I restored back down to the normal size, it stayed at 50FPS.

Since then, I’ve closed, relaunched MSFS, and restarted my computer several times, and it is staying at 50FPS with the ATC window undocked and on the second screen.

So, so strange. A bug for sure.

Holy ■■■■ that worked!
This is what i tried following your hint:

1 Open ATC
2 Undock it and Move it to the second monitor, double click the window title to maximize ATC
3 Click on the ATC area and Alt+enter. ATC will go full screen on second monitor
4 Alt+enetr again

Now you get 60 FPS!

Absolute strange thing is that if you try to resize it to make it smaller… boom 30 FPS again.
Definetely a bug.

1 Like

Unfortunately, this did not work for me. Tried to follow your steps as closely as possible, but I’m still seeing halved framerates with an undocked window. I also tried restoring my Nvidia settings. I was looking forward to actually using the ATC panel on the second monitor for once too.

I’m also suffering a loss of 15 fps when I undock any window with vsync off.

The fix seemed plausible to me too. I’m rusty on Direct3D, but in D3D9 you need to reset the swap chains when there’s a window size event, and the events are handled differently if you’re doing a continuous resize where you wait until the window is done sizing before you reset everything, or just a one time size event like going to full screen. So it’s possible the one is coded wrong with the bug, and the other properly resets the swap chains for drawing in multiple windows.

Awesome! Glad it worked for you, too! Now we’re slowly getting somewhere!

BTW, if you resize the window before undocking, you can avoid the loss of frames again.

Hope Asobo is reading this and this helps them figure this one out!