UPDATED - ATC window causes severe loss in FPS after updating to 1.14.6.0

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Removed for testing, no change in problem behavior.

Are you using Developer Mode or made changes in it?
Using it for FPS view. When closing, no change in behavior.

Brief description of the issue:
I’m actually getting far worse performance now, post 1.14.6.0.

I’ve ensured I’m running 1.14.6.0, and community folder empty. Cache deleted (I dont use it anyway).

I used to get 45-50 fps with the High preset with most GA aircraft, in photogrammetry areas. Now I get 25-30 fps in the same areas. Even in the middle of nowhere Wyoming, I cant get above 30fps.

With the FlybyWire A320NX, I could expect previously around 30 fps. Now I’m getting 12-15.

Something is seriously wrong here. No clue how to fix it. Mainthread/GPU is getting hammered.

UPDATE: I’ve found that when any window is popped out, as I’ve always flown with ATC on the second monitor, it tanks my framerate (from 55-60 to 25-30). If I close the ATC window, or pop it back to my main monitor, framerate instantly goes back to 55-60.

Disabling VSync in game has a similar effect. FPS go from 25-30 up to 40-50, but not quite as high as simply closing the ATC window.

SECOND UPDATE:
I re-enabled “Hybrid Mode” in Lenovo’s Vantage Software, and although this is supposed to be for intelligent switching on battery power, it seems to have cured the issue. Beyond Bizarre. I’ve had this disabled from day one, and now it becomes an issue apparently. I’m guessing that it disabled the integrated graphics card, which…maybe handled the ATC window when on the second monitor, so now the Nvidia GPU had to do double duty? Not sure if that’s how it works.

But…I’m now seeing high framerates again. Will update if things change.

UPDATE #3 - problem has returned. So I guess the ‘Hybrid Mode’ change did not fix it.

Provide Screenshot(s)/video(s) of the issue encountered:
With ATC window on second monitor:

With ATC window “popped in” to game.

Detail steps to reproduce the issue encountered:
Fly in any aircraft, in any region.

PC specs for those who want to assist (if not entered in your profile)
i7-10750 6-core CPU, 32 GB DDR4 ram, and Nvidia RTX 2060 GPU with 6bg of memory. Two 1TB M.2 NVMe SSDs. Windows 10 is at 20H2 update, Nvidia 461.92.

Did you submit this to Zendesk? If so, what is your ticket #?
I’ve never had any positive experience, or resolution of any of the problems which I’ve submitted to Zendesk, so no, I’ve not filed a report.

Yep. The ATC Window, like the VFR Window, both are buggy. A well known fact for a long time. Both have my Com crash to desktop if I try to move either window. I get a friendly note telling me that the Graphics driver timed out {AMD}.

Not moving, or resizing, the Windows and everything is just fine. The game itself runs great on my Comp. Does anyone have a solution? I definitely have the latest AMD Driver; so this is not the problem.

No, this is not a new Bug Report, just a friendly plea for suggestions.

Hello
I have the same problem. If you open the ATC window on the same monitor, the frame rate is ok. If you then open the window on a second Montor, it collapses. For me this is 10 fps with version 1.15.10.0.
Greetings from Germany

I just discovered this as well. I have only one monitor; if the ATC window is off or popped somewhere on the screen, the frame rate is ok, if I pin it to the corner of my screen using the middle of the upper right window sizing icons (the open box with the arrow), I lose about 10 FPS.

Edit; just discovered by searching further this is not a true frame rate issue, but just a peculiarity as to how frame rate reported values are calculated. The number depends on how any extra windows are displayed. But it’s good to know that if you are trying different game settings, the manner in which windows are displayed skews the frame rate reported value.

Hello everyone,

did you see the folllowing topic?

It could contain related information.