Update stuck at 89%

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons? If the issue still occurs with no mods and add-ons, please continue to report your issue. If not, please move this post to the User Support Hub.


Brief description of the issue:

Update stuck at 89%

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Today I have tried to update to

The install first opened the “Accessibility Settings” menu - pressing Next started the update proces, but it got stuck at 89% (only missing 1 package).

I waited for a very very longtime, and then restarted the sim, but know it won´t resume downloading and says “Please wait…” with 0 kb downloaded.

I have remaned my community folder and tried again to no avail.

I can see that in my MSFS2020\Packages\Official\OneStore**.fscontent**\ folder there is a file called “asobo-airport-eham-amsterdam”, which I asume is a package file that should be decompressed, but isn´t.

As far as I know the .fscontent folder is where update files (Package files) are stored during an update download, and then should be decompressed afterwards - this doesn´t seem to happen.

Many issues may be due to an outdated graphics card. Please state your Graphics Card Driver Manufacturer (NVIDIA, Intel, AMD) and Version (Learn how to find your current graphics card driver version):


PC specs and/or peripheral set up if relevant:

Build Version # when you first started experiencing this issue:

:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video: