Update loop solution

Looks like I found the way to fix the dreaded update loop, it has to do with the windows autotune feature that I had to disable, you can find it here: https://www.thewindowsclub.com/window-auto-tuning-in-windows-10

I tried this too but didn’t fix it for me :frowning: Still downloading, still looping.

I’m sorry it didn’t work for you, I never had any download problems before this update came out and this method solved it, did you make sure the cmd prompt instruction registered? did it say ok after you pressed enter to commit the instruction?

The only thing I hadn’t tried was throttling with Netlimitter as I saw it wasn’t free, but didn’t realize there was a free trial. Installed it, set a limit just below the speed it was downloading at unthrottled and that did the trick. What a strange problem, but glad I’ve got a fix now.

Hope this might help others too if they haven’t tried Netlimitter yet.

1 Like

Closing this topic as this is the first thing listed in the MSFS FAQ for “looping” issues as well as using Netlimiter or VPN.

Download stuck on packages / Install loop – Microsoft Flight Simulator Support (zendesk.com)