Update not showing in Microsoft Store

Hi,

I’m running Win11, 5600X, 3080RTX and 64gb RAM.
MS Store, Std edition digital ownership.

I went to update MSFS today and it’s not showing in MS Store. The Xbox app install worked for my last update, but it’s not working at all this time.

I’ve tried MS Store Reset, Xbox App logouts/uninstall/reinstall, WSReset, wuauserv and bits stop/start, removed cache manually etc.

Any ideas?

Yes - uninstall the Xbox app then reinstall. Happens every single time I try a mandatory update. It’s very frustrating - such a great game such a poor store app

saw you’ve tried that but would check again just in case

Found another thread and got it fixed.

For Win11 customers, if you find MSFS in the MS Store, scroll down until you find ‘In this bundle’ and click on the version you have (should say installed).

It’ll open and there’s a button to say ‘Update’.

Once I clicked that, an Icon appeared on the Library button (left hand side). Click on that and you will see the MSFS update ready to install.

For me I opened the Xbox app and it finally appeared.

Hello ! Could you please be more clear ? Can you describe the concrete steps to follow. Thanking you very much ^^