Update stuck downloading and decompressing same file

The update was going fine, downloading surprisingly fast , then got stuck at 94%

the file Asobo-simobjects-characters-0.1.56.fspatch will download , then decompress

then it says please wait , and downloads the file again and does everything over again , this is 155/191 .

Using a lenovo legion 5 pro . Any help would be appreciated, trying to avoiding downloading the whole game once again

I have same problem with this file… i wait 2 hours, restart msfs zero help

I am stuck on this screen during installation… two reboots … nothing.

OK… so deleted the game and did fresh install , took about 5 hours instead of 3 days so I’m happy , had to find the files myself , steam wouldn’t properly uninstall the game , hope this helps

The accepted workaround is to note which file is causing the problem, stop the download (Task Manager if nothing else works) then find the rogue file and delete it. Restart the sim which will download the affected file again, hopefully successfully, and you’re away without having to reload the whole game. Not so bad if you’ve only just started but after 20Gb has been downloaded…!
It’s a random file corruption which could be caused by a number of things, most likely a momentary break in your internet service.

I just waited might of just been a big download

There is another thing which worked for me on two separate PCs on separate occasions.
In BIOS, if you have set your RAM speed manually, for example to 3600, this for some reason causes the decompression issues. If you set it to Automatic, decompression works flawlessly.
I don’t know what the connection is, but this was recommended to me by Microsoft and it worked in both cases.

Trying to download su 13. Keeps freezing at 100% on the right of download bar but frozen on decompressing an Fspatch I’ve done what others have recommended and found and deleted the suspect file. On next try it does the same on another file. I’ve deleted a number of files and now it’s freezing on a a file I deleted before. Any new thoughts?

1 Like

Thank you - I will try this. I am frozen at "Decompressing asobo-aircraft-longitude-0.1.107.fspackage.

I’m the same, been stuck on 100% for 2.5 hours now…

I am having the same issue… This is absolutely ridiculous! They can’t get a 2GB update right? Mine is also stuck on 100% Fix this broken mess before you worry about releasing 2024.

There is an ongoing issue being investigated at the moment around installation issues in the sim. Please use this thread for comments: [Polls] Sim Update 13 ( Discussion