Update won't download from store with error 0x80070141

Anyone else getting this?

3 Likes

Myne is saying Code: 0x80073D02 = application still open when I know it is not.

I ended up just uninstalling the game. Redownloading the entire thing now :frowning:

1 Like

Possibly a store problem. Try ‘wsreset.exe’ from the run command and see if that helps.

I am getting the error and wsreset did not fix it.

1 Like

Are you on Windows 10 Insider build?
This issue usually occurs in Windows 10 Insider Preview and prevents users from installing or updating apps from the Store.

You can try ’ wureset11008_setup_winx64.exe’ from here
Reset Windows Update Tool for Windows (32/64 bits)

1 Like

Yes, any tips? Never been an issue from 1st Alpha.

You can try ’ wureset11008_setup_winx64.exe’ from here
Reset Windows Update Tool for Windows (32/64 bits)

I’m not on the insider build. I tried resetting the store and that didn’t work either.

I needed to uninstall and reinstall the whole game.

Unfortunately didn’t help. I was able to update the Xbox Game Bar app update so I was able to run an app update prior, just not MSFS.

Sorry to hear that. Sometime the whole MS drives me crazy…

1 Like

Sorry :wink: you can also try

Appsdiagnostic10.diagcab

i’m sorry to say that too but you’ll have to reinstall windows completely if you want play at this game again

i had the same problem this morning and even after uninstallation, it was impossible to reinstall again because of many corrupted files

i have formated now and this problem are solved, its downloading right now

fun fact, i reported this bug on another official forum and got automaticaly censored for lying and propaganda

1 Like

I fixed this by resetting the app in the windows settings (settings, apps&features, search for Flight Simulator, advanced settings).

To be safe, I renamed the folder that I saved my MSFS content to while the reset occurred so that it would not make me redownload the game. This step cannot help you if you used the default location for install.

The reset made me redownload the app (1GB), but then everything updated and I had no issues. I renamed my content folder when the reset was complete and launched the game to complete the content update in game.

Save your folder next time so you dont have to redownload the whole thing!

Hi BTD29,

When you say you renamed the MSFS content folder am I correct in assuming you were asked if you wanted to rename as part of the reset option?

Or are you referring to the Community folder.

I have MSFS installed in it’s own SD drive and not the default C: location.

Ok I’ve managed to fix

When I pointed the installation to another disk it went through just fine so I’m guessing there is something to do with “WindowsApps” folder that Windows Store creates to store the games. the solution for it I believe is shutdown Microsoft store and then delete this folder, then try to reinstall/update the game. please note this won’t delete your FS2020 folder and all game files, just the launcher.

As a precaution, I have renamed my FS2020 folder to FS2020_old - This will prevent me to download everything again

EDIT:

In case you have more games to Windows Store and you don’t want to loose them, just simply open the folder and Delete “Microsoft.FlightSimulator_XXX” folders

Unfortunately I’m not being given the option of a folder, when I click on Get Updates in the MS store the error message pops up…Submitted to Zendesk.

This folder

then delete

Will try now.