USB disconnect sound plays randomly and MSFS freezes

Hello,
Randomly, the USB disconnect sound plays and msfs freezes for 30 seconds- 1 minute. I briefly seemed to of fixed this by dust cleaning my pc, but it seems to have returned after plugging in a steering wheel. I am not in any betas and the issues started about a year ago. This is very irritating on vatsim especially on approach as it can ruin controllers traffic management.

“Sleep” mode applied to the USB port?

How do you check if this is disabled?

I had it happen all the time. Replaced a cheap USB cable and it went away.

Disable USB power saving in Windows

  1. Open the device manager. …
  2. When the listing expands, look for the items marked USB Root Hub.
  3. Right-click one of the hubs and select Properties.
  4. Press Power Management tab. …
  5. De select Allow the computer to turn off this device to save power.
  6. Click OK and you’re done.
2 Likes

I have disabled power saving but it is still doing it.

Is the USB system being overloaded?

Try minimising the USB devices or a powered hub.

Other option - are the USB ports appropriate for the connected devices? I.e.USB 3 device in a USB 2 port sort of thing.

It maybe a device failing but that is likely to be hard to trace as the obvious thing to do is remove devices on at a time. Good luck sPK

1 Like

It’s usually the whole system that is freezing for a moment, not the game. It always amaze me how in 2024 Windows cannot handle USB connection/disconnection in the background without freezing for a few seconds? No matter how modern your PC is it’s always the same 1-2 seconds stutter every time you plug a controller or something else.

Is there any way of checking what type of usb the cable is in the device manager?

Not that I know of. I’m always disapointed how hard it appears to be to find what is connected to each USB port.

I’d check PC manual or motherboard information to find which each USB port is. They usually colour the ports to aid identificaiton. Mine appear to be blue for USB2 and red for USB3 on the back at the front they are black but labeled. sPK

Definitely invest in a powered hub (if you haven’t already.)

Will do and see if that fixes it.

There is a free tool called “USBDeview” from Nirsoft. It can show you what devices are plugged in and what devices was plugged in. I see it has a column “Power” and “USB Version”

What I like about this tool is that you can delete the device drivers of USB devices that are not plugged in. When you then plug them in, it is as if you are plugging it in for the first time.

2 Likes

This is a video of USBdeview when it happens https://drive.google.com/file/d/1l-Kb7yI4AwcopjzTCl3YnCmAkjdmGY9Q/view?usp=drive_link

It also seems to happen when the system load is high (when opening more apps)

I used to have LOADS of USB based issues, because I have so much plugged in I guess. Think I finally have it stable now though. Issues were a good mix of hardware and software issues.

There’s the obvious “disable USB suspend” that everyone always mentions, but beyond that there’s also other software that can cause havoc with USB connections.

Do you have any Razer products connected per chance? If so, try closing/prevent startup of all Razer software (like synapse, etc.).

I was getting this issue where, when I plug one device in (say my wireless Razer mouse), it would then cause other devices to be “lost” / “disconnected” from the game controllers list. So I’d get the mouse, but lose my yoke or something. I found that this happened much LESS when I totally uninstalled the Razer software…although it still happened sometimes when I had EVRYTHING plugged in. It seemed to completely go away when I both UNISTALLED Razer software AND kept everything WIRED…but I mean, why would I want to use my wireless mouse with a cable attached?

I had read online a while ago that the Razer software devs have essentially been a bit lazy and use generic device drivers for a lot of their products, just slightly recoded, and this causes all sorts of conflicts with other products connected. I learned this when I was previously using Razer Tartarus (both pro and V2…as in my old setup I had one screen set up for flight sim with the tPro and one screen set up for snowrunner+wheel with the tV2…having BOTH connected started cutting out the wheel…because I’ve now gone full on flight sim setup, I don’t use the wheel or EITHER of the Tartarus keypads anymore). It seems that having more than 1 Razer product connected at a time will almost certainly cause device conflicts with other products, be they Razer or another brand. Removing the Razer software, and having all products WIRED instead of wireless mitigates this issue somewhat…but the better option seems to be avoiding Razer now :frowning:

I have since switched to a wireless Logitech G305 mouse (which has no RGB, so maybe that’s a factor also?), and I can now seemingly have everything connected and working all the time.

The other HUGE difference I found was that I moved all my Logitech/Saitek flight stuff to dedicated USB 2.0 powered hubs. They are technically 7 port hubs, but for the actual controls and switch panels etc. I found that 2 devices per powered hub worked best, except the FIP’s which I use 2 hubs to share 8 other USB 2.0 4 port individually switched mini hubs. (4 hubs on each of the main powered USB 2.0 hubs).

I used to get some controls or panels, especially the Logitech multipanel, freeze up MID-FLIGHT…sometimes even several hours into a flight. Since switching to the powered USB 2.0 hubs, this has never happened though.

Sounds complicated, but, touch wood…it’s actually working great now.

So I have now connected:-

-USB 2.0 powered hub
—USB 2.0 switched hub
------creative play!3 soundcard with Saitek flight headset
------FIP1 (fipgauges.com Approaches/Takeoffs)
—USB 2.0 switched hub
------FIP2 (fsxtimes ENG)
------FIP3 (fsxtimes ASI)
—USB 2.0 switched hub
------FIP4 (fsxtimes TCR)
------FIP5 (fsxtimes ATT)
—USB 2.0 switched hub
------FIP6 (fsxtimes Clock/OAT)
------FIP7 (fsxtimes CMP)

-USB 2.0 powered hub
—USB 2.0 switched hub
------FIP8 (fsxtimes HDG)
------FIP9 (fsxtimes ALT)
—USB 2.0 switched hub
------FIP10 (fsxtimes VSI)
------FIP11 (fsxtimes fipgauges.com checklist)
—USB 2.0 switched hub
------FIP12 (fsxtimes RPM)
------FIP13 (fsxtimes ADF)
—USB 2.0 switched hub
------FIP14 (fsxtimes VOR1)
------FIP15 (fsxtimes VOR2)

-USB 2.0 powered hub
—Logitech Yoke+Throttle
—Logitech Switch Panel

-USB 2.0 powered hub
—Logitech Throttle
—Logitech Multipanel

-USB 2.0 powered hub
—Logitech Rudders
—Logitech Radio Panel

-USB 2.0 powered hub
—Saitek Trim Wheel
—Saitek BIP

-Sabrent USB 3.0 Hub
—Creative G6 soundcard with Beyerdynamic DT240 Pro headphones
—hyperx duocast mic
—G1000 unit usb connection for PFD
—G1000 unit usb connection for MFD
—SRS Intellibox 2.0 for hurricane wind kit
—Thrustmaster eswap X pro controller
—Logitech C922 webcam for twitch streaming

-Mobo USB 2.0
—USB 2.0 powered hub for FIPs
—USB 2.0 powered hub for FIPs
—Logitech G305 wireless mouse dongle
—Red Dragon K585 wireless keypad dongle

-Mobo USB 3.1
—Razer huntsman mini WIRED keyboard (without any custom lights/keys due to removing Razer software)
—Startech USB to 2x HDMI port (with G1000 PFD/MFD attached)

-Mobo USB C
—Loupedeck Live S

-Mobo USB 3.0
—Sabrent USB 3.0 powered hub for soundcard/mic, etc

-PCIE USB 2.0 card with 4 ports
—powered USB 2.0 hub for logitech/saitek controls
—powered USB 2.0 hub for logitech/saitek controls
—powered USB 2.0 hub for logitech/saitek controls
—powered USB 2.0 hub for logitech/saitek controls

These are the hubs I used:-

Plugable 7 Port USB Hub USB Hub for Multiple Devices and USB 2.0 Data Transfer with a 60W Power Adapter : Amazon.co.uk: Computers & Accessories

SABRENT USB Hub 4 Port USB 2.0 Portable Travel USB Docking Station with Individual LED lit Power Switches [Charging NOT Supported] for Mac & PC (HB-UMLS) : Amazon.co.uk: Computers & Accessories

Looks like the powered 2.0 hubs are not currently available, but if they do come back, I can say that, for me, they work great now in this setup…finally.

All this, connected at the same time, everything now working fine…and on a system which is also running 3x 4K monitors (I have a strix 4090 and 14900k).

It’s been a long journey getting everything connected, working, without USB conflicts or disconnections…but I think I’m finally there.

Also running a whole bunch of software alongside the sim itself. Software for the G1000 units, software for the wind kit, spad.next for the FIPs, BIP and panels (still using the in sim control setup for yoke/throttles/rudders/trim, as I already have them set up how I like, and they’re working, so didn’t see a reason to switch them to spad.next just yet). Can even run OBS with the webcam at the same time too without issues (although, my flight skills are still not such that I’d like to stream flight sim just yet lol). I did have autofps running too, but actually found that flights seem smoother (especially take-off and landing, but also during turns at altitude) without it and instead I just keep TLOD set at 100 instead of the default 200 for ultra graphics settings.

For me, the biggest changes that seemed to work are:-

  • use USB 2.0 PORTS and add a USB 2.0 pcie card if you need more of them
  • use USB 2.0 HUBS, powered and split your devices among as many hubs as you have available ports.
  • avoid Razer products if you can (sorry Razer, been a big fan until recently), or at most have only ONE Razer product, WIRED and choose something that you DON’T need to customize, as you’ll want to uninstall Razer software.
2 Likes

@GlennyPlays Thank you for that detailed post. It was most informative! :slightly_smiling_face:

Thank you for this!

I have no razer products plugged in and will try and invest in some power 2.0 powered hubs and see if that worked. Also, on USBDeview, is the highlighted green lines the usbs that are plugged in?

Thanks for this…i didn’t realise you could easily delete drivers from disconnected devices…i guess this is actually a good idea generally to help avoid conflicts too. Will download this tool later :slight_smile:

1 Like

Would I be correct in thinking white connectors are usb 1.0, black 2.0 and, blue 3.0?

I have 2 black (2.0)
2 blue (3.0)
And one red?

Black are 2.0, blue are 3.0, red are 3.1 i believe.