USB losing connection to MSFS

Anyone having the issue with Spad and MSFS with windows sending the device (or the hub/usb-root it is connected to) into sleep mode? This is my thought but I am here to get other thoughts on this issue.

Spad works at initial start up but stop responding after a few minutes - Yes turned on programming mode to check . I made a small change to stop USB selective suspend in the registry. Spad stops talking to MSFS as I am not seeing activity in the lower right events monitor in Spad. All my aircraft had no issues until recently with this issue occurring - any suggestions - Is it microsoft issue?
The encoder stops moving, many of the AP controls do not respond via Spad - I have to do it directly using the mouse. I removed the AP setting in the control profiles so there would not be any duplication.

Common issue if you search the forums. Long story short, too many USB devices and the USB Bus is not able to supply them all.

  1. Go into Device Manager, expand the USB HUB / Devices, right click on each and ensure power management (allow to put to sleep) is turned off

  2. Get a good quality externally powered USB HUB.

I have 19 USB connections, all of them are split between 2 USB Powered HUBS and those HUBS are the only USB connections going to the PC.


I did the power management change…next new USB HUB.


1 Like

Also check out this & subsequent comments from @GlennyPlays

The comments were w.r.t. Logitech. I don’t know if Spad has a “preference” for USB 2.0 or 3.0 hubs - maybe the documentation for the device has a recommendation.

Hi. the device is the HC Bravo. I got the Sabrent 3.0 hub.lets see what happens. I did the change on the sleep mode for USB which I think did no change.

@SmotheryVase665 Does it happen after a few minutes into the flight? I shutdown Spad and restart and it works again but the issue appears again.

I keep thinking there was a variable change but truthfully, I am happy with the way things are from my profiles until further changes come.

Great hub! Those are what I run as well.

Happy to report…problem is solved with the new Hub. So crazy this was not an issue in the past.