USB mouse needed for Console

Load up the game and go to World Map to start a flight… Cant select anything with a controller, but as soon as i plugged my mouse in i could select a departure airport.

I then unplugged my mouse and again, the cursor disappeared and i couldn’t select anything.

Restarted fully and just the same again, cant select a Departure Airport with controller, only USB mouse.

Same issue here, literally can’t select anything in the menus with just a controller

Click L3 (press down on left stick). I believe that puts the controller into cursor mode from what I’ve read.

Not tried it, no XBox here and still waiting for download to complete on PC

im sure i tried this, will try again now

Clicking L3 doesn’t work, depending on what screen you’re in it either does nothing or loads a help menu

Sorry it didn’t help. That is what the release notes say to do.

No worries, thank you for chiming in and trying to help :slight_smile:

1 Like

yeah its just a help menu… thank you for trying though dude :slight_smile:

1 Like

No probs. I’ll probably be back later asking the same question as I use an XBox controller on PC and would like to avoid using the mouse if possible :slight_smile:


  • Syncing customized controller mappings from a PC build to console may cause the controller to become unresponsive other than the B button.
    • Workaround:
      • Select the Default controller profile in your PC settings and sync the updated settings to the Console
      • Use an external mouse attached directly to the console to update to the Default controller profile and then customize as needed.

I´ve this same problem, but I don´t have the pc version installed anymore, I really thing this should be addressed in an update.

all you have to do is plug a mouse in dude, you dont need the PC version installed…

Plug mouse in go to settings, and just click the arrow to change “controller profile” press Y on controller to save, unplug mouse…

Im flying right now :smiley:

Closing topic as issue was marked by OP as solved.