Varjo aero bug or even damaged?

Hi ,
After Long thinking i decided to buy a varjo aero.

Got it since Saturday , but I can’t get it to work properly…

I downloaded the software , firmware , updated driver , at last completely reinstalled windows.

The problem ist that the display resolution inside the headset is just bad. The edges flicker , as I said the resolution is bad (the image quality in my g2 ist actually better than running at 39ppd in varjo settings )

I’m getting crazy here and I have no more idea of what to do ( when I check display render resolution in developer mode in game , it shows me the right resolution but I cannot see it , it is simply ugly … ) the problem appears in virtual desktop as in msfs and Aerofly fs… everywhere the same…

Maybe someone can help me , if not I believe the headset itself is the problem and I send it back …

Very frustrating because I was really hyped… :confused:

Which version of the Varjo Base software do you have installed? There is a known issue with the latest version 3.6 that causes flicker and extreme blurriness…almost like vaseline is smeared over the lenses. Varjo is aware of the bug and plans to release a fix this week. In the meantime, rolling back to software version 3.5.1 fixes the issue for most of us until the update is released.

I can see exactly what you describe, but even when I rollback the vajo base it is still the same …

You said “fixes the issue for most of us” does this mean you know people that have the same issue and is even after rollback still present ? sorry for dump question but my hope is not fully gone yet… :grimacing:


This is not through the lense but this describes it well , what I see inside. And then there is this weird effect over the lenses that looks like dirt.

Try resetting the headset to default in the Varjo base software. I updated to that software on Friday when it stopped working completely. I then contacted support in which they immediately replied and said there’s an issue with VR stream and the software. Hitting reset to default worked for them and myself

Tried it several times with no luck , I believe I can say I tried everything several times … it is very weird and the image itself look like downsampled , in msfs it looks as I said worse than my g2 … but also Aerofly which is steam vr looks like this too.

I mean I have until now not seen the “real picture” of the aero , but I believe I can say that what I can see now is not what it used to be … looks more like rift s / quest 2 Niveau.

Contact support. They’re awesome at replying quick and assisting in troubleshooting especially if it’s Miles. Great dude. My first headset was dead on arrival (right lens completely black) and nothing worked. They shipped another and I returned the original faulty headset. It’s been great since

1 Like

Done it with diagnostic file and waiting for reply now …

1 Like

I just received my Aero yesterday and the headset would go black after 3 or 4 minutes. I would have ti unplug jt and replug the power everytime, till i changed ny USB port to a different one. Try that! And reset everything, uninstall Any Open XR, WMR etc, reinstall Varjo Base from scratch. See if that fixes it.

Honeslty ,in kinda dissppointed with the very narrow FOV. Clarity is awesome but My G2 wasnt bad!. I judge clarity by if i can read the smallest digits in th COMM radio! (Example the 200 in 35.200).

May return the Aero and just keep my G2 till the Pimax crystal comes out

I’m glad you mentioned pimax crystal. I just looked into it, I’m going to sell my aero and wait for crystal to release soon as they said Q3

just a word of warning, pimax are notoriously late at releasing things. i hope it is Q3 release date but doubt it.

1 Like

Thanks for the heads up

1 Like

I cant believe you consider pimax after vario. I tried the 5k+. It has so much distortion it feels 2.5d max its not true 3D. Also the support was impossible to deal with. I sent numerous mails cancelling my preorder several months before shipping and they ignored me. I then had a faulty unit that couldnt do 90 hz and had to battke support for over a year until they finally sent a replacement despite having video proof.

I then got the 120 Hz version which worked but I sold it as fast as I could!

It was fun trying the wide fov. Its cool of course but I want true 3D in my vr headsets. There is always compromises I rather have sharp higher res image over wide fov. You cant have both and believe to actually have some fps left.

I have Rift S now and dream about the varjo but I am trying to Hold off until next generation gpu because oculus Rift S is hard enough to drive on an 3080. I have tried the g2 which was quite nice but didnt play well with my usb:s.

After some Time I can write something about my Topic here.

The problem with the blurryness is fixed for me when i use version 3.5.1 of the varjo software ( version 3.6 AND 3.6.1 not working still blurry).

One thing that is not fixed is the weird lens effect that i get. When i look at at the sky or a white wing etc it is very “good” to see. It is like dirt is on the lenses ( like thousands of micro black points) which move with my headmovement so deffinitly a lens (or software , i dont know) problem.

I was in contact with varjo and they send me a new device which reached me yesterday. Sadly this weird effect is still there ( and the blurryness with the other varjo base versions too).

I dont know what to do but with this quality for me the varjo is not worth the 2k €… very dissapointed right now. ( the sharpness with 3.5.1 is insane but the effect destroyes it for me and the other version dont work correctly either…)