Vatsim traffic at night

Yes same issue with me, have not found a resolution yet.

found this, not sure if it’s still valid with new hotfix. it worked for some aircraft for me on IVAO

It only changes the stuff for the Asobo generic models and not any other 3rd party aircraft. I can’t try to fix files i don’t have.

1 Like

I put the wrong link up :roll_eyes:. I meant to put the link to that post you replied with a fix. I did change every aircraft on IVAO and it seems to work on most now. Again thanks for that!

Same here. I just completed a Vatsim flight in a busy event and saw NO other aircraft’s lights day or night. In all my pre-sim update 5 Vatsim flights the lights showed up no problem, but after the update nothing… annoying bug to add to the long list.

I created a quick and dirty python script to update the ivao_x-csl systems.cfg files. This script will create a backup of the original file. Still did not fix the issue on VatSim for me. Looking at SimConnect and vPilot debug logs I don’t see any glaring errors being thrown.

4 Likes

I spent about 30 minutes in KLAX and KJFK observing traffic. No lights at all. This needs to be fixed by WU6 on August 24th. Have you guys filed a bug report on Zendesk?

interesting I was able to see lights on some models this evening at CYWG. I did the crossfire event from KMSP → CYWG. I didn’t see any lights at KMSP but could see on certain models lights at CYWG.

I was able to get screenshots of lights on CRJ and TBM. Landing I did see other lights as well, I believe on IVAO models. I wasn’t able to get a good shot because final was tricky in 26knot gusts.

Screenshot_2021-08-08_171922

Went back to KMSP couldn’t see anything, then back to CYWG and I could see the above lights from the brief time I was observing. If I had more time I would have tried to see IVAO models, but had to run to dinner.

Hi guys. I’m having the same issue in MSFS while flying on VATSIM. However I’m using the AvGeek Model Matching Rules and have not yet tested it without it. Just wondering as I’m currently in flight - did anyone of you tested this lack of lights at night but with generic traffic?

It’s hit or miss with me, sometimes the generic widebody twin engines models have some lights, sometimes they don’t. The A320 generic model doesn’t ever work. This evening I saw the generic business jet work for first time with a taxi light and strobes.

I really can put a pattern on it other than I tested in Europe and seemed to be better with lights and model matching than the US. I’m hoping someone with more knowledge on the subject will chime in at some point.

Here is the thing. My mod only looked at the Asobo generic AI models. The A320 or the TBM are NOT generic models. These are player aircraft models and can be used for traffic. If you are flying in multiplayer or in a network you need to check if the aircraft is controlled by a player or AI. In multiplayer i can see Asobo generic planes without the correct lights because the PLAYER on the other side of the internet didn’t turn them on. The AI controlled lights (related to my mod) should always work.

When it comes to aircraft like the TBM or A320 we are having the problem that these are player planes. If i add them to a mod than this could enable the lights for traffic BUT will break the aircraft if you want to fly it yourself. The user would always need to remove that specific aircraft they want to use from the mod. Another thing is that the model.xml of these planes is more complex so i would need to find out what to delete and what needs to stay. The xml for the generics is way more simple.

The last point is that i don’t know how VATSIM works. I don’t know if it also uses the Asobo generics or just the player aircraft (like the TBM or A320).

Adding my voice to this- I’ve been suspicious that lights have not been working on VATSIM for a while now, but just confirmed it. I’m looking at a very busy Copenhagen Airport on the network, and none of the aircraft have lights on. Not the generic ones, not the model-matched ones. Nothing. 26 days since the last post, was a solution ever found for this?

1 Like

Just to elaborate - no AI or 3rd party flights show external lights anymore since SU5

No idea why Asobo hasn’t fixed this.

There is actually a temporary workaround in post 3.

You said it yourself though, it only fixes the generic aircraft models NOT the third party ones.

The generics, the non-premium Asobo aircraft and the PMP A330. I mean if you prefer complete darkness over at least some lights than i can’t help you out.

Ohhh I see! Sorry I mistook ‘generic models’ for the default twin engine airliner 00 that vPilot uses to fill in the blanks. This makes much more sense. Thank you!

Hey simmers,

Any idea if and when the vatsim traffic lighting issue will be fixed?
Gutted that I can’t really fly at night with vatsim at the moment. I had an issue where the controller said “line up and wait after arriving traffic” but I couldn’t see the traffic :rofl:
Iv seen a workaround for AI traffic in the game but does this work for vatsim traffic too?

1 Like

Not just vatsim, same thing happening for me…
Well. Since update 1.19.0 it seems a lot of lighting has broken. Landing lights throw very little light ahead, seems the taxi lights throw way more light now than the landing lights. Airport light reflecting off the ground at many airports is sometimes non existent making taxiing almost impossible. Lighting from other planes(large or small, on the ground or in the air) is totally non existent, I almost hit an airliner coming in for a landing, zero lights on it. I tried a total reinstall of MSFS thinking some of my light files had been compromised, that didn’t help( I don’t recommend this approach, literally took 12 hours of 30 Mbit’s download speed). This has totally ruined MSFS for me at night. I should add that this is happening in VR as well as 2-d for me. I hope Osobo sheds some light on this issue…

2 Likes

The problem is that the workaround doesn’t seem to work for Vatsim. I had somebody saying that he had no lights on the ground but in the air the other planes suddenly got lights.

I don’t use Vatsim and i don’t know what kind of system it is using for the lights so i won’t be able to make it work.