VCRUNTIME140.dll Error

and I simple asked: have you tried the things which working fine for @Uxio1214219

Your answer is still that you not want to try something and that’s okay for me and we can ignore your issues.

No, I have not altered my overclocking because my PC was custom built by Overclockers in the UK and never since I first turned it on - again, NEVER - ever casued an issue with ANY games, including games way more demanding. So, no, I have not messed with my overclock because it was delievered to me from the shop like that.

I have indeed removed and reinstalled each and all C++ libs, individually and altogether. Did not help.

I disabled Azure, dd not help. But again, I did not need to disable Azure on launch day, why would that be the issue anyway? Does not make sense. Nevertheless, I tried and did not help.

Tried different Nvidia drivers too. No solutioon.

I do not have Afterburner installed so that should not be the cause. Overall, I never fiddle with my system, I left it pretty much as the shop sent it to me. I did not overclock anything any further, did not increase GPU voltages etc. My system is in the state Overclockers US (shop) delievered it to me. And it is awesome, robust and powerful. Yet, MSFS started crashing at some point after the Japan update. The Japan update was still fine, I played a lot, but then I got bored so I stopped playing and haven’t touched the sim until late January. So, whatever updates came out after the Japan update and before the end of January are probably the keepers of the “secret”.

Finally, last week I formatted all my drives. Reinstalled Windows 10. I did it just for pure, regular maintenance, but I though I also check if it helps with the game. So I also installed MSFS onto the fresh system. Drivers all up to date. The game crashes, 100% of the time.

Something has been introduced in one of the updates.

2 Likes

thanks… so we can have a discussion and I can add comments which may be helpfull or you just already knew.

What we can do here is only try to find possible settings… we never can find issues in code, this must do the developers and therefore the questions like “have you tried” also in case there is seemingly nothing changed on your system side ( if we ignore e.g. these million windows updates ).

The lib version we have mainly no longer in main-focus, in special because MS-Store users get this from ‘internal’ , only Steam users seems to use the system wide lib. But re-install is still on the list to be sure. I also shown here a possible way how to find out which one is used.

The old Azure issues ( ATC voice ) seems no longer cause issues… may be some traffice stuff. Of course nobody can be sure, but e.g. the latest server issue related to this shown us, that the app seems stable related to this: it not crashed.

I read no bad things about the latest 466.11 nvidia driver and it runs fine in my case. And if you not use HAGS, then I assume no issue from this side… but may be depends on GPU model… there are huge diffs in the graphic-cards models related to issues ( 10xx, 20xx, 30xx ). More strange is the last windows update, but I assume we can ignore this here.

We have some experiance with pre-configured systems which are running fine in normal usage or for ‘usual games’ , but crashing with MSFS. Often the power-supply was the “bad boy” and game runs fine after users replaced it. One, or two times the GPU was defect and we had also cases with defect memory sticks. But that we can exclude all these, we asking for disabling the overclocking and run a test-case without any overclocking ( store the current setting in BIOS into a profile , then you can restore ). The worst experiance we have with overclocking of graphics-cards.

But sometime the app crash also because of the connected usb devices. But normaly with another error message as the “VCRunt…dll”. Similar to errors which some users get if they use memory overclocking with xmp profiles and others…

In special if you mention that “The game crashes, 100% of the time.” and if we assume you get not allways the VCRUNTIME140.dll Error (then it is a other story) , my first guess would be in meanwhile the windows virtual memory (pagefile). That this comes of top started more with a 1.11, or 1.12… They get normaly a 8000003 or a 0000005. Affected are mostly the users with 16GIG RAM, but also owner of 32GIG RAM run into these issue. Therefore the question about your system specs…

May be you can recheck the windows event log whether you still get the VCRUNTIME140.dll Error.

We here, the community, find of course not allways a solution. But we can try it and thats why we asking. But users have to allow it, or say directly that they just want to report without any discussion ( in this case is ZenDesk much more important ). If we would do same as Gsx31 (or also bit you) and we say allways “the game is the bug” , we had never can find all these settings with which help a lot of users can play MSFS without any kind of problems. Sometime of course we not find the issue.

1 Like

Finally, some useful communication.

I indeed have only 16 GB RAM. However, I refuse to take it out of the box that it is the reason why the game crashes because it did not crash at all from release day until the end of 2020. So it cannot be the fact alone that I am having 16 GB of RAM, unless - and I repeat UNLESS - something VERY demanding was added with one of the updates. On the other hand, there are numerous reports from users with 32 even 64 GB of RAM about the exact same kinds of crashes.

Graphics card. I have the Nvidia MSI 1070 - an oldie but goldie -, which I find reliable. It never gave me a headache. It is getting outdated but so far I have not felt that it’s bottlenecking my gaming. I could run all games I wanted to play without issues. DCS, a number of P3D versions, racing games, FPS games and so on. While there are way more powerful cards out there, it cannot be the cause of the crashes since MSFS did perform very well on my system from release day until the end of last year. If my card was not up to the task, I should have experienced the issues right from the start.

USB ports failing is a good point, I actually thought of that. But the question is, why all of us here suddenly have faulty USB ports? Nonetheless, it is something worth looking into, for sure.

I also take into consideration a possible failing graphics card or perhaps a dying PSU. But again, it is unlikely that suddenly, all of us have this issue. Because it seems obvious we are experiencing the same problem: VCRUNTIME140.DLL being it.

All of my crashes - 100% of them - are VCRUNTIME140.DLL crashes and they occur early on in the game. Therefore it is logical to assume it’s the devs that introduced something that takes a toll on some systems while leaving others untouched. Or alternatively - but again, unlikely - failing hardware. But in that case, other, clear signs should also appear and that is why I don’t think it’s the actual cause. Nonetheless, I will get my PC checked by experts soon, to rule out a possible hardware failure.

1 Like

As I said, since 1.11/12 the reports about memory issues ( mean the not-enough memory ) comes more and more on top. Additional with the fact that for some users the window auto-increasment of pagefile works not as expected ( e.g. because low on disc space related to the increasment rules ) the users must do only one simple setting related to the windows virtual memory. Switch from “System Managed” to a value like “min: 8Gig max:20GIG (better30GIG)”… and ensure there is enough free space on disc. Thats it. And yes, also users with 32GIG are affected and / or have other kind of issues.
May be you can try it as first ( it helped realy so many users ).
The summary about all the analysis before e.g.: Finally.....Solved CTD issues... for those of us with < 32 GB ram
( e.g. Settings → Info → Extended SystemSettings → Tab Extended → Performance → Extended → Virtual Memory → manual 8192 / 30000 )

The 1070 is good one… not high-perf, but good old ages, as you mention.

ähmm,… not all… the most users which have an issue with this, can not start the game. There are issues, not sure whether they are fixed, if usb devices go into sleep-mode , e.g. often the wireless devices.

1 Like

Same issue…lol
Faulting application name: FlightSimulator.exe, version: 0.0.0.0,time stamp: 0x60783c14
Faulting module name: VCRUNTIME140.dll, version:14.28.29231.0,time stamp: 0x5f4c66c9
Exception code: 0xc0000005
Fault offset:0x0000000000001fc2
Faulting process id: 0x26b4
Faulting application start time: 0x01d735c1fa784480
Faulting application path: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe\FlightSimulator.exe
Faulting module path: C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.29231.0_x64__8wekyb3d8bbwe\VCRUNTIME140.dll
Report Id:1abe2732-6959-42be-b84f-c9a4377fb7dc
Faulting package full name: Microsoft.FlightSimulator_1.15.8.0_x64__8wekyb3d8bbwe

Had these again. Tried everything once more and it didn’t fix them. Couldn’t even be in the air for more than 5 to 10 minutes.

Followed this right here and now testing. LFMN-LIPZ it would crash at around 5-12 thousand feet and so far so good have been cruising for half an hour almost. Will report back but leaving this here so people can try.

Uninstall the latest windows update:

1 Like

Recently, I have noticed more and more posts in this thread describing CTDs while flying 3rd party aircraft. I can only assume that the number of people experiencing CTDs that are actually flying the default aircraft with default liveries and default sceneries is getting slim.

Please remember that this thread is dedicated to…

“VCRUNTIME140.dll Error” using ONLY the default sim.

Before posting here, PLEASE remove ALL mods and add-on content to determine if the failure is with the base sim and NOT related to any add-on.

To discuss issues with add-ons and 3rd party software you should always start at the vendors website.

1 Like

Does this include addons from the marketplace that have apparently been vetted before release? :thinking:

this can cause issues, but in focus is the community folder as also mentioned in issue template:

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.

I’m sorry but if these have been vetted and approved for release on the marketplace why the hell should we have to do more testing for them? Why should people have to deprive themselves of a product they’ve paid for purely because of Asobo’s incompetence?

2 Likes

@SirBloke,
Per the guidelines of all subcategories in #bugs-and-issues we only want topics/posts related to the base MSFS. The developers can not control 3rd Party coding. If the base sim works without the additional add-ons, then contact that 3rd Party. If the base sim still causes issues, then this is what the developers need to know.

Yup. 'Cause they can conflict with another mod you may have installed. Or the sim was updated but the add-on developer hasn’t updated their software yet. Both can result in CTD that is not in any way the fault of the sim.

What makes you think the adds in the market are vetted? They worked on the developers machine and maybe on an Asobo machine, but there has never been a guarantee that it will run on your machine. That is why there is a separate forum category for adds.

This is the initial release for FlyingIron’s Spitfire IX and so for now it is available only from their website webstore. If you want to buy it today, this is the only way to get it. According to FlyingIron, the aircraft has been submitted to SimMarket.com and the MSFS Marketplace. The former will take about 2-4 weeks while the latter typically takes 4-7 weeks for approval

Are you telling me this is untrue and all addons are untested? If these are tested and validated by Asobo/MS before going on sale then they should be compatible surely?

Addons or not MSFS doesn’t work so doesn’t make any difference to me, I’m just trying to make others aware of the smokescreens being put in place trying to deflect blame from the developers, onto users, 3rd party developers or anybody else that might get in the way.

1 Like

The purpose of the #bugs-and-issues categories is to discuss issues that affect the base simulator. Please do not discuss issues with third-party addons or modifications in this category. These should be filed via the developer’s preferred support method.

If you believe your issue may be caused by a third-party addon/mod, empty your community folder, restart the simulator and try to reproduce the error.

All issues caused by, or involving third-party addons/mods should be reported to the third-party developer. All issues related to the core simulator can be formally reported through Zendesk.

Hey everyone, I thought I would share some investigations I did with the sim in multiplayer and the stuttering bug. In summary if you have a different edition of MSFS than another player you will probably get a blinking nameplate AND stutters that are synced with their nameplate. Also the stutters also apply to any custom livery as well - so there’s two things going on with the stutters. Also since upgrading and adding the extra Asobo aircraft and scenery strangely enough my CTDs VCRUNTIME 140 errors have “appeared” to stop.

Anyway, see the link and maybe something in there may help you. It may or may not. Again, I’m not an employee of Asobo or a programmer just a guy who noticed something and wanted to investigate and share my findings with everyone plagued by these issues.

3 Likes

Hi all !!

No, nothing in the Community folder. With or without addons, the error persists. No systems overclock at all.

Getting the dreaded CTD when passing an exact location, every single time. No addons installed.

Takeoff from SBGO Rwy14 (Brazil) on MOSNA1A departure, with a “not very performing aircraft” (I’ve notice if you overfly the CTD location VERY high, you don’t get the error). Try with the 172. After passing GO014 waypoint, 38.4nm to NIMVA, boom, you CTD. It happens EVERYTIME.

The only noticeable difference is that a few times, let’s say 1 out of 5, the error description in event viewer is grammar.pggmod instead of VCRUNTIME140.dll

i7 4790K / RTX 3090
1.15.8.0 - MS Store Version

Thank you for your feedback. I remain convinced that the vast majority of CTDs are caused by bugs on the map.

Other than that, with your I7 4790, your RTX 3090 has a bottleneck.

thats interessting, because these error points often to a repeatable issue with the map at these position.

Hi @ZaZa747

I can confirm the map bug:

tried two times

Route : GO014 → NIMVA

image

Name der fehlerhaften Anwendung: FlightSimulator.exe, Version: 1.15.8.0, Zeitstempel: 0x00000000
Name des fehlerhaften Moduls: grammar.pggmod, Version: 76.0.0.3, Zeitstempel: 0x6062f188
Ausnahmecode: 0xc0000005

crash:
1
image
2

Time for a ZenDesk Ticket…

But as mentioned,

  • the VCRUNTIME140.dll is normaly because of another reason.