Very Bright colors and overexposed in VR

Hi all,
Is it just me or everyone else is also finding scenery using VR very bright and over exposed? I don´t know if it´s related to winter lightning effect (which usually makes light more “blueish”) or that is normal.
How can I make colours and light look more natural?
I Believe it´s a matter of light temperature, being very cold overall.

THANKS

4 Likes

No - daytime seemed normal to me. I noticed at night it was not very dark though. Like twilight. (Rift)

Since alpha testing I plead for implementing a brightness/gamma control. With VR it is even more needed.

2 Likes

I noticed that it’s brighter ( more aggressive lights) in my Pimax 5k+ than Xplane 11
Reason why I wear sunglasses with headset ( don’t judge :wink: ) and decreased the brightness in Pytool

Same for me - and here:

I don’t know if it works in VR but if you have an Nvidia graphics card, have you tried using the Nvidia Freestyle post processing filters?

I use them in non VR mode and they work very well with no noticeable performance hit.

Also here

and here

1 Like

I created a bug report - Please vote up if you support it!

4 Likes

The problem in using FreeStyle (or any similar ReShade tool) is that it is working on the back buffer and you’ll be therefore compressing the output sRGB 8bits component values. In the end, you’ll turn already clipped white into clipped light gray, and loose colour component resolution which is creating banding. Unless of course FreeStyle is capable of intercepting the render buffer which I doubt though.

Such adjustment must be done at the FS2020 Tone Mapping Shader so that the high precision (or half precision) linear component value gets adjusted prior being converted to sRGB and clipped in the [0,1] range.

1 Like

Well I don’t know the technical details of how it works but it improves things considerably in non VR mode.
It might be worth trying it to see what can be achieved in VR mode if it’s possible.

Freestyle never worked for me in VR.

1 Like

tried it myself, no go with freestyle in vr.
Recently posed the same question on here before finding this thread.
I would think its possible, i remember flyinside had a menu where you could adjust some of the settings.

Same problem, pimax 8kx. It’s some sort of sun glare effect, it’s terrible. Up voted bug report above.

Isn’t this characteristic of the Bloom setting instead? What about disabling it if not already?

I think it is the exaggerated “white out” effect especially at lower sun settings which gives this washed out color look mainly against the sun. I tried to cure it with disabling “Bloom” and in UserConfig.Opt setting ColorGrading to 0. No luck.

2 Likes

Thanks sir. I thought it was only me.

2 Likes

I think this is where people have over expectations of current VR optical hardware, especially with the cheaper headsets. Even the G2 isn’t going to give you the vivid colours and contrasts you’re used to on a flat screen. I suspect some of these bugs aren’t actually bugs but are characteristics of either a badly optimised set up or VR hardware shortcomings.

1 Like

Some other sims allow custom gamma settings, while MFS2020 doesn’t :frowning:

1 Like

Nah, I’ve got the Rift, Pimax 5k, Pimax 8kx & a Reverb G1. Been using VR exclusively in XP11, iRacing, DCS, and now MSFS 2020 since 2017. I’ll take VR over my 4k triples any day, and in titles other than MSFS, I have no such issues with washout, even when sun glare is modeled such as in DCS. This is definitely an MSFS specific anomaly, not a headset specific issue, as I’ve tried all of the above with the same results.

5 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.