VFR map causing game to completely freeze up

Every time I click on the VFR map when it is in a separate window it completely freezes up the game and it becomes entirely unresponsive until I have to kill the process

VFR map is on my second screen and starts very small so I wish to resize it, but as soon as I click any of the MSFS instruments that are on the second monitor the crash occurs. This happens 100% of the time without exception when flying the Yosemite bushtrip.

One monitor is 1440p and 165hz and the other is a basic 1080p 60hz for the monitors

Running on a Ryzen 7 5800x and RTX 3080 so surely not the hardware being unable to handle it, as my old FX 8350 and GTX 970 managed to run the game on these monitors fine

Brief description of the issue:
FS2020 just freeze when i you use the pop-up panel such as VFR map or radio and all I can do is force shutdown game

i tried…

  • run in administrator
  • stop full screen optimization
  • scan/repair game
  • update drivers
  • remove all mods

i use
Windows 10 20H2(korean lang.) / Ryzen 5600X / RTX 3070 / 32GB ram / SSD

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:

  1. in flight
  2. opne vfr or radio or checklist
  3. click pop out icon (middle in minimize and close icon)
  4. freeze

Have you found a fix at all? I get this issue 100% of the time too, and can’t figure any fix out

Oh wow really? Any help would be great as I can’t play the game at all right now as the VFR map is currently covering most of my screen and I can’t touch it without crashing…
Is it something in Nvidia control panel or the geforce overlay?

What add-ons, mods, fixes do you have installed?

None at all. I uninstalled what I had after the US update, as the ones I had installed were just scenery fixes in the USA

Can you press V to close the vfr map without it crashing?

I can close them with the shortcut but then opening them will freeze the game again. So currently I can only mess about flying with no radio/VFR etc

Try disable °use hdr° in windows display settings.

This is happening to me too after a fresh install today. If you don’t press the maximize or run the game windowed the game runs fine. As soon as you maximise a window like VFR or ATC the game crashes instantly and you have to bring up the task manage to close it.

Is the solution to use LittleNavMap with the concomitant plugin? Those that use it report some successes.

turn off HDR fixed it for me. Not a great solution but at least i know why now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.