[Video Tutorial] Fix your Digital Trim Wheel (Bravo, Logitech, Desktop Aviator, etc.) in-game speed AND precision using freeware

I did this for my own benefit and have been very happy with the results for my Trim Wheel. I decided to turn in into a Video Tutorial. I really hope this helps others who are struggling with their physical trim wheel having poor responsiveness and/or precision in the sim! I think it will help with most digital trim wheels, like the Honeycomb Bravo trim wheel, the Logitech multi-panel Trim Wheel, the Desktop Aviator 2890 trim wheel, etc.


Thank you for taking the time and recording this well explained and detailed video!

I like your approach of using freeware software!

On the weekend I will try to take some time and set it up for the Bravo.

1 Like

finally got it working, thanks. If i increase the count to say 10, would that make it input more to the trim ?

1 Like

@RankPie46356598 You got it working? Fantastic! You’re the first to report in with success after I posted the tutorial. I wasn’t 100% sure it would work for any other trim wheels. What is your trim wheel and do you see the improvement in the speed but still have the precision when you want it?

Yes, you can experiment with the count. 10 would put more input to the trim when it detects a “double tap” (when you’re trying to move in a hurry). But, the higher you make that number the longer it takes to complete the move. So, especially in VR where we have to run with a slower loop rate, it gets even more laggy. It continues to move after you stop moving your wheel. But, try different things and see what you find out! I literally just came up with this a few days ago and maybe between all of us we can come up with something even better. :slight_smile:

I have the Bravo throttle. The 2 buttons on vjoy were not auto assigned, so that was a curve thrown at me. I’ll keep working with it. Thanks again.

Yes, sorry, that was a huge oversight on my part. I already had it mapped and forgot to mention it in the video. I mentioned it in the comments, but most people won’t look there. I will add an annotation to the video with a big note about this, if I can. Thanks for the feedback.

I can confirm your settings work also for the Bravo! Works like a charm! Thank you very much!

1 Like

That is fantastic and welcome news, @maatz86! I didn’t know until now, for sure, that this would work for the Bravo! Just curious, did you try it both in 2D and VR?

Would it be possible to share the Joystick Gremlin profile file (the .xml file) that you created? I couldn’t make one for the Bravo because I didn’t know the button numbers or the specific timing. If you share your .xml file (with a link to google drive or dropbox or something like that), then other Bravo users who don’t want to or can’t do it for themselves can just install vJoy and Joystick Gremlin, use the profile you created, and then make the vJoy device assignments in the sim! They won’t have to sit through my Tutorial or go through the debugging process of getting it working!

Again, thanks for letting me know that it works. :slight_smile:

I am afraid I use the simulation in potato graphics, so 2D. I do not own any VR device so I cannot try that to be honest!

I tried to upload the profile xml which is generated by this Gremlin program, but inside the profile it also contains all the other devices which I have connected to my computer, along with their internal device IDs. Ranging from the Alpha, to the rudder Pedals etc.
So I do not know if anybody else then could actually use and simply import this profile file to start off directly?

Oh, good point. I didn’t realize until this evening that the Joystick Gremlin profile has all the other devices in it. It shouldn’t matter, since you didn’t remap any of the others, but it may mean someone else can’t just load that profile. There may be a way to export just the important parts but I don’t know enough yet to know for sure. Thanks, anyway, for reporting that it worked with your Bravo! That should give Bravo users who don’t mind going through the tutorial motivation to do it for themselves. :slight_smile:

1 Like

Got my Bravo today, took it out for a spin, and immediately hit the issue with the Trim wheel being extremely insensitive as you described. Applied your workaround an hour ago, with the same settings, and have been a happy camper since. I did have to also unbind the trimwheel from the bravo itself in the sim, as it would otherwise register input from the vjoy buttons and from the bravo directly, but after i did that, it was smooth sailing!

Thanks a lot for the guide!

1 Like

@DeejayBarney It’s great to hear another success story.

Leaving the bindings for the wheel itself is how you can get the “slow”, “precise” movement, when you are zeroing in on the proper trim and don’t want it accelerated. If you move the wheel very slowly, it will not trigger the macro and will not send any button pressed via vJoy. If you leave the bindings for the wheel, then you’ll get the slow button presses from it in this case, which I think is ideally what you want (to have movement with no acceleration when you are trying to be precise). And, when you are trying to go fast, the extra button presses from the wheel itself helps with the acceleration! I would recommend putting that binding back, but it’s up to you. If it doesn’t work that way, let me know I’ll try to understand why.

Thanks again for checking in with your success story! :slight_smile:

I finally had time to try your trim workaround.
I fly in VR and I could not get my Bravo to work with Vjoy and Joystick Gremlin. I watched your video a number of times to make sure I wasn’t missing something, assigned Vjoy buttons 1 and 2 in the sim, and still no change.
Your solution was brilliant I thought and thanks for doing that video.

1 Like

@BassMarmot48037 So, did you get it figured out? Is it working for you now?

Hey Mike. Thanks for the reply.
Nope, I just checked again and it’s still not working in VR like it did in your video. I’ve taken some screenshots of my settings if you want to take a look and see if I’ve done something wrong.

Yes, I would definitely like to try to help you figure out why it’s not working. Post your screenshots here and we’ll see if we can figure it out. We may need to switch over to private messages but we’ll be sure to post the resolution here, if we can find it, for the benefit of others.

Some questions:

  1. When you use the input viewer in Joystick Gremlin to watch the button presses, do you see them both for your Bravo and for the vJoy Device?
  2. When you bring up the vJoy Device control settings in the sim, do you see any activity on buttons 1 or 2 when you spin the trim wheel?
  3. Are you sure the Joystick Gremlin profile is active (green icon)?
  4. Have you tried it in 2D to see if it seems to work better when not in VR?


Before I start sending screenshots I’ll go ahead and answer your questions…

  1. I’m seeing the button presses on my Bravo but not one the vJoy device in the input viewer in Joystick Gremlin.
  2. vJoy activity in the sim control settings isn’t apparent when I turn the trim wheel, and again, I can see movement on my Bravo.
  3. The Joystick Gremlin profile is showing a green icon on both.
  4. I just tried turning the trim wheel in 2D and there is no discernable difference in speed.

I guess it’s good that you’re not seeing activity on the vJoy Device on the input viewer or in the sim. That would explain why you aren’t seeing any speed increase and also why it doesn’t work in 2D either.

Are you sure you did the macros on the proper Bravo buttons? I don’t know which buttons are the trim up/down buttons on the Bravo.

Maybe I should send you my screenshots of the settings. I’m sure it’s probably something I messed up since you got it to work on your system. I’m still amazed that you figured out a solution while Asobo either can’t or is too busy with other things.

I wouldn’t say that I proved that this can work on the Bravo trim wheel, but @maatz86 and @DeejayBarney both got it working for the Bravo trim wheel, in 2D at least, so we know it can work.

Everything looks good to me except that for VR you should also change the Pause in the macro (between the vjoy button pressed and released commands) to 0.0400 s. You left yours at 0.0200 s , which could make it too fast when in VR but should still show activity on the vJoy device in the input viewer and should still produce results in 2D at least.

I assume you have closed and restarted Joystick Gremlin (and perhaps even rebooted the PC)? I have had Joystick Gremlin fail to work after I had been editing things and had to close it and restart it. Rebooting might be worth a shot too. Just make sure you re-enable the Joystick Gremlin profile before testing. If you can’t see the activity on the vJoy device buttons in the Joystick Gremlin input viewer then there’s no reason to even try it in the sim. We need to figure out why that’s not happening and I don’t see the reason in your screen shots.

Oh, and also, I think this can’t be it because you see the vJoy device in Joystick Gremlin and in the sim, but go to your windows start menu and run the “configure vjoy” app that is in the “vjoy” folder on the start menu. Make sure that the “Enable vJoy” box is ticked:


@maatz86 and @DeejayBarney Can you look at @BassMarmot48037’s screen shots and see if you can spot why they are not seeing any activity on the vJoy device in the Joystick Gremlin input viewer or in the sim? Did you use 0.20 as your double-tap delay? Even if that wasn’t quite the best value for the Bravo trim wheel, it sill shouldn’t prevent vJoy button presses from showing up in the input viewer, but I’m grasping at straws here.