Virtual cockpit yoke is moving the wrong way - Isafjordur landing challenge

Do you have any add-ons in your Community folder? If yes, please remove and retest before posting.
Yes, removed add-ons and restarted FS. No difference

Are you using Developer Mode or made changes in it?

Brief description of the issue:
Virtual cockpit yoke is moving the wrong way.

Provide Screenshot(s)/video(s) of the issue encountered:

Detail steps to reproduce the issue encountered:
During the Isafjordur landing challenge I steer right (which works fine), however the virtual yoke inside the Cessna 208 is turning the other way. So left is right, and right is left.

The controller is working fine were left is still left, and right is still right, only the cockpit in VR is showing it the other way around.

PC specs for those who want to assist (if not entered in your profile)
AMD 3700
MSI 3800

Build Version # when you first started experiencing this issue:
WU5 (latest version)

Are you on the Steam or Microsoft Store version?

Did you submit this to Zendesk? If so, what is your ticket #?

It starts with the autopilot on. Make that your first keystroke/button when you start and you’ll be fine.

tried to disconnect, no result for me.

You can’t disengage the AP immediately when starting a flight in the air. It takes a few seconds.

Furthermore there’s still an annoying bug with the AP indication:

Switching the AP OFF by clicking on the AP switch with the mouse, correctly disengages the AP.
The green AP ON message nevertheless stays on for 5sec.
After that, the message turns yellow and remains visible. No way to make it disappear.

IRL, the AP message should immediately turn yellow upon disengaging the AP.
Depending on the aircraft the yellow AP should either remain steady or flash on for 5sec,
or flash yellow for 5sec, then disappear.

Using the keyboard command and/or a joystick button the green AP ON message stays on forever, regardless if the AP is ON or OFF.

I have AP on/off mapped to a button on my flight stick. That’s the first think I press as soon as the challenge starts. And like every other plane, the indication I get is a red AP indicator that never goes out - but at least I’m able to complete the landing with no other issues than my skill (or lack thereof…).

same issue here :

Thanx for taking the time to upload a screenshot. This makes troubleshooting way easier :slight_smile:

It confirms that the AP is enaged and countering your manual input.
(The white vertical bar next to the AP button)

There’s even a green AP message on the PFD, but unfortunately there’s still a bug which prevents a correct indication of the AP state.


(2021-06-20) Just updated “The Nordics” and try this landing challenge at ISAFJÖRDUR and yes, not only the yoke turns in the opposite direction, the elevator trim is also making weird things.

Of course, as long as the AP is engaged!


I have an other one with my Thrustmaster sett… The cockpit view moves 90 degrees upward… when reset the view, it slowly starts moving upward… rudders and all seems to me working…

That happened to me one time when I had my drone controller (Xbox controller) plugged in and it was laying upside down on one of the sticks.

I have the Thrustmaster sett, and it worked fine before the update. They are not blocked or upside down. But i will se if i can find a driver update or so.

Please keep posts on topic and assisting each other. Not attacking each other. Thank you.

you need to setup a deadzone probably.

If disconnecting the AP doesn’t let you fly the approach, then there is something else going on.