VKB Rudder pedals reacting violently

Not sure if my problem is related to the SU5 update but my VKB rudder pedals are no longer as smooth as they were. All tests show that the pedals react smoothly to my foot pressure but when in an aircraft the pedal reaction is violent with increased pressure on the pedals. The aircraft yaws violently. I have tried all settings of sensitivity with no improvement.
Any ideas will be gratefully recieved. Thanks

I also have the VKB pedals and am struggling to find a good set of settings, tried various sensitivity settings but the aircraft reacts violently to even slight pedal movements. This was happening before SU5. Not sure what to do to be honest.

Not sure if SU5 is to blame but my rudder pedals have been silky smooth until now.
Update. Disabled the rudder pedals and reconnected but that made no difference.
The sim is now unflyable.

Hmm, not having that problem.

Are you sure you’ve properly calibrated your gear in VKB Device CFG? Running the latest firmware?

Are you sure they aren’t mapped to a keypress slot, and not an axis in fs2020 options?

Dumb questions, I know. But they need to be asked.

In FS2020 options, I’m sure you’ve tried setting up a shallow sensitivity curve like this,

I wish I had more answers for you. One possible option is to use FSUPIC7 to setup your controllers.

On an unrelated note, do you have virtual toe brakes working?

I have a VKB Gunfighter MKIII with Modern Combat Pro grip, VKB pedals, and they are all plugged into the same black box. I use this profile to get virtual toe brakes working with my rudder pedals in FS2020.
http://forum.vkb-sim.pro/viewtopic.php?f=26&t=4513&p=42617&hilit=vkb+toe+brakes+fs2020#top

For some reason I had mapped my rudder pedals to Rudder right and left axis instead of just Rudder axis. Now smooth again. Thanks for your info WaldoP3pper. Hope this helps you PridedThread577.

Thanks for the heads up I will check my assignments. Think I may also have used left and right axis.

Let us know if this works for you.

Hi, as I thought I had the pedals assigned to left and right axis not rudder axis. Not sure what the difference is though as the rudder did move. What sensitivity settings do you use ? It has improved but isn’t as controllable as I would like on take off but is ok taxiing . I don’t use virtual toe brakes.
Thanks for your help as I wanted to fix this. The pedals themselves are good quality.

I love it when a plan comes together.

Edit: Regarding takeoffs, FS2020 is a bit off in that area. But, it’s important to take note of real life factors which influence this. I’m not an expert, but

1)A control surface cannot be effective until it has sufficient airflow.

2)Spiraling Slipstream. The rotation of a propeller blade throws off a swirling vortex of air which travels down the length of the fuselage due to the propellor’s slipstream, that spiraling air impinges on the vertical stabilizer and rudder assembly. This creates a strong yaw factor which increases exponentially as you increase propeller thrust.

3)Propeller torque and gyroscopic precession. A force imparted onto a rotating mass is felt at a point 90 degrees prior to that point. In this case, the landing gear is a component.

4)P-Factor. A propeller’s thrust moves off center as the airframe’s angle of attack increases. The angle of attack of a blade moving downwards is greater than the aoa of the blade moving upwards. Furthermore, as the aoa increases the blade moving downward will have greater forward speed than the blade moving upwards.

4)Tail wheel locked / vs unlocked. Tail wheel is not effective, unless it is locked and in firm contact with the ground.

So in short, be sure to lock the tail wheel, keep some back pressure on the stick, advance the throttle smoothly and slowly to avoid abrupt forces, and don’t let the tail wheel lift until you have enough airspeed to establish rudder authority.

Thanks for the reply. What sensitivity do you use ? I have tried different settings but cant decide on the best one.

I’ll have to check when I get home.