VR and Turbulance

I cannot fly in VR anymore. After the latest patch turbunace effects cannot be disabled. It virtually makes me sick. I tried removing the wind layer with no effect or betterment in this matter. Any help much appreciated.

2 Likes

Dampen it using OpemXR toolkit

1 Like

how can i change the Setup no Turbulenzen?

It smooths motion sensitivity

1 Like

No it does not…that is to do with the camera sake in VR headsets, nothing to do with turbulance which is now enabled by default even with clear skyes.

Yes good question. This issue needs addressing!

Some flights are indeed unbearable in VR right now. The way turbulence is simulated is totally wrong.
The plane starts rotating around its center of gravity along the wing axis. Up down up down like a spring.
As if they are just rotating the scenery instead of the plane.

2 Likes

Things got messed up definitely since the last patch.

If you are using an HP G2, make sure is set to run at 90 MHZ. 60 MHZ can make most people sick.

I use the G2 in 90Hz and with Motion Repro on. This helps a lot, without Motion Reprojection (MR) i also got sick. But with MR on, i felt it was much more realistic in the C172 and i wish it stays this way or for others gets an option to disable turbulence.

The other thing you can do is to fly in the morning in winter, there is less or no turbulence.
Hope this helps!

1 Like

This has been an issue forever. We had a request going to add a buffer to head movement during turbulence but it has not been implemented. Someone needs to write a mod to fix it.

Once again this is a problem since SU9 for me. I used to delete the wind layer in any cloud configugation chosen and things would settle quite nicely. Something has changed now and this trick is not working anymore. Shame, as I have to fly less due to nausea.