VR broken after changing PC resolution settings

:wave: Thank you for using the Bug section, using templates provided will greatly help the team reproducing the issue and ease the process of fixing it.

Are you using Developer Mode or made changes in it?


Have you disabled/removed all your mods and addons?


Brief description of the issue:

Ok, so this started with me having the very high resolution, and hence text on VR toolbar windows, as described in another thread here. A proposed fix was to change the PC resolution in MSFS graphics settings. I did this, and for some reason that broke VR for me. I could enter VR but after about 5-10sec the frame headset would start to shake almost like it’s loosing tracking. This reset every time I entered a different menu (for example going from main menu to settings would “fix” it for another 5-10sec before it became unstable again.) The tracking was solid in all other games so this was a bug with MSFS not a tracking issue with the headset. I tried to reset the changes I made but nothing worked. Same issue. Then disabled all mods, reinstalled Pimax software, reinstalled SteamVR and OpenXR toolkit/PimaxXR/OpenComposite. Not thing helped.

I the reinstalled MSFS from scratch, and now then I enter VR the game immediately crashes if I use SteamVR. If I use OpenXR it works (however can’t acces the OpenXR Toolkit menu for some reason…) but my frame rate is around 5fps in the menu or in-game. This only happens in MSFS. Tried to change settings and disable HAGS, but still same issue.

Lost at what to do now except a complete Win11 reinstall….

RTX4090, 5800x3d and 32GB DDR4. Latest Win11 updates and GeForce drivers updated.

Provide Screenshot(s)/video(s) of the issue encountered:

Detailed steps to reproduce the issue encountered:

Changed resolution in MSFS PC settings

PC specs and/or peripheral set up if relevant:

Pimax 8kx, RTX4090, 5800x3d, 32GB DDR4, 2TB m.2, Win11.

Build Version # when you first started experiencing this issue:


:loudspeaker: For anyone who wants to contribute on this issue, Click on the button below to use this template:

Do you have the same issue if you follow the OP’s steps to reproduce it?

Provide extra information to complete the original description of the issue:

If relevant, provide additional screenshots/video:

Found the solution