VR Controller support is missing. Please add in addition to 3D mouse

Why? What does internet say? As much as I’d love to see hand tracking, I haven’t seen a single mainstream PC VR HMD that has it implemented and working in any mainstream PC game. Why should we expect it in MSFS? I think you’re just setting yourself for disappointment. I suspect the hardware isn’t build for this and camera passthrough that gets to PC for processing isn’t present, or is too bad to use. That’s why the only mainstream HMD that has hand tracking (in theory, though it wasn’t widely accepted) is Oculus Quest, because it has on-board CPU that has access to cameras feed. Anyway, I’d love to be mistaken, but I don’t expect hand-tracking without external cameras etc. any time soon on PCVR. I’m afraid HMD has to be designed with hand tracking in mind - maybe in near future…

1 Like

Although i haven’t personally used it, i hear there’s a 737 mod for Xplane that implements VR controllers really well. Maybe not VTOL VR level interaction but a certain step in the right direction. So the people that gush over this mod say.

But that’s like literally it as far as i’m concerned. DCS does have vr controller support but it’s janky…

I was talking specifically about hand tracking, responding to another remark about hand tracking, not just VR controller support. Does X-Plane support hand tracking? You just said it supports “VR controllers”, which I do actually show in video in my main post above.

There is some Quest games, ie: Top 10 Best Oculus Quest Hand Tracking Games & Apps

But to have a proper hand tracking system, you need to have a game that’d use it well. Most of the games are more hand tracking experiences than real games unfortunately.

I think Flight Simulator would be a perfect candidate. :pray:

Ah, that’s exactly what I was talking about: those are Quest games, they run on internal Quest CPU, not on PC. Quest CPU has access to its cameras and a hand tracking API. Even when you play the same Quest as PCVR - there is no hand tracking games on PC, as far as I know. I don’t think that camera data is even passed to PC at all. That’s why hand tracking is only available on Quest - because of its internal CPU that’s both powerful enough to process hand tracking AND has access to camera’s feed. It’s not looking like this will happen on PCVR any time soon, unless it involves a separate external camera or cameras to manage the video feed for PC to process.

Oh sorry, it’s true that the linked article was only about Quest native games.
But yes, there is. Blade and Sorcery for example is a PCVR game that uses hand tracking.

I didn’t know that. I looked it up. Apparently it’s a kind of a hack: “Hand tracking works with blade and sorcery through virtual desktop”, so it uses a 3rd party app, and it’s only for Quest anyway. Apparently the app manages to pass through the hand tracking data from Quest. Not applicable to any other HMDs like G2 then. Best case scenario is Quest support, but because it’s not even native to Quest official flow, I very much doubt Asobo would even try to implement it…

Interesting, I didn’t know that.
Well in that case it won’t happen until Oculus gives us native hand tracking support for PCVR games indeed.

oh hand tracking like what the quest 2 got n stuff. my bad dude lol

add controller support!

2 Likes

Is SU 7 available as beta somehow? I heard beta testing mentioned before, and I would love to test out this feature.

Nope not yet. The only test right now if for the Reno Races.

SU7 Update

Well, the controller support is out, and it’s not a good job, unfortunately. The sim is completely grounded in VR after the SU7 update. Unplayable. And the controller support is very rudimentary and worse than older sims, and has introduced the bugs that killed the VR experience entirely. As updating is not optional, for most if not all VR users Asobo just killed the sim, period. Such bugs need to be figured out by QA and fixed before releasing a mandated update and killing the sim. It took me all of 15 minutes to see them all. What is their QA doing? Is there any QA for VR at all?

These are my observations from the first short session with SU7:

Good:

  • Laser and direct control are working.
  • Rotational controls are working (kind of).
  • Controller image is small, unobtrusive and tasteful
  • There is haptic feedback when you touch the control

Bad:

  • Huge FPS drop!!! I have a high-end PC - Ryzen 9 5900X / RTX3080 / 64Gb RAM / HP Reverb G2 - and from “barely adequate” on mostly medium settings at WMR OpenXR rendering at 70% and game render scale at 100% TAA it got to the vomit-comet on the same settings as before, unable to maintain even 22.5FPS anymore (which it was easily maintaining before), so motion reprojection falls apart. A lot of stuttering that weren’t there with this settings before. Any lower settings and it becomes too blurry to enjoy. The sim should get more optimized with updates, not less!
  • VR Menu can be triggered but is often unreachable, and even when it is reachable - its icons usually can’t be clicked. It worked for me for a minute somehow, but then I couldn’t press any of the VR menu icons and no matter what I tried I couldn’t open any menus.
  • Rotational controls are terrible: no matter how slowly you try to turn your controller, heading jumps by 20-30 degrees at a time, and all rotational controls jump by a huge margins. It’s impossible to tune anything to any degree of accuracy at all. Come on, X-Plane did it right in 2017!
  • Rotational controls do not click, there is no haptic feedback on rotation “clicks” which is so great in X-Plane. You hear the sounds, but feel no encoder clicks. Why, it’s free and easy to code this, has anyone thought through the VR implementation, compared to existing VR sims?
  • There is no haptic on flipping switches, as far as I noticed. Nothing happens after haptic feedback when flipping the switch.
  • Yoke can’t be hidden anymore, and switches obscured by the yoke can’t be easily manipulated via laser either. The controller tends to snap to the yoke instead, and I have a hardware yoke, I need to access switches, not steer the plane with a laser! But I can’t. There should be an option to disable yoke control, so laser would go through to operate switches behind the yoke.
  • I don’t think it’s possible to change the controller button assignment, at least I haven’t found a way to do that. A button opens the (unusable) VR menu, B button triggers the laser. Menu button doesn’t do at all, instead of triggering menu. Grab button activates the controller (instead of it being tracked constantly when moving) and there’s no way to reassign those that I can see.
  • Controller doesn’t appear by itself, it has to be triggered by pressing a grab button. That adds a completely unnecessary extra step every time you need to adjust something, if you haven’t used a controller for a minute. Every time!
  • There’s no reason to hide the controller, it should always be present, as long as it’s tracking. If it’s on your lap or on the table in front of you - the ghosted image should be there so you can grab it easily. Instead it disappears completely, very quickly, without ability to adjust the timeout or its behavior.
  • I have a very strange joystick-related glitch, the button assigned to something else now changes the view to external camera, in parallel with what’s it supposed to do. Very strange. It does 2 actions at once - what I had mapped AND jumping the camera.

I wonder what kind of QA can let it all through at this state? Beside the FPS decrease, the VR controllers are barely usable and can’t adjust anything to any degree of accuracy, nor can they open menus. I have waited for this for almost a year, since VR was introduced without controller support. But this is a whole lot worse than what X-Plane has. I was expecting the functionality to be at least as good, if not better, considering Asobo’s resources. But it’s much worse… I hope the hotfix is coming, but any kind of QA testing should have exposed all those issues. I don’t understand how it was possible to release it like that…

3 Likes

Yep exactly. I can add, if using an Xbox controller (logged already):
Aiming at an instrument and moving the right stick moves the VR view
left/right/up/down and changes the 0,0 reset view.

I reported this already and I still don’t know if this is a bug or not but I like this “feature” :
The center of the head can aim at instruments (sometimes the white dot appears, most of the time it doesn’t) and from there, we can press A to lock on the instrument, use the right stick to change its behavior and then press B to unlock.
BUT the labels and a big eye icon are buggy and in the way sometimes.
This is 1000% easier to use than the completely unusable VR controllers.
VR is definitely NOT the devs or QA priority.
Let’s see how it evolves.

And I’m glad I’m not the only one with a huge fps decrease overall.

I will also add the following issues I have noticed that have made flying it with VR not what I thought.

  • Cannot “Grab” the yokes, throttles or other surface controls as experienced in XP.
    In XP I enjoy the fact that you actually have to grab the controls using the lower buttons of the touch controller that your third finger and pinky squeeze. Then having to maintain this grab in order to use the control as if you’re actually holding the yoke in your hand.

  • Unable to grab both throttles or all throttles (on multi engine aircraft) at the same time.
    It would only highlight one throttle handle at a time making synchronized movement impossible.

  • Only one touch controller is active at a time as the grab or manipulate controller as opposed to both at the same time.
    In XP, you can grab and hold the yoke and manipulate it WHILE manipulating the throttles with the other controller.

  • Switch selection is not based on movement of the switch, but rather like a mouse click.
    In XP you can click on a switch with the controller but nothing will happen to that switch unless you MOVE your hand in the direction you want the switch to go making it mimic you actually having to flip a switch.

I know there’s a lot of comparison to XP here and some can say “this is not XP” and no it’s not, but seriously. XP had this figured out in 2017 like mentioned above and they are leading this part of the flight simulation world hands down. They are the baseline for others to at least match and try to exceed when it comes to VR functionality.

I would highly suggest that Asobo and the developers at FS2020 take the time to sit down and play around with XP’s VR functionality and ability to control and manipulate the aircraft’s controls and switches and then see where they need to be with FS2020 because right now as Roman said, the sim is grounded for me as well. between the huge FPS drop, and the utter disappointment with VR Touch Control Support (which we waited patiently for) I have to decide if I want to keep flying FS2020 using an actual controller, or switch back to XP for now where at least the functionality coupled with ZIBO’s 737 actually gives you the most realistic feel of flying a large commercial aircraft. Asobo, you had me so pumped for SU7, but I can only hope that this is the early stages of what hopefully will be future improvements.

3 Likes

Any way to get past the ‘press space to center view’ when switching to VR? It defeats the point of having controller support for wireless users as a benefit of wireless is running the Sim away from the computer itself.

I mapped it to my yoke button with a modifier, i.e. I have to press 2 buttons together to center the view. So I can still use those buttons separately for other functions, and won’t recenter accidentally.

I use Voice Attack and say “Center View”. I find voice commands great for adjusting my position in the seat without having to use any buttons.

I do the same for “move seat forward” etc.