VR - Focus broken

Before Sim Update 5 (I think it’s broken since then) I was able to zoom into where the mouse cursor is by using the “VR - Focus” keybinding. It stopped working.

Does anyone else have this problem? Is there a workaround?

Thank you!

It works for me. Is your binding still setup?

I had an unused button on my hotas I set for VR focus. It’s nice to be able to glance down and zoom without hunting for my mouse on the table then placing the cursor where I need it. Now I look and zoom. Makes me feel like robocop :slight_smile:

1 Like

It doesn’t zoom where the mouse cursor is for me. It zooms where I’m looking.

Ok, wow, so I will try to reset everything to defaults and see if that helps.

Ok, I’m going to solve:

This only happens with some™ aircraft.
Happened here with the payware Piper Seneca V, and the Cessna 172 iirc.
Works fine with the TBM 930, and the XCub.
Others untested so far.

Hoping it gets fixed.

Certain addon planes are not fully VR compatible. Meaning the zooming isn’t there. The default planes are compatible, so you may have an issue if some stock planes work and others don’t.

1 Like

Sorry about opening up an old thread, but I simply can’t get the VR Focus (aka VR zoom) to work, even in default aircraft.

I’ve set all mappings back to the default settings, so the right mouse button, if I’m understanding it correctly, should zoom in on where I’m looking/the mouse pointer.

I’ve been without it for a while, but now that my eyes and my Rift headset are getting older, I need all the help i can get to read the instruments. :slight_smile:

1 Like

I think it’s more where you are looking than anything to do with the mouse pointer. However, there is some kind of bug with focus getting stuck. Sometimes the focus won’t release for me unless I move the mouse.

I have it mapped to the ~ button and that also bound using Voice Attack. So I often use it without any mouse. It can be useful for looking out the front window or co-pilot window.

Sometimes the focus also won’t turn on, but is more likely to get stuck in the on position for me.

It simply doesn’t work for me anymore, although i fondly remember it working, at least in the early days of VR in the alpha.

I’ve tried emptying my community folder, changing various graphics and camera settings and clearing any mappings that might be conflicting with my right mouse button. It’s not the mouse by the way, as i have also tried mapping keyboard keys and controller switches, again with no joy.

I suppose it might be something to do with the oculus drivers, so it might be worth me giving steam vr a bash, if i can remember how to do that. :slight_smile:

\o/\o/\o/

It would appear, from a more detailed search of the forum, that someone else has had and solved this issue. Their solution has also solved it for me.

There is a setting in the Camera section of General Options called ‘HOME COCKPIT MODE’ and having set to ON appears to prevent VR FOCUS from working. I don’t remember how, but I had somehow got that setting and changing it back to OFF has solved my issue.

Also, some 3rd party airplanes don’t implement it.

I’ve also noticed it does not work to turn on or off unless I have the mouse cursor showing.

With the default binding on the mouse this usually works okay. But it should not have a mouse dependency. Just because you want to focus on something doesn’t mean you need to be using a mouse.

Well with VR you can always just lean in and get a closer look, but I now have countless cranial contusions as a result of forgetting that my desk and monitors don’t understand that they don’t exist in the virtual world. :wink: