VR has completely stopped working on my Index

After the latest update, my game has totally stopped working in VR. It was previously working fine but now every time I try to go into VR, it’s acting like my Index isn’t detected. I can see on my monitor that the game switches to VR mode but the headset doesn’t enter the game and no tracking is detected.

Has anyone encountered this before? I’ve tried verifying my files, different branches on SteamVR, updating my drivers, and launching VR before/after the game. I’m at a loss here and any help is greatly appreciated.

I have CTD when in DX 12 when switching to VR. No issues with DX11.

i cant play in vr any more sense the newest up date jan 6 2022 now all the game does in vr goes to 16 gigs of ram all the way beyond 32 gigs of ram with a massave mem leak. and hard crashes my pc with an erroe 0x0 canot write memory my spec are as following./ win 11 DX12 , Asues Strix x570 latest bios , Trident Z Neo 2 x 16 gig CL16 , AMD Ryzen 3950x 16 core MSI X TRIO Gameing , Rtx 3090 flashed latest v bios and drivers resizeable bar enabled i mean i know this game doesnt support win 11 but i havent had any problem running brfore on win 11 till this update and no its too late i canot roll back to win 10 hopefully this will get resolved soon i mean that are forceing ppl to use win 11 why not make it compatable and also i am useing valve index also

I’m having the same problem since updating to SU8

I have the exact same problem.

So far I have:

  • Reinstalled Windows (10)
  • Reinstalled Steam VR
  • Reinstalled Steam

Nothing seems to works. My best guess is somehow the OpenXR runtime is not communicating correctly. For those wondering this is what it looks like:

From FS2020:

When I move the headset nothing happens in FS2020

The webconsole log from the moment I enable VR in FS2020
go to pastebin[dot]com/KSrwyLzH

My Specs:
MSI GTX 2070 Super (latest drivers but I have issues since January like OP)
MSI Gaming Plus B450 (latest BIOS)
AMD Ryzen 5 3600
48GB RAM (Same problem with 16 and 32GB)

Any help or suggestion would be appreciated. I know something is not quite right as I not only having issue with FS2020: AGOS, Until You fall, ((The black screen fix beta worked for me), Myst…

Stupid rules from the forum don’t let me post more than one media per post…

From the Headset:

Utter Darkness but movement are tracked correctly

Getting the same with my Pimax so this doesn’t seem to be an isolated issue. I think something broke with WMR in MSFS based on my research.

Just check in SteamVR settings and put NO in “pause the headset when idle”.
I had the same problem and now everything’s ok.
Sorry for my english (i’m french).
In french is "mettre le casque en pause quand il est inactif " if you can find a better translation.
Have a good day

Salut @Skyginer ,

Merci beaucoup d’avoir pris le temps de répondre.
Malheureusement cela n’a pas fonctionné pour moi.

For the non french speaking folks:
I toggled off the “Pause VR when headset is idle” but I’m still experiencing the same issue.
I will update to the latest Nvidia driver and if it fix the issue I will keep you posted.

I have the same problem. It’s because of the Steam VR tool. The new version 1.22.11 is incompatible with MSFS. I am now using the older Build for Linux users. This works very well, even with some other games. The new DX12 beta in MSFS is also causing problems. Using the DX11, is better. Greeting metzi95

I have a MS FSMS package and a Quest 2 … Since some months I do not succeed in using VR either with a cable or with Oculus link.

Having the same issue. VR view shows on desktop screen but not headset. Valve Index, SteamVR 1.22.13.

has anyone found a fix for this yet. my vr works when i look straight up or down but not straight ahead. goes black in cockpit same issue in main menu. no issues on other vr titles including il 2 and DCS so this is a msfs issue not the headset. also im on valve index so i cant use wmr or openxr as far as i know i use steam vr