VR Head Movement Is...Strange

I have a slight problem in VR that I can’t seem to find a solution to, or others describing a similar issue.

The best way I can describe it is that when I slightly tilt my head up, the cockpit itself feels like it’s slightly moving down independent of the view. Same when looking left to right, or right to left. It’s like there is a slight translation of the camera in the opposite direction that is not tied to the headset movement.

It’s just enough to make it uncomfortable. I have not really found anyone else describing this problem. It doesn’t seem to change depending on framerate or graphic settings. OpenXR Toolkit hasn’t helped. That said, I can’t truly rule out if it’s just a performance issue.

Does anyone else know what I’m describing or how to fix it? Any help is appreciated!

i7-10700
RTX 2060 Super
Quest 2
SU9
DX11

Are you on steam vr? If so, i had similar issues a while back a go.
What i did was i deleted steam vr app & reinstalled again, that solved my issue. I hope it works for you.
Give it a try

1 Like

There’s a lot of is experiencing a “tracking like” issue that we’ve seem to come to the term “judder” when using DX12 and NIS or FSR in toolkit. You can find some threads by searching “judder”.

Are you using DX12? Are you in SU9 or SU10?

We only see this using DX12, DX11 is fine.

Win 11
SU10 Beta
RT5700XT
R7 3700

1 Like

Sounds like the problem I had a little while ago. Clearing out the Environmental Data in the Mixed Reality/Environment settings fixed the problem.

2 Likes

R U able to run DX12 using NIS or FSR?

Thanks for the replies so far.

I’m currently on a fresh install of SU9. I’m using DX11.

@SamuraiSax can you point me to where the “Mixed Reality/Environment” are located, please? Not sure if that’s a sim setting, directory, or config file.

@jayccab I’ll try that as well. Thank you.

I don’t think that would apply to the Quest.

I’ve had my Quest 2 do that. The fix for me was to power cycle the headset. Sometimes it needs a reboot. It handles more processing in the headset compared to most other headsets.

1 Like

Yep, that’s right. I gave my advice before I read that the OP uses the Quest headset. Sorry.

1 Like

Unfortunately, this had no affect for me.

Thanks for the clarification. I’m guessing it’s just a horsepower problem. I’ve been using the AirLink method of connecting, so I’ll try it with the cable and keep playing around with the MSFS graphic settings and OpenXR.

Don’t give up, there are very knowledgeable vr pilots in the forum that will gide you to a solution to your issue.
Jay.

1 Like

Have you changed your FOV setting? If so, try resetting it back to default.

Hi,

I use a Quest 2 and have a similar spec machine to you. And I use the link cable whilst flying.

I’ve encountered a similar type of issue on rare occasions In my case, the room scale guardian seemed to be causing my glitch. As soon as I switched to a fixed/seated guardian the issue went away.

Hope that might be helpful if you haven’t already tried adjusting it.

Cheers,

Thanks for the suggestion. I always use the stationary guardian, so I don’t think that’s the issue. However, I might try moving locations and trying again. Maybe I have something in my play area that the Quest doesn’t like.

As a side note, I have since upgraded to a 3070 Ti and I feel like the issue is less apparent, although it’s still there.

If I ever completely fix the issue, I’ll report back here.

I think I know what you are talking about. It’s almost like there is a certain amount of “fish eye” effect on the “camera” being used to project the VR image for our eyes.
I have a Reverb G2, and I thought it was limited to that headset (or maybe WMR headsets in general) but interesting that you are seeing it on Oculus.
I guess I’ve got used to it over time, but I definitely experienced it.

(It’s not judder, jitter, or any other performance/fps related issue - more of a FOV-type problem)

1 Like