Vr is an even bigger mess

So, here i am. New system (i9 10900K @5ghz rtx3090 64gb ram and fs running on an nvme 2tb ssd)

Have this system for couple of days now and flying has been great so far.

Well, today i hooked up my oculus rift to this new pc to give the vr implementation a go…

What a sh*tshow. And i’m sorry but there’s just no other way to descripe this horrible mess. I allready read the forum alot before even trying and fogured chances it will fail were pretty big. But this just doesnt make any sense to me.

Since i’ve installed the oculus and tried vr for the first time i am unable to go to the general settings tab without the sim crashing to desktop.

So i skipped changing my graphic settings and just went for a flight. I hit the vr mode button. And now it’s saying me i have to press the vr center something button to recenter vr (while it was allready centered) one tip for asobo: give it a default button that we can change later. Now i had to ctr alt delete out of the sim because it wouldn let me do anything else then press tbe center vr button (wich i didn’t have because i didn’t assign one)

So i learnes from this. Started up the sim again and assigned a button. Started my flight and found myself sitting somewhere between the main gear of the aircraft. Really? I just set everything up and in every other programm the vr just put me where it should. In fs i’m unable to get in the cockpit seat. Also only up and down /left and right mocement controls are working. So i can’tgo forward or backward ( it put me all the way back in the plane so…)

Then i tried to find some solutions here and read about registry edits and messing with the oculus debug tool to get thinga working properly.

Wasnt this in beta?

Great job again asobo. But hey, how could we even expect this to be working atleast a little bit when they can’t even seem to make a simple replay system ( that should be allready available since launch to be hounest)

What a huge waste of time it was to focus on vr.
Was gonna be a 20fps slideshow anyway but still was curious about how it would look.

Back to aerofly fs2 for vr flying


So, here i am. RTX 2060. Rift V2.

Had a couple of rift issues to sort out, a few keybindings to set up, and VR works fine.


Well that’s great for you, but reading the forums it seems i’m not the only one having these major issues.

But there’s also people got it working and saying it’s great. So fair enough;)

If I can run it on my Ryzen 3700x 32gb RTX2060 you should be able to get it running on yours.

You need to set keyboard bindings for:
. Reset VR
. Launch/Stop VR
. Show control bar in VR

Rift issues were:
When seeing black stencils in your Oculus view:
Update to the latest version of the Oculus software. Their Beta Version/public test channel has the fix for this.
If that doesn’t work:
1. Go to the Oculus Debug tool (Default folder should be D:\Oculus\Support\oculus-diagnostics (or wherever installed)
2. Open the Oculus Debug Tool
3. Turn the option “Use FOV Stencil” to Off
4. Disable/enable VR in MSFS
If you see yellow, try to recenter the view.

From https://forums.flightsimulator.com/t/vr-issues-oculus-rift-s/338344/7

Also had some peripheral vision blocking going on trying to reset the view in VR, and found the solution was to go into Oculus Home, reset the view there, then go back into MSFS VR and reset view and all was good.

After that, it seems pretty good. Just break it down issue by issue and resolve each one logically, and I think you’ll get there.


Rift S here, I get those black frames to the top right of my view. I installed the beta version as instructed, frames were gone but horrible performance. Reverted to original and rather put up with the frames!

1 Like

Well, The hardware isn’t really related to this. I put it there more so people won’t ask me what pc i’m running. So everyone knows that’s not the problem.

But anyway. the whole point of my complaint was that there’s too much fiddling around to be doing before to get it running properly. I’m sure i’ll get it running eventually. But that doesn’t mean it’s not a mess.

This was in beta for a while… so things like this should really be better at release.



I had the same issues. I had to use the beta version 24 of the Rift S, (Make sure to turn on the public feature in the Oculus settings to get it to down load it. It also required a reboot after making that change) I have the latest drivers for the 3090 as well. After that I had to go into the control settings for the keyboard and make my bindings (What keys I wanted to use for VR (Reset center, toggle toolbar, etc) then she came up fine.

You and I have the same rig setup. Same Processor, RTX3090 FE, 64GB Ram, etc.

Just be patient and work through the couple of Rift Issues. Its definitely worth it. I am running my VR settings on mostly high and am getting smooth flight.

I think you will like FS2020 in VR. I enjoy it as I use it as a tool for practicing traffic pattern work for when I fly full scale. (Only single engine cessnas)

I found this forum helped with the little issues. This thread was helpful…



I had the same issues until I turned on the Oculus Beta version and it downloaded. After that the black frame had gone, I’m sat in the seat instead of under the plane and the menus are scaled and positioned correctly. I know it’d be nice to not have to read forum posts etc. to get software working but I’m happy to have to jump through this small hoop for what’s been an amazing experience so far for me.


Thanks everyone. I’m finishing up on a project today so right now i don’t have the time to get it working. Will try tonight.

As i said. I’m sure i’ll get it working properly. And i’m thankfull to have this forum so we can find solutions to this problems.

But, i still can’t get over the fact that everything around this sim has to be buggy/messy and needs some time to get things working properly. Especially when there was a beta program dedicated to vr. You would think things were different this time around!

The seat position can be adjusted up/down left/ right forward/ backwards. Just set what keys you want to use in the keyboard assignments

1 Like

Are you able to get at least 45fps with your setup? I get mostly 50 - 60 fps in high density areas like new york for example. And even 70-90 fps in rural areas. (on 1440p mixed ultra/high settings and 100%res scale) so i hoped to atleast have a stable 45fps in vr with maybe some settings down. (i’d like to keep the LOD distances at 200 if possible)

Like i said. Somehow in vr it will only let me go up/down left/right. But forward backward is not working. It works in normal screen mode. keys are binded;)

I’m taking it that you have found the VR graphics settings and the VR traffic settings? If not, they are under the respective Graphics and Traffic tabs under General and selectable, in the first field, between ‘PC’ and ‘VR’.

If you have read my post you’d notice that i am unable to go to the general settings tab because somehow the sim will CTD. Somehow this happens since i installed oculus software and tried the sim for the first time in vr mode.

Not sure if it’s related. But yesterday everything was working fine.

Working great for me on Rift S. I had to assign the necessary controls for VR recentre and camera movement, and one to switch between desktop and VR modes. Also had to run the Oculus Beta and switch off some setting to get rid of a black square. All that took about 15 minutes, but VR is working amazing now.

1 Like

Your almost there. Just go into the Oculus Folder and then the Oculus support folder, the click on debug tool and change the mask from auto or on to OFF.

Worked fine since day 1 on my i7-9700k with RTX2070 on Rift S, and even playable on my 10 years old desktop with I-can’t-remember-which-video-board, not one single crash to desktop.


Thanks I’ll give it a whirl

VR works great. You just need to know how to set up. HP Reverb g1 and no problems.




Got it running at 80% with other settings on high, some on medium and it is great. Only bug i`ve got is if I try to change weather in VR mode instant CTD.

Motherboard: Asus Rog Hero x11 wifi Z490
55" curved oled Tv, till VR arrives.
CPU: Intel i9-10900K @5.1mhz per core.
GPU: Gigabyte GeForce RTX 3090 turbo
CPU-Cooler: Liquid cooled 240mm
PSU: Kolink 1200watt Platinum
RAM: Corsair Vengeance 32GB (2x16GB) DDR4/3600mhz
M.2 NVME SSD: 1TB Samsung 970 EVO Plus
M.2 NVME SSD: 1TB Samsung 970 EVO Plus
SSD: NVME Samsung 970 EVO 500GB
5.1 logitech sound system Soundblaster Z.
Next level V3 Motion platform on GT Ultimate rig.
2 Buttkickers on race rig with 300watt earthquake amp.
VR HP Reverb G2
Sim Racing studio wind and tactile generators.
Saitek Hotas.
Alpha Honeycomb flight controls.
Thrustmaster TPR Rudder.