VR issues - Oculus Rift S

Hi Andy! Can you confirm you’ve read and wen through the workarounds here for Oculus?

1 Like

I have it working in my Oculus Rift S with two issues.

  1. I’m having to move to the center of the room because it’s not calibrating to my location when I click space bar. I’ve tried the oculus recentering but it’s not working. I think I should be able to straighten that out.

  2. My other issue is this black box with a big hole in it that I have no idea how to get rid of. Any ideas?


I’m having this exact issue with the black box.


Figured I wasn’t the only one.

Same issue, not centering to my location, and the black box upper right.


Anyone else missing the VR Graphics and VR Traffic tabs in options?

1 Like

Sorry to post again, but just want to make sure those who are having the stencil issue have tried this:

When seeing black stencils in your Oculus view:

Update to the latest version of the Oculus software. Their Beta Version/public test channel has the fix for this.

If that doesn’t work:

  1. Go to the Oculus Debug tool (Default folder should be C:\Program Files\Oculus\Support\oculus-diagnostics)
  2. Open the Oculus Debug Tool
  3. Turn the option “Use FOV Stencil” to Off
  4. Disable/enable VR in MSFS

If you see yellow, try to recenter the view.


I’ve done that. Now when I click to go VR. I have a black screen. I hear the music. But nothing visual on headset.

1 Like

Got mine working by upgrading to the Oculus Beta V24 and FPS were good!


This fixed the black stencil issue for me.

Worked for me. Thanks a lot.

1 Like

For ActiveRuntime change its value to the one that matches your platform (note: default path is shown below):

What does this mean ? and how do i find the value that matches my platform?

Im no pc wxpert


Now I’m not even sitting in the cockpit I am under the plane. I still have a split screen on my monitor. As opposed to one screen showing what I am looking at

1 Like

Try standing up. Your head will probably pop through the seat. :slight_smile:

1 Like

I have to use the arrow keys to reposition myself in the cockpit each time. Also I only hear the prop when outside the plane, once I reposition to the cockpit there is no sound.

1 Like

There’s got to be a way to get the positioning calibration to work. I can’t imagine Asobo didn’t work on this issue.

Does it seem like it’s using the center of your room as the cockpit position?

Hi! Tried this. But my Rift S headset is still not detected:

  • Having Oculus Software open
  • Fixed the registry thing with the correct patch
  • Rebooted

Tried like 5 times, says: Headset not detected ;(

All of my Rift S issues were resolved by downloading the “public test channel” in Oculus settings. Worth a try to anyone having issues.


There are no such tabs, you’re just expecting them because you watched the video while downloading the update…
In the release version you have to look inside the graphics or traffic tabs: At the top you can switch between PC and VR.


Watched a YouTube video that had them. You could have different settings for be than flat screen.