VSynch Problem / Tearing with DX12

Hey everyone,

I guess I need your help. I recently upgraded to a GeForce 4070 and I’m finally enjoying the benefits of DLSS 3 and Frame Generation. However, since these features only work under DirectX 12, I’m facing an issue where my Vsync no longer functions. I have tried adjusting the settings both within the game, through the Nvidia Control Center, and utilizing the Adaptive Sync function of my monitor, but I can’t find a setting to prevent tearing. Do you have any tips? Everything worked flawlessly under DirectX 11 (Vsync set to Fast in the Nvidia Control Center and Low Latency Mode set to Ultra).

Hardware:
AMD Ryzen 7 5800x3D
Asus GeForce 4070
32 GB Ram
Samsung Odyssey Ultra Wide DQHD Gaming Monitor C49RG94SSR @120 fps

1 Like

Hello there,
We ask that all members not use General Discussion for help, troubleshooting, bug reports, or advice questions. Your topic has been moved to a subcategory of General Discussion & Community Support.

Vsync will not currently function with frame generation no matter what settings you use. From what I understand, this is an Nvidia issue, not a sim issue. They may enable vsync in a future update to DLSS3.

Your monitor has FreeSync, though, so you could turn VRR on?

good to know, thanks! If I turn on VRR on my Monitor, should Vsync be turned off in the sim and NCP?

best,
Florian

I don’t really know, I’ve never had a monitor with VRR, but I’d assume that setting it on would either disable or cause the drivers to ignore any other settings.

I reported issues with vsync and FG back in January. The thread is marked as bug-logged but still waiting for a fix. My report was about losing the ability to force vsync in the control panel but it still applies to your case in that once FG is turned on the vsync toggle in game has no effect. Please vote if you want a fix :slight_smile:

https://forums.flightsimulator.com/t/regression-dlss3-frame-generation-with-vsync-broken-in-1-30-9/568809

By using Adaptiv Sync you are explicitely allowing tearing. If you dont want tearing use “ON”.

For me Vsync is working with DLSS 3. You just have to enable it via the nvidaia control panel. This can have to do with the fact - that the Sim itself does not recognize the frame generation, because it is done via the GPU. You would need an option to sync the sim to 50% of your original VSYNC FPS, so the GPU could make 100% VSync out of it with frame generation. SO it is just easier to let the GPU do the vsync from the begin with.

1 Like

Using a 240 Hz monitor and DX 12 enabled with frame generation I have not come across any visible tearing with a 4090. I did on my 75 Hz monitor.

I could never make that work, but I’m running old drivers; also, since I run more than one display normally, vsync in the control panel causes odd things to happen around frame rates for me. But I don’t use FG anyway, despite having a 4090. I’m less worried about pure FPS numbers than I am about smoothness and lack of stuttering. I vsync at 50% and try to get 30FPS everywhere, which I mostly manage.

I’m guessing you have a VRR capable monitor?

Yes but i am not using Gsync. I am using normal VSYNC at 60 Hz.

Thats nearly exact the same I do. My Sim is running very stable 30FPS and with enabled frame generation I got 60 FPS visible on my monitor. I recommend to make a nvidea panel profile for the SIm and cap the FPS at 60, and then VSYNC ON (either with or without adaptiv). The GPU then limits the Sim to 30 FPS exactly and provides the other 30 FPS via Frame Generation. Cheers

Unfortunately, frame rate limiting in NVCP doesn’t work if you have the game using multiple monitors. Instead, it divides up the frame rate number between the monitors. The sim vsync doesn’t have that issue.

To be honest, the difference between 30FPS and 60FPS doesn’t matter to me. Not saying I can’t see the difference - I can - but 30FPS is fine for my old eyes, as long as it’s smooth. So I’m not terribly fussed about frame-gen.

Ok, I oversaw your multimonitor sim setup, sry. I also have 2 monitors, but I only use one for the Sim itself, that is probably the difference.

1 Like

Thanks a lot for your feedback!!
I found a solution for my setup, extreme simple.

Following steps worked out really fine:

  • turn off vsync in-game
  • turn off adaptive sync on monitor
  • in Nvidia control panel just switch vsync from “fast” to “on”
  • no fps limit in ncp needed

With frame generation on I get fps between 50 and 90 with Fenix a320 and 3rd party add on scenery. No tearing at all and absolute minimum off recognizable input lag.

Just change vsync setting from fast to on in Nvidia control panel made the change when switching from dx11 to dx12. :slight_smile:

Figured this the most appropriate thread for this.

I’m in 2D on a 3090 (so no frame generation) and using VSYNC set to ‘Fast’ in Nvidia CP with DX11 it works just fine. Switch to DX12 and I have tearing which is definitely a new phenomenon because it never used to be like that.

Switching from ‘Fast’ to ‘On’ the tearing stops but the performance is more akin to the in-game VSYNC rather than the ‘Fast’ option in the CP. It would appear that ‘Fast’ doesn’t work with DX12 anymore.

It’s proper odd, and I’m not sure a) why it’s happening and b) the best solution.

On the plus side, the poor DX12 performance that prompted me to switch back to DX11 seems to have improved somewhat.